bluetooth headphones

Forum Forums Official Releases antiX-23 “Arditi del Popolo bluetooth headphones

  • This topic has 4 replies, 5 voices, and was last updated Feb 11-8:32 am by orthodox42.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #127559
    Member
    pierce.jason

      What is the most straight forward method to connect bluetooth headphones for Mic/Sound on antiX-23 base? I’ve installed bluez and blueman, but connection fails out shortly after connecting from laptop to headphones using the blueman applet.

      #127566
      Moderator
      caprea

        The most straightforward would be to install antiX23 full 64bit in this case.You need pipewire for bluetooth sound.On full 64bit it’s installed per default with the right configuration.Did you take the runit or sysvinit version?
        I got a base installation here and will install pipewire and bluetooth in the near future, will then return here and report on the steps that were necessary for bluetooth and pipewire.

        —————————————————
        These are the steps for pipewire

        sudo apt update
        sudo apt install pipewire pipewire-alsa pipewire-jack pipewire-pulse wireplumber pavucontrol gstreamer1.0-pipewire antix-pipewire-extras liblua5.3-0

        Then open the control-centre > Session > User Desktop-Session
        This will open geany with the startup file
        Go to line 23 and remove the # from the line
        pipewire-start &

        Most people need to give the volumeicon some time to start in interaction with pipewire.So go to line 26 and change the volumeicon line into
        sleep 5 && volumeicon &

        Save and close the file.Now reboot.Hopefully everything works as smoothly as it did here.
        Go to the menu > applications > Entertainment media > pavucontrol(Pulse-audio volume control) and see if it is working.
        If everythings fine you can now right click on the volumeicon in the taskbar,go to Settings.
        Under “Externel mixer” delete the desktop-default-alsamixer and write instead there pavucontrol.
        You can now achieve quickly pavucontrol with a right click on the volumeicon — Open Mixer
        ———————————

        Now to the bluetooth part

        sudo apt install bluez blueman bluetooth bluez-alsa-utils gnome-bluetooth libspa-0.2-bluetooth

        Go to control-centre > system > choose startup services
        Look if bluetooh is now mentioned there as a service, you have the option to enable it to autostart on every boot.
        During installation here I got the impression it’s better to reboot here,too.
        Then try your headphones, open blueman
        In blueman under Adapter > Adapter Settings you have to make it visible.
        Search for the head phones or if they are already shown right click on them and trust them,then right click and click on Pairing.
        Afterwards try to connect.
        Everything went well here, if you have any problems please let us know.I may also have overlooked something in the howto.

        • This reply was modified 2 months ago by caprea.
        #127844
        Member
        akaEpitaph

          Thanks @caprea for this how-to. It worked perfectly and saved me a lot of grief. antiX-23 base, sysvinit I think. Thanks also to @pierce.jason for starting this thread.

          • This reply was modified 1 month, 4 weeks ago by akaEpitaph.
          • This reply was modified 1 month, 4 weeks ago by akaEpitaph.

          If it's not broke, break it
          Then learn how to fix it

          #130360
          Member
          keshav-uses-linux

            Save and close the file.Now reboot.Hopefully everything works as smoothly as it did here.
            Go to the menu > applications > Entertainment media > pavucontrol(Pulse-audio volume control) and see if it is working.

            Soo, mine is stuck on this

            Edited by caprea: Further clarification of the problem can be found here
            https://www.antixforum.com/forums/topic/audio-too-loud-on-antix/#post-130361

            • This reply was modified 1 month ago by caprea. Reason: added link for other users
            #132755
            Member
            orthodox42

              Apart from the fact that I used bluetoothctl instead, thanks a lot for the “straight forward” method! I wanted to connect a keyboard and I find (considering the other tips) it works very well with bluetoothctl. The program doesn’t have a detailed entry in the man pages, but the help tells you everything you need to know.

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.