Bluetooth in AntiX

Forum Forums General Hardware Bluetooth in AntiX

  • This topic has 9 replies, 7 voices, and was last updated May 9-8:22 am by stevesr0.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #33583
    Member
    AvatarBrandonIrizarry

    I have a pair of bluetooth headphones I’d like to use with AntiX. The GUI that comes with AntiX was giving me problems, so I went to the Arch Wiki and
    found some CLI-based instructions. However, I was unsuccessful. Here’s my session, which I managed to copy-paste from my terminal:
    (Note: Device E4:0F:44:7F:D3:0A MBH539 is what I want my computer to pair with, the headphones. They’re not, of course, paired with any other device.)

    $ bluetoothctl
    Agent registered
    [bluetooth]# remove E4:0F:44:7F:D3:0A
    [DEL] Device E4:0F:44:7F:D3:0A MBH539
    Device has been removed
    [bluetooth]# scan on
    Discovery started
    [CHG] Controller 7C:E9:D3:B7:D7:66 Discovering: yes
    [NEW] Device 8C:79:F5:8B:C7:3A [TV] Samsung Q60 Series (43)
    [NEW] Device C4:8E:8F:3B:9F:C0 Living Room
    [CHG] Device C4:8E:8F:3B:9F:C0 TxPower: 10
    [CHG] Device C4:8E:8F:3B:9F:C0 UUIDs: 00001200-0000-1000-8000-00805f9b34fb
    [CHG] Device C4:8E:8F:3B:9F:C0 ManufacturerData Key: 0x000f
    [CHG] Device C4:8E:8F:3B:9F:C0 ManufacturerData Value:
    00 01 64 ..d
    [NEW] Device E4:0F:44:7F:D3:0A MBH539
    [CHG] Device 8C:79:F5:8B:C7:3A RSSI: -62
    [bluetooth]# pair E4:0F:44:7F:D3:0A
    Attempting to pair with E4:0F:44:7F:D3:0A
    [CHG] Device E4:0F:44:7F:D3:0A Connected: yes
    [CHG] Device E4:0F:44:7F:D3:0A UUIDs: 00001101-0000-1000-8000-00805f9b34fb
    [CHG] Device E4:0F:44:7F:D3:0A UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
    [CHG] Device E4:0F:44:7F:D3:0A UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
    [CHG] Device E4:0F:44:7F:D3:0A UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
    [CHG] Device E4:0F:44:7F:D3:0A UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
    [CHG] Device E4:0F:44:7F:D3:0A ServicesResolved: yes
    [CHG] Device E4:0F:44:7F:D3:0A Paired: yes
    Pairing successful
    [CHG] Device E4:0F:44:7F:D3:0A ServicesResolved: no
    [CHG] Device E4:0F:44:7F:D3:0A Connected: no
    [bluetooth]# trust E4:0F:44:7F:D3:0A
    [CHG] Device E4:0F:44:7F:D3:0A Trusted: yes
    Changing E4:0F:44:7F:D3:0A trust succeeded
    [CHG] Device E4:0F:44:7F:D3:0A RSSI: -43
    [bluetooth]# connect E4:0F:44:7F:D3:0A
    Attempting to connect to E4:0F:44:7F:D3:0A
    Failed to connect: org.bluez.Error.Failed
    [bluetooth]#

    #33592
    Member
    XecureXecure

    Unfortunately for me I had to use pulseaudio instead of alsa to get my bluetooth headphones to work on antiX. Installing pulseaudio, pavucontrol and pulseaudio-module-bluetooth (apart from the general bluez, blueman, etc.) made it for me. I really haven’t investigated how to get them to work with only alsa, so this is the best I can offer.

    #33624
    Member
    Avatarolsztyn

    Unfortunately for me I had to use pulseaudio instead of alsa to get my bluetooth headphones to work on antiX.

    Same here…

    #33627
    Forum Admin
    anticapitalistaanticapitalista

    Unfortunately for me I had to use pulseaudio instead of alsa to get my bluetooth headphones to work on antiX.

    Same here…

    Same here – so I decided to just plug in the bluetooth headphones to the hardware audio socket and use alsa.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #33640
    AvatarAnonymous

    I don’t know why the TE runs bluetoothctl executes as root.
    Otherwise, with antiX19 the establishment of a Bluetooth connection is no problem for me

    #35708
    Member
    Avatarstevesr0

    So, apulse doesn’t substitute adequately for pulseaudio?

    I have the same failure (running antix 17 on this laptop).

    Does this also fail with antix 19?

    Separate question – has anyone tried using bluealsa to enable speakers and headphones?

    stevesr0

    • This reply was modified 3 months ago by stevesr0.
    #35721
    Member
    XecureXecure

    So, apulse doesn’t substitute adequately for pulseaudio?

    apulse: PulseAudio emulation for ALSA
    ALSA is still running and managing on the background, so devices connect through ALSA but programs comunicate with ALSA “thinking” they are talking to pulseaudio.

    Separate question – has anyone tried using bluealsa to enable speakers and headphones?

    I haven’t. Maybe you could test it out and report how it goes if you get it to work. It could be a very good improvement and help us in the future.

    #35744
    Member
    Avatarstevesr0

    Hi Xecure,

    It might be above my pay grade. I have not done hardly any making from source. It may well take me weeks (which is fine, as I am retired and “sheltering in place”).

    So, I would appreciate some advice before and while trying to install that.

    There is a “comprehensive installation guide” that I printed out and plan on following. (Link: https://github.com/Arkq/bluez-alsa/wiki) However, I am not sure that antix is Debian enough for this to work exactly. So, I would appreciate feedback that the instructions would APPARENTLY work with Antix 17.4. before starting. Also, if there are any programs that need to be installed beyond those mentioned in the guide.

    Finally, hopefully someone will respond if I get started and confused <g>.

    stevesr0

    #35749
    Member
    AvatarModdIt

    You might find some more pertinent information here. Thread includes links. Armbian is not so far away from Debian.
    https://forum.armbian.com/topic/6480-bluealsa-bluetooth-audio-using-alsa-not-pulseaudio/

    #35766
    Member
    Avatarstevesr0

    Thanks, Moddit. I looked at that site, but having studied the procedures to install to linux distros more, it doesn’t appear so complicated. Just a lot of sources and locations to get correct. So I am trying to use those install directions.

    I notice that libdbus is used for one component and on my computer, various versions of libdbus files are present in two different directories.

    /usr/lib/x86_64-linux-gnu
    $ ls -asl libdbus-*
    684 -rw-r–r– 1 root root 697602 Jun 14 2019 libdbus-1.a
    0 lrwxrwxrwx 1 root root 42 Jun 14 2019 libdbus-1.so -> /lib/x86_64-linux-gnu/libdbus-1.so.3.14.16
    0 lrwxrwxrwx 1 root root 23 Jan 12 2017 libdbus-glib-1.so.2 -> libdbus-glib-1.so.2.3.3

    /lib/x86_64-linux-gnu
    $ ls -asl libdbus-*
    0 lrwxrwxrwx 1 root root 20 Jun 14 2019 libdbus-1.so.3 -> libdbus-1.so.3.14.16
    316 -rw-r–r– 1 root root 321680 Jun 14 2019 libdbus-1.so.3.14.16

    So, there is one libdbus file (1.so.3.14.16) in /lib/ which is symlinked by files in both /lib/ and /usr/lib/,
    AND there is one libdbus-glib file (1.so.2.3.3) in /usr/lib/ which is symlinked to by two files in /usr/lib/.

    So, it appears that only /usr/lib has “connections to all the libdbus files that might be needed?

    Appreciate comments on whether I need any other dbus components and whether the /usr/lib/ directory is the location to specify in the configure step.

    Thanks.

    stevesr0

    • This reply was modified 3 months ago by stevesr0.
    • This reply was modified 3 months ago by stevesr0.
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.