Boot time takes more than 8 mins…

Forum Forums New users New Users and General Questions Boot time takes more than 8 mins…

This topic contains 15 replies, has 7 voices, and was last updated by stevesr0 Jun 19-1:22 pm.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #3044
    Member

    blue digit

    Hi everybody again, here’s what I’m facing.
    I made a USB-live (Sandisk Ultra Fit USB 3.0 32GB) whit antiX-17 and on my old laptop (Hp Compaq 6720s) works a charme, but on the laptop I’ve made it for (HP Elitebook 2760p -162A) the boot time goes beyond 7/8 minutes to load. Sure it depends on the Elitebook, but I lack so much in understanding the real cause of this. Is it possible for someone to give me a step-by-step workaround to identify (and solve) the problem?
    Here’s the Inxi output:

    System:    Host: antix1 Kernel: 4.10.5-antix.3-amd64-smp x86_64 bits: 64 gcc: 6.3.0
               Desktop: IceWM 1.4.2 Distro: antiX-17_x64-full Heather Heyer 24 October 2017
    Machine:   Device: laptop System: Hewlett-Packard product: HP EliteBook 2760p v: A0005E02 serial: N/A
               Mobo: Hewlett-Packard model: 162A v: KBC Version 05.33 serial: N/A
               BIOS: Hewlett-Packard v: 68SOU Ver. F.02 date: 07/26/2011
    Battery    BAT0: charge: 37.2 Wh 98.2% condition: 37.9/37.9 Wh (100%)
               model: Hewlett-Packard Primary status: N/A
    CPU:       Dual core Intel Core i5-2540M (-HT-MCP-)
               arch: Sandy Bridge rev.7 cache: 3072 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10381
               clock speeds: max: 3300 MHz 1: 1113 MHz 2: 818 MHz 3: 939 MHz 4: 801 MHz
    Graphics:  Card: Intel 2nd Generation Core Integrated Graphics Controller
               bus-ID: 00:02.0
               Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: 1280x800@59.98hz
               OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
               version: 3.3 Mesa 13.0.6 Direct Render: Yes
    Audio:     Card Intel 6 Series/C200 Series Family High Def. Audio Controller
               driver: snd_hda_intel bus-ID: 00:1b.0
               Sound: Advanced Linux Sound Architecture v: k4.10.5-antix.3-amd64-smp
    Network:   Card-1: Intel 82579LM Gigabit Network Connection
               driver: e1000e v: 3.2.6-k port: 4060 bus-ID: 00:19.0
               IF: eth0 state: down mac: <filter>
               Card-2: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter
               driver: wl bus-ID: 24:00.0
               IF: wlan0 state: dormant mac: <filter>
    Drives:    HDD Total Size: 190.8GB (2.3% used)
               ID-1: /dev/sda model: Hitachi_HTS54321 size: 160.0GB
               ID-2: USB /dev/sdb model: Ultra_Fit size: 30.8GB
    Partition: ID-1: / size: 3.1G used: 2.6M (1%) fs: overlay dev: N/A
               ID-2: /home size: 5.8G used: 25M (1%) fs: ext4 dev: /dev/loop1
               ID-3: swap-1 size: 4.55GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
    Sensors:   System Temperatures: cpu: 47.0C mobo: 0.0C
               Fan Speeds (in rpm): cpu: N/A
    Info:      Processes: 184 Uptime: 1:17 Memory: 193.8/3928.3MB
               Init: SysVinit runlevel: 5 Gcc sys: 6.3.0
               Client: Shell (inxi-gui) inxi: 2.3.40

    I try to explain more accurately what happens:
    The OS on USB-key is antiX-17_x64-full.iso (verified md5sum) and full persistence enabled.
    When I start the sistem looks to load everything correctly, then I ear a beep and obtaining a blank screen (except for a not blinking cursor in upper left corner), from this point on takes 7/8 minutes to show the desktop (fully functional!).

    • This topic was modified 10 months ago by blue digit.
    • This topic was modified 10 months ago by blue digit.
    #3047
    Forum Admin
    anticapitalista
    anticapitalista

    What happens if you do not enable persistence?

    Philosophers have interpreted the world in many ways; the point is to change it.

    #3051
    Member

    blue digit

    … same boot time, 8.30 minutes, should I try to boot using toram option?

    • This reply was modified 10 months ago by blue digit.
    #3052
    Forum Admin
    BitJam
    BitJam

    It may not be related but I’ve stopped using SanDisk Ultra-Fit for live-usb work. They have problems but I don’t think it is related to your problem. I switched to using Samsung usb flash drive Fit and have not looked back (except to say “Sayonara SanDisk Fit!”).

    My guess is your problem is related to the video driver. You can test this by adding the boot parameter “3” to boot into console mode. You could also try using the safe video option. Using the cheat “xorg=intel” may be a quick fix. IIRC one big change in 16 –> 17 was the default driver for Intel graphics changed from “intel” to “modesetting”.

    If none of that brings you joy, after the 8 minute boot, there may be clues in the Xorg.0.log file or in the output of dmesg. If you made the live-usb with live-usb-maker then you can store these on the live-usb with the commands:

    cd ~/Live-usb-storage/
    cp /var/log/Xorg.0.log .
    dmesg --color=always > dmesg.out

    You can look at them with “less Xorg.0.log” and “less dmesg.out”. I’m not sure how to attach log files in this forum. I was stymied the last time I tried.

    ps: I’d be surprised if “toram” helped. You can combine “3” with other suggestions such as safe video or “xorg=intel”. Then to start X use “sudo telinit 5”.

    Context is worth 80 IQ points -- Alan Kay

    #3057
    Forum Admin
    rokytnji
    rokytnji

    I’d poke around the /var/boot/ logs though with persistent usbs. I may talking out of line here. Since live is read only.

    Sounds to me like the kernel is looking real hard for something when it changes the computer port it is plugged into.

    Might have to be a bios change to speed up the boot by turning something off in hardware settings. Poke and hope. That is me.

    Beer, Bikes, and BBQ. It's what we do
    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #3065
    Member

    blue digit

    Might it be a good way to append log files as attachments?!?

    #3069
    Member

    blue digit

    Also, there were a couple of lines just before the boot I was unable to read (too fast!), so I’ve recorded a video to be able to read those lines:

    [   3.614063] tmp tmp0: A TMP error (7) occurred attempting to read a pcr value
     [   4.534143] tmp tmp0: A TMP error (7) occurred attempting to read a pcr value

    …I do not know the real meaning of these lines, so I attach the log files from “Xorg.0.log” and “dmesg.out”
    Hope not to be crucified! 😉

    #3070
    Member

    blue digit

    ….mmmmh, says: file type is not permitted for security reasons.
    How can I show those? As attached archives maybe? Looks a bit too long to put it in code tags…

    #3075
    Forum Admin
    BitJam
    BitJam

    Instead of attaching the log files or inserting them into a post, try using pastebin: https://pastebin.com/

    Did you try “xorg=intel” or “3”?

    A Google(tmp tmp0: A TMP error (7) occurred attempting to read a pcr value) brings up a number of suggestions on how to fix the problem. One person got this message when they had two hard drive partitions with the same UUID. You can check this with the command:sudo lsblk -o name,size,fstype,label,uuid.

    Some people suggested turning off TMP in the BIOS. Others suggested turning it on.

    Context is worth 80 IQ points -- Alan Kay

    #3090
    Forum Admin
    rokytnji
    rokytnji

    Bitjam is spot on . Pastebin links are very very good to use here if not using code tags with copy and paste.

    I was able to upload old forum posts and I used .tar as my way to compress pdf pages of old forum posts with images.

    Conky "how to" thread from Tapatalk

    • This reply was modified 10 months ago by rokytnji.
    • This reply was modified 10 months ago by rokytnji.

    Beer, Bikes, and BBQ. It's what we do
    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #3094
    Member
    tbuser48
    tbuser48

    Don’t disregard hardware.

    I’ve seen built in DVD’s and wireless cause issues with the kernel looking and looking before finally giving up.

    Heat (looks o.k. here), bad ram, older hdd in case you are using it. My 160 drives are getting a little long in tooth.

    I strip them down to essentials and start adding until they break again.

    Maybe try a different USB port???

    I see this a lot. 🙂

    $ dmesg | grep pcr -i
    [    1.560282] tpm tpm0: A TPM error (7) occurred attempting to read a pcr value
    [    2.546999] tpm tpm0: A TPM error (7) occurred attempting to read a pcr value

    Good luck.

    #10811
    Member

    stevesr0

    I am also experiencing a long boot time (5 minutes)on one of my computers with 17.1 (vs 24 seconds with 16.1). I also see a tpm (trusted platform module) error. My UUIDs in fstab and by blkid are identical. I also have a black screen (?no backlight) for most of that time.

    My boot option editing doesn’t seem to take properly. I tried eliminating quiet and splash options and used xorg=intel without any change.

    Except, after editing and rebooting several times, now I seem to go only to a console login. Startx doesn’t work. There is a message about lacking an xauthority file.

    When it was launching to a desktop, the system worked ok.

    I have wacom digitizer on this computer. Version 16.1 didn’t apparently detect or load that, while 17.1 does, so I suspect that it may be related to the initialization of the wacom files. (The Xorg.log file goes from 68 seconds at one point while working on the serial wacom driver to 312-319 seconds before then starting on the wacom stylus.

    Apparently, the OP’s computer doesn’t have a wacom digitizer…

    Hope that suggests something.

    Steve

    #10812
    Member

    736b69646f6f

    suggest:
    sudo apt-get install haveged
    (it is tiny, less than 100kb)
    reboot and check whether slow boot problem is solved.
    If it is not, read this: https://scotte.org/2015/07/TPM-for-better-random-entropy
    and
    dmesg | grep -i tpm

    and a websearch, like ” tpm0: A TPM error occurred attempting to read a pcr value”
    will lead to reported solutions like
    “[SOLVED] A TPM error (6) occurred attempting to read a pcr value” https://bbs.archlinux.org/viewtopic.php?id=139415

    #10849
    Member

    stevesr0

    Hi 736b69646f6f,

    I’m not sure if you were replying to me or the OP.

    I tried to use haveged, but I realized tonight that it hadn’t been saved in the persistence file. I made a root persistence file, so I guess I have to install the app as root (or add a home persistence file). I will try to try that tomorrow.

    Interesting to read about low entropy related problems with linux. Not something I thought was significant for an enduser.

    My computer is 2007 vintage, so I didn’t think it had TPM hardware. However, it does. But, deactivated and disabled. I would need to add a supervisor password in order to get control of it to see if it changes things. Not clear on the positives and negatives of doing that on this old laptop.

    stevesr0

    • This reply was modified 3 months, 2 weeks ago by stevesr0.
    #10869
    Member

    stevesr0

    Hi Blue Digit,

    If you are still following this thread, I checked and your elitebook does use a digitizer. There is a known bug with an xorg-server file that multiplies wait time for setting up the wacom digitizer by 1000. This makes for a delay of ~250 seconds. There is a fix in a new version of the server.

    This is described in detail in three links in a post by caprea today (#10634) (in an thread entitled “Wacom Digitizer and antix boot”) on the Heather Heyer subforum.

    (Kudos to caprea!!)

    Hope that solves your problem

    steve

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.