Booting antiX Frugal-only From HDD Without Any Full-Installed OS – with Extlinux

Forum Forums General Tips and Tricks Booting antiX Frugal-only From HDD Without Any Full-Installed OS – with Extlinux

  • This topic has 55 replies, 10 voices, and was last updated Aug 27-2:18 pm by Brian Masinick.
Viewing 15 posts - 16 through 30 (of 55 total)
  • Author
    Posts
  • #40188
    Member
    anilkagi

      Since you are using the instructions on this post, you don’t need to boot the live usb into frugal mode. Just regular live boot works.

      Hello Christophe,

      I tried regular live boot, just now, in the VBox VM. I left the F4 & F5 options untouched like below;

      F4 Options: none
      F5 Persist: off

      And completed all the steps as described, but that didn’t help either. Again I got the same error. I am attaching the images of the bootloader error. Earlier I couldn’t.

      #40192
      Member
      olsztyn

        11] Shutdown
        12] Remove USB live
        13] Reboot

        Then I get this error.

        fatal error: device found but could not find antix-19/linuxfs file on device

        It looks to me you performed steps and you are very close. The above fatal error indicates that it is not able to find linuxfs file, which is the compressed file system of Frugal system.
        It might be just a mismatch of Frugal folder name with boot entry.
        The label in the extlix.conf must reference the correct name of Frugal folder:

        LABEL l0
        MENU LABEL antiX 19.2.1 Base, frugal only, zram enabled
        LINUX /antiX/vmlinuz root=UUID=1071a266-a5ce-4cfd-b0b5-2765e54e5f02 bdir=antix-19 buuid=1071a266-a5ce-4cfd-b0b5-2765e54e5f02
        APPEND frugal_only vga=default quiet splasht=va
        INITRD /antiX/initrd.gz

        Here the label says /antiX, so if you changed folder to antiX-19, corresponding change in Label is necessary.
        You have probably done it already and I just missed to notice, though…
        Just a thought…

        • This reply was modified 3 years, 9 months ago by olsztyn.
        • This reply was modified 3 years, 9 months ago by olsztyn.
        • This reply was modified 3 years, 9 months ago by olsztyn.

        Live antiX Boot Options (Previously posted by Xecure):
        http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

        #40197
        Moderator
        christophe

          OK. I’m seeing 2 errors in the extlinux.conf file (one error is mine from the example in the main post, the other is an unneeded boot parameter).

          LABEL l0
          MENU LABEL antiX 19.2.1 Base, frugal only, zram enabled
          LINUX /antiX/vmlinuz root=UUID=1071a266-a5ce-4cfd-b0b5-2765e54e5f02 bdir=antix-19 buuid=1071a266-a5ce-4cfd-b0b5-2765e54e5f02
          APPEND frugal_only vga=default quiet splasht=va
          INITRD /antiX/initrd.gz

          The line LINUX needs to have the “/antiX/vmlinuz” match the “bdir” parameter, like this
          LINUX /antiX/vmlinuz root=UUID=1071a266-a5ce-4cfd-b0b5-2765e54e5f02 bdir=antiX buuid=1071a266-a5ce-4cfd-b0b5-2765e54e5f02
          or like this
          LINUX /antix-19/vmlinuz root=UUID=1071a266-a5ce-4cfd-b0b5-2765e54e5f02 bdir=antix-19 buuid=1071a266-a5ce-4cfd-b0b5-2765e54e5f02
          These 2 references to the “boot directory” (“bdir”) have to match. (My fault. Sorry.)

          The other is here:
          APPEND frugal_only vga=default quiet splasht=va
          The “frugal_only” boot parameter doesn’t apply here — since you are not using the live-USB. Just remover it, so it looks like
          `APPEND vga=default quiet splasht=va’
          to go without any persistence.

          THAT should fix it.

          EDIT olsztyn said the first part already, catching the typo from my original post.

          • This reply was modified 3 years, 9 months ago by christophe.

          confirmed antiX frugaler, since 2019

          #40199
          Member
          olsztyn

            Looks like christophe already found the issue, before I finished my preceding post, so please disregard my preceding post on mismatch of boot entry and frugal folder name.
            Christophe explained this extensively…
            Thanks christophe!

            Live antiX Boot Options (Previously posted by Xecure):
            http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

            #40200
            Member
            anilkagi

              you boot Live USB antiX stick (not any Frugal option from F5) and arrive to desktop, execute file manager (such as SpaceFM) and look at sda1 you should see your Frugal install.

              Olsztyn,

              Mysteriously, every time when it fails to boot into frugal install and then I mount the live usb and boot into it to find any mistakes, what I see is, there is no sda1 there, though I created and mounted by issuing the following commands.

              mkdir /media/sda1
              mount /dev/sda1 /media/sda1

              However, what I find in place of ‘sda1’ is another directory named ‘antix-Frugal’. Every time I go through these steps, while making partitions with Gparted, I create the partition sda1 with the label ‘antix-Frugal’, I never created a directory named ‘antix-Frugal’. However, it shows here now. Is it because I mount /dev/sda1 with the label ‘antix-Frugal’ on /media/sda1? I thought so.

              Look at content of Frugal install. It should have:
              -boot folder
              -EFI folder
              -state folder
              -bios-dev-uuid
              – grub.entry
              -homefs
              -initrd.gz
              -linuxfs
              – vmlinuz
              and a few .md5.

              I looked at the contents of the directory /media/antix-Frugal. It only has the ‘antix’ and ‘boot’ folders. The ‘boot’ folder has only the ‘extlinux’ folder in it. Here below are the images of the contents of the said folders. There are these;

              linuxfs
              vmlinuz
              initrd.gz
              random-seed
              and the related md5 files.

              There is no ‘grub’ or ‘efi’. Like you said, even I thought the grub and efi would not be there, since we are booting from extlinux.

              When you renamed Frugal folder to antiX-19, did you remember to make these corresponding changes in grub.entry?

              No, I didn’t, because there was no grub folder at all, but I made corresponding changes in extlinux.conf.

              #40206
              Moderator
              christophe

                I believe when you booted from the live-USB as “frugal_only”, you also changed the volume name of sda1 to “antiX-frugal” to make it easier for the live-USB to find the frugal partition/device. (But you don’t want to boot frugal with live-USB if you are following the directions in this post.)

                I think you have it all set up, with the fixes here https://www.antixforum.com/forums/topic/booting-antix-frugal-only-from-hdd-without-any-full-installed-os-with-extlinux/page/2/#post-40197

                • This reply was modified 3 years, 9 months ago by christophe.

                confirmed antiX frugaler, since 2019

                #40208
                Member
                anilkagi

                  These 2 references to the “boot directory” (“bdir”) have to match.

                  Christophe, every time I edited the extlinux.conf I had matched the entries. I copied it from ‘blkid’ output and pasted it in both places as you have mentioned in the step 10.b.3 to “paste in both places”.

                  The “frugal_only” boot parameter doesn’t apply here — since you are not using the live-USB. Just remover it, so it looks like
                  `APPEND vga=default quiet splasht=va’
                  to go without any persistence.

                  I edited the extlinux.conf accordingly, it now looks as shown in the attachment below. I edited it and unmounted the live usb and tried to boot but I again got the same error.

                  #40214
                  Member
                  olsztyn

                    No, I didn’t, because there was no grub folder at all, but I made corresponding changes in extlinux.conf.

                    Sorry. I was editing interim content, which was for Grub version. This interim one you used in quotes.
                    Corresponding one is for Extlinux/syslinux, which christophe explained in detail.
                    Just make sure the Frugal folder name matches the one specified in boot entry.
                    From your snapshot it looks like label l0 boot entry specifies ‘antiX’ as Frugal folder name.

                    Live antiX Boot Options (Previously posted by Xecure):
                    http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

                    #40216
                    Member
                    anilkagi

                      I believe when you booted from the live-USB as “frugal_only”, you also changed the volume name of sda1 to “antiX-frugal” to make it easier for the live-USB to find the frugal partition/device.

                      While I posted this, I did a fresh install in a new VM. I did not boot in frugal_only mode. I did a regular boot. I also did not change the volume name, it is being done automatically. After installation and reboot I have never seen the ‘sda1’ folder even though I had created it. It is always ‘antix-Frugal’ in place of it, whether it is in the VM or HD.

                      #40220
                      Moderator
                      christophe

                        Your extlinux.conf screenshot still has the mismatched entry in the LINUX line.

                        I see from the screenshots of your ROX filer, that your frugal folder is named “antiX”, so change the LINUX line to this:

                        LINUX /antiX/vmlinuz root=UUID=1071a266-a5ce-4cfd-b0b5-2765e54e5f02 bdir=antiX buuid=1071a266-a5ce-4cfd-b0b5-2765e54e5f02

                        Note that here the LINUX /antiX/vmlinuz matches the reference in the bdir=antiX paramater.
                        (Obviously, your blkid should be whatever yours is, as well.)

                        confirmed antiX frugaler, since 2019

                        #40221
                        Member
                        anilkagi

                          Just make sure the Frugal folder name matches the one specified in boot entry.

                          The name of the Frugal folder name matches the one specified in boot entry. Both are ‘antix’. However, the paths have changed from what I had created from /media/sda1/antix to /media/antix-Frugal/antix because ‘sda1’ got changed to ‘antix-Frugal’. This is happening on its own. I tried to change back the name from ‘antix-Frugal’ to ‘sda1’ in ROX-filer-as-root, but I get ‘resource busy, failed to move’ error.

                          #40223
                          Member
                          anilkagi

                            Your extlinux.conf screenshot still has the mismatched entry in the LINUX line.

                            I see from the screenshots of your ROX filer, that your frugal folder is named “antiX”, so change the LINUX line

                            Sorry, I had not seen that. Now I changed it, but the issue still persists. Now the extlinux.conf and blkid look like this below;

                            • This reply was modified 3 years, 9 months ago by anilkagi.
                            #40225
                            Moderator
                            christophe

                              I tried to change back the name from ‘antix-Frugal’ to ‘sda1’ in ROX-filer-as-root, but I get ‘resource busy, failed to move’ error.

                              Don’t concern yourself with that. (You can do it in gparted if the partition isn’t mounted, but don’t bother.)
                              It’s just the “antiX” folder that matters (be aware of the capital X). As long as the antiX folder is on the top level (which it is), you are good.

                              confirmed antiX frugaler, since 2019

                              #40226
                              Moderator
                              christophe

                                Sorry we are both typing at once, which may make things hard to follow…

                                But I see in your latest screenshot that you don’t have a capital X in antiX in the bdir= parameter.

                                confirmed antiX frugaler, since 2019

                                #40234
                                Member
                                anilkagi

                                  Solved !!!

                                  Ah! that’s a capital X. When you cautioned me Christophe, about capitalisation earlier, I just concentrated on the first letter A of ‘antix’ because I usually write nouns beginning with a capital letter. Just a old school habit. So I was only focusing on that. I was not aware throughout that the X in ‘antiX’ is a capital letter. Whenever I was editing the extlinux-conf I just copy pasted from your post and edited it according to my system parameters. So part of the things that were left unedited were yours and so were correct. The things I edited were wrong.

                                  I spent a hell lot of time and energy on this capital X and consumed the time and energy of you all guys too. Sorry for that.

                                  And many thanks, Christophe, Olsztyn and Xecure for helping out and please forgive me for this foolish blunder. I am so embarrassed. 🙁

                                  BTW, why is the X in ‘antiX’ a capital letter? Just for aesthetic purposes or any specific computing necessities?

                                Viewing 15 posts - 16 through 30 (of 55 total)
                                • You must be logged in to reply to this topic.