Bug with “sudo” package update

  • This topic has 10 replies, 5 voices, and was last updated Mar 13-4:25 pm by Brian Masinick.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #51330
    Member
    GirafenaineGirafenaine

    Hello,

    I use a frugal antix 19. I boot it from a USB stick, with frugal option on the customized grub entry. It works well.

    From times to times I meet issues when upgrading system.

    After last system update, i was not able to use anything with “sudo”. When launching “sudo any_command” in a terminal, it complains about “sudoers” file not being here or right (I did not write down the displayed error). I had to delete my rootfs file to be able tu use normally my frugal install.

    I blocked “sudo” package to current version : 1.8.27-1+deb10u2. After blocking it, I could upgrade (apt full-upgrade) and all is working well, even after reboot.

    So it appears that 1.8.27-1+deb10u3 “sudo” package version makes my system to fail. I don’t know if it is a bug or an issue due to a mess in my conf files and especially on my sudoers file. What should I test to make it clear ?

    Girafenaine
    ----
    Antix 19, Live USB stick / Manjaro XFCE (Dell XPS 7590) / MX Linux 19 (various PC)

    #51331
    Member
    Avatarskidoo

    FYI, no problems seen here after upgrading to the “…10u3” sudo package.

    it complains about “sudoers” file not being here or right

    Readers probably will be unable to provide precise troublshooting assistance until you post an exact error message.

    In the meantime, you can refer to the manpage for the visudo command. It explains how the tool can be used to check the integrity of the sudoers file.

    #51339
    Forum Admin
    anticapitalistaanticapitalista

    Yes, the update breaks sudo on antiX live system. The update (from Debian) rudely overwrites /etc/sudoers with the effect that the file appears empty.

    Rename the working /etc/sudoers file to something like sudoers.safe, enable persistence, upgrade and after upgrading sudo copy /etc/sudoers.safe to /etc/sudoers

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #51341
    Member
    GirafenaineGirafenaine

    Hello,

    Skidoo thanks fo your ideas – “visudo -c” does not show any error. I would have make another test to get the exact error message, but anti’s post should make the job.

    Anticapitalista, thank you very much to share your knowledge. I will follow your instructions. (but I don’t understand why other antix users do not seem to get the same issue !).

    Girafenaine
    ----
    Antix 19, Live USB stick / Manjaro XFCE (Dell XPS 7590) / MX Linux 19 (various PC)

    #51349
    Member
    XecureXecure

    (but I don’t understand why other antix users do not seem to get the same issue !)

    For some reason I cannot remember, I disabled the debian security updates sources on my live USB, so I didn’t receive this upgrade. It seems I was lucky.

    #51357
    Member
    Avatarskidoo

    Y/N/D/k

    Maybe its installation presented a choice: keep same, use maintainer’s version… and I had chosen “keep”?

    #51358
    Forum Admin
    anticapitalistaanticapitalista

    Y/N/D/k

    Maybe its installation presented a choice: keep same, use maintainer’s version… and I had chosen “keep”?

    No choice was presented – at least not when running live/frugal.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #55650
    Member
    GirafenaineGirafenaine

    Hello,

    This issue seems to be still here with the newer package for “sudo”, which is 1.8.27-1+deb10u3.

    I tried to skip 1.8.27-1+deb10u2 with “sudo apt-mark hold sudo”, and unhold when 1.8.27-1+deb10u3 was released. I met the same issue with the last version.

    I used Anticapitalista’s solution :

    Rename the working /etc/sudoers file to something like sudoers.safe, enable persistence, upgrade and after upgrading sudo copy /etc/sudoers.safe to /etc/sudoers

    You just have to copy back /etc/sudoers.safe to /etc/sudoers BEFORE you restart your system… if you forget this step, it’s too late : you won’t be able to use sudo in the restarted system. And whithout sudo you cannot copy anything in /etc/ … actually even (properly) shutdown your system is not allowed… So copy back /etc/sudoers just after you upgrade sudo package, and it will be fine.

    Girafenaine
    ----
    Antix 19, Live USB stick / Manjaro XFCE (Dell XPS 7590) / MX Linux 19 (various PC)

    #55652
    Moderator
    Brian MasinickBrian Masinick

    Hello,

    This issue seems to be still here with the newer package for “sudo”, which is 1.8.27-1+deb10u3.

    I tried to skip 1.8.27-1+deb10u2 with “sudo apt-mark hold sudo”, and unhold when 1.8.27-1+deb10u3 was released. I met the same issue with the last version.

    I used Anticapitalista’s solution :

    Rename the working /etc/sudoers file to something like sudoers.safe, enable persistence, upgrade and after upgrading sudo copy /etc/sudoers.safe to /etc/sudoers

    You just have to copy back /etc/sudoers.safe to /etc/sudoers BEFORE you restart your system… if you forget this step, it’s too late : you won’t be able to use sudo in the restarted system. And whithout sudo you cannot copy anything in /etc/ … actually even (properly) shutdown your system is not allowed… So copy back /etc/sudoers just after you upgrade sudo package, and it will be fine.

    The last statement isn’t entirely accurate; you may not be able to use sudo if it is not functioning properly, but you can always switch to root with the classic su tool and provide the root password, then you can perform root/system administration activities. Also, if you allow login to root, you can login to the root account and perform administration directly from the root account, so an issue with sudo does NOT eliminate administrative abilities, it only inhibits the correct behavior of the sudo command.

    Brian Masinick

    #55706
    Member
    GirafenaineGirafenaine

    Hello Brian,

    Thank you for your correction, for others… and for me ! I did not try “su” wich could have saved me time (deleting root.fs file and rebooting and re-upgrading…).

    Regards

    • This reply was modified 2 months ago by Girafenaine.

    Girafenaine
    ----
    Antix 19, Live USB stick / Manjaro XFCE (Dell XPS 7590) / MX Linux 19 (various PC)

    #55712
    Moderator
    Brian MasinickBrian Masinick

    Girafenaine: You are welcome.

    Brian Masinick

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.