Can antiX-16 be "upgrade" to antiX-17?

Forum Forums Official Releases antiX-16 “Berta Cáceres” Can antiX-16 be "upgrade" to antiX-17?

This topic contains 9 replies, has 6 voices, and was last updated by millerebonds Apr 1-7:48 am.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #747
    Member
    TonyVanDam
    TonyVanDam

    THIS is not intended to be a stupid question. I was just wondering if I can upgrade antiX-16 to antiX-17 OR do I need to do an all new full installment of antiX-17 altogether?

    BTW, I using antiX-16 base 64-bit on my desktop and antiX-16 32-bit on my laptop.

    • This topic was modified 1 year, 5 months ago by TonyVanDam. Reason: spell check!
    #756
    Forum Admin
    anticapitalista
    anticapitalista

    If you have not installed anything outside the repos, then a dist-upgrade should be ok. I’d suggest doing it in a terminal with apt-get.

    1. Make sure you are up to date with the default antiX-16 repos, ie jessie.
    2. If all is ok with this update, edit debian.list and antix.list to stretch. Do not use mx repos.
    3. If you want eudev, add it to the list in 5. (I added it)
    4. apt-get update and then apt-get dist-upgrade. Check nothing important will be uninstalled.
    5. You will need to install the following apps manually, since they are not on antiX-16, but are on 17. (You can choose which ones you don’t want)

    apt-get install adobe-flashplugin arc-theme apt-transport-https artwork17-antix bootrepair-antix broadcom-manager-antix cli-aptix conky-legacy-all console-grid-gui eudev firejail fonts-crosextra-caladea fonts-crosextra-carlito fskbsetting galculator gnome-mahjongg gnome-mpv grubcc-antix gsmartcontrol gufw-legacy libeudev1 lxkeymap mps-youtube packageinstaller qt5ct xmms-skins-antix xserver-xorg-legacy

    6. Remove the following (you may want to keep some)

    apt-get purge browser-plugin-freshplayer-pepperflash bunsen-pepperflash gnome-icon-theme gnome-icon-theme-symbolic gnome-mplayer gnu-fdisk gufw keyboard-cc-antix install-meta-antix live-usb-cli-antix live-usb-gui-antix mplayer2 roxterm-common roxterm-gtk3 siduction-archive-keyring spacefm-extras system-antix toshset ttf-dejavu-core udev libudev1 unetbootin upower xmahjongg

    7. Install a new kernel. package-installer should give you some options.

    • This reply was modified 1 year, 4 months ago by anticapitalista. Reason: added more information
    • This reply was modified 1 year, 4 months ago by anticapitalista.
    • This reply was modified 1 year, 4 months ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #764
    Member
    TonyVanDam
    TonyVanDam

    I’m making a note of this right now. Thanks!

    #808
    Moderator
    fatmac
    fatmac

    You can also use the new release to install with, but keep your old /home, it is an option when you install. 🙂

    Linux (& BSD) since 1999

    #1737
    Member
    Avatar
    yadbash

    New to AntiX, as long as I leave the Repos list with Jessie then safe to say, my AntiX 16.2 will NOT upgrade to AntiX 17 when I use sudo apt-get dist-upgrade ?

    • This reply was modified 1 year, 5 months ago by yadbash.
    #1761
    Moderator
    fatmac
    fatmac

    You can ‘update’ & ‘upgrade’ safely, (but, I personally, don’t do a ‘dist upgrade’).

    • This reply was modified 1 year, 5 months ago by fatmac.
    • This reply was modified 1 year, 5 months ago by fatmac.

    Linux (& BSD) since 1999

    #1768
    Moderator
    masinick
    masinick

    New to AntiX, as long as I leave the Repos list with Jessie then safe to say, my AntiX 16.2 will NOT upgrade to AntiX 17 when I use sudo apt-get dist-upgrade ?

    Leveraging what anticapitalista and fatmac have shared, yes it is possible to do a system update or distribution upgrade from one release to the next incremental release.

    The steps have been explained. This is something that is best left to those who are able to read and research information, deduce how to manage the steps and details that may change, and do a fair amount of self learning. If that’s you, then it’s reasonable to upgrade your system in any way that you desire. If you have to have accurate information and instructions about the process, then you are better off installing the new system directly.

    Brian Masinick

    #1769
    Moderator
    masinick
    masinick

    Also performing dist-upgrades across release changes works fine but the antiX release number doesn’t change unless you modify it manually, though the Debian release information will change any time a package containing the Debian release string changes.

    Brian Masinick

    #19952
    Member
    Avatar
    millerebonds

    If you have not installed anything outside the repos, then a dist-upgrade should be ok. I’d suggest doing it in a terminal with apt-get.

    1. Make sure you are up to date with the default antiX-16 repos, ie jessie.
    2. If all is ok with this update, edit debian.list and antix.list to stretch. Do not use mx repos.
    3. If you want eudev, add it to the list in 5. (I added it)
    4. apt-get update and then apt-get dist-upgrade. Check nothing important will be uninstalled.
    5. You will need to install the following apps manually, since they are not on antiX-16, but are on 17. (You can choose which ones you don’t want)

    It’s not clear for beginners!
    I have a friend who tested, and didn’t understand these guidelines.

    1. It means sudo apt-get update

    2. It means look in /etc/apt/sources.list.d
    cd /etc/apt/sources.list.d
    Then open repositories files, remove the #behind the line with stretch, and put a #behind the line who had no #

    nano antix.list
    nano debian.list

    I made all these things on this old computer, and made I mistake with GRUB (I could correct it with the liveusb, but preferred to install a new system…)

    I use archlinux, tested gentoo, debian + JWM, and then think we can not allways know everything about every OS…

    • This reply was modified 2 weeks, 6 days ago by millerebonds.
    • This reply was modified 2 weeks, 6 days ago by millerebonds.
    • This reply was modified 2 weeks, 6 days ago by millerebonds.
    #19956
    Member
    Avatar
    millerebonds

    If you have not installed anything outside the repos, then a dist-upgrade should be ok. I’d suggest doing it in a terminal with apt-get.

    1. Make sure you are up to date with the default antiX-16 repos, ie jessie.
    2. If all is ok with this update, edit debian.list and antix.list to stretch. Do not use mx repos.
    3. If you want eudev, add it to the list in 5. (I added it)
    4. apt-get update and then apt-get dist-upgrade. Check nothing important will be uninstalled.
    5. You will need to install the following apps manually, since they are not on antiX-16, but are on 17. (You can choose which ones you don’t want)

    It’s not clear for beginners!
    I have a friend who tested, and didn’t understand these guidelines.

    1. It means sudo apt-get update

    2. It means look in /etc/apt/sources.list.d
    cd /etc/apt/sources.list.d
    Then open repositories files, remove the #behind the line with stretch, and put a #behind the line who had no #

    nano antix.list
    nano debian.list

    I made all these things on this old computer, and made a mistake with GRUB (I could correct it with the liveusb, but preferred to install a new system…)

    I use archlinux, tested gentoo, debian + JWM, and then think we can not allways know everything about every OS, even somebody which come from an other linux and is a little bit beginner appreciate more details.

    • This reply was modified 2 weeks, 6 days ago by millerebonds.
Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.