Cannot change permissions recursively?

Forum Forums New users New Users and General Questions Cannot change permissions recursively?

Tagged: 

  • This topic has 2 replies, 3 voices, and was last updated Mar 1-6:09 am by abc-nix.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #134887
    Member
    kaye

      Hello friends!

      I execute the following command to open zzzfm file manager as root:

      sudo zzzfm

      I right click the following folder in zzzfm file manager

      /home/user/Desktop

      Point mouse pointer to Properties -> Permissions

      I tick the checkbox of:

      Recursive (apply changes to folders and their contents)

      I click ok.

      If I repeat the process, Recursive checkbox returns to being unchecked.

      Normal?

      Thank you for your time!

      #135054
      Member
      Claxsis

        The following is my way to change permissions of files.
        Open terminal and type
        *********************************
        sudo chmod 777 (filename)

        ********************************
        The above is a just example.

        #135058
        Member
        abc-nix

          Point mouse pointer to Properties -> Permissions

          I tick the checkbox of:

          Recursive (apply changes to folders and their contents)

          I click ok.

          If I repeat the process, Recursive checkbox returns to being unchecked.

          Recursivity is an option to perform the action recursively, not a permission option. You activate the checkbox, make the permission changes (like changing user or group ownership and permissions), and then apply the changes. The changes will be applied not only to the files/folder selected, but to all files and folders inside (recursive means to operate on all files and folders contained under the selected folder). If you don’t enable “Recursive” before performing the action, the changes will only take place for the selected directory and not the files and folders inside it.

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.