Cannot create LVM in antiX 17

Forum Forums Official Releases antiX-17 “Heather Heyer, Helen Keller” Cannot create LVM in antiX 17

  • This topic has 3 replies, 2 voices, and was last updated Nov 2-5:25 pm by skidoo.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1360
    Member
    Avatarwean_irdeh

    after creating physical volume and volume group, I’m still unable to create LVM
    here is the error message

    $ sudo lvcreate -n antix.rootfs -L 5G vg0
    

    /dev/vg0/antix.rootfs: not found: device not cleared
    `Aborting. Failed to wipe start of new LV.

    #1464
    Member
    Avatarwean_irdeh

    bump

    ModEdit: Please don’t – if someone knows, they will answer, you just have to wait, (no one gets paid here). 😉

    • This reply was modified 3 years, 5 months ago by fatmac.
    #1707
    Member
    Avatarwean_irdeh

    It turns out that the lvm is stored in
    [code]/dev/mapper/*volume_group_name-logical_volume_name[/code] ,
    in my case it is
    [code]/dev/mapper/vg0-antix.rootfs[/code]

    Now if only there is a way to make lvcreate aware that the lvm is stored in
    [code]/dev/mapper/*volume_group_name-logical_volume_name[/code]
    instead of
    [code]/dev/volume-group-name/logical-volume-name[/code]

    • This reply was modified 3 years, 5 months ago by wean_irdeh.
    • This reply was modified 3 years, 5 months ago by wean_irdeh.
    • This reply was modified 3 years, 5 months ago by wean_irdeh.
    #1719
    Member
    Avatarskidoo

    (I’m not an lvm user)

    check the lvcreate manpage
    Maybe you just need to pass the path via the –name option

    -n, –name LogicalVolume{Name|Path}
    The name for the new logical volume.
    Without this option a default names of “lvol#” will be generated where # is the LVM internal number of the logical volume.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.