[SOLVED] Cannot disable titlebar on Firefox.

Forum Forums New users New Users and General Questions [SOLVED] Cannot disable titlebar on Firefox.

Tagged: ,

  • This topic has 10 replies, 5 voices, and was last updated May 6-8:41 pm by Brian Masinick.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #58643
    Member
    jdxU5NGdbc

      Netbook: Acer Aspire One Happy
      Distro: antiX 19.3
      Browser: Firefox 78.3.0 ESR

      For whatever reason on my fresh antiX install I do not have an options to disable titlebar, be it through “Customize” menu or through about:config. Why is that so? Any other workarounds?

      Thank you all in advance.

      http://i.imgur.com/XHgVlBy

      http://i.imgur.com/FEJbqVy

      • This topic was modified 3 years, 2 months ago by jdxU5NGdbc.
      • This topic was modified 3 years, 2 months ago by Brian Masinick. Reason: Moderator put [SOVED] by editing the first post title
      • This topic was modified 3 years, 2 months ago by Brian Masinick. Reason: Moderator put [SOLVED] by editing the first post title
      #58648
      Anonymous

        possibly (meaning, I do not know) because, as of version suchandsuch, firefox is preconfigured to use CSD (client-side decorations)

        http://vitux.com/how-to-try-firefox-client-side-decoration-csd-on-ubuntu/

        toward disabling CSD, you can try:
        type “about:config” in browser addressbar
        type “widget.allow-client-side-decoration” (noquotes) into config searchbar
        toggle the value to FALSE
        You may need to restart the browser for the change (if any) to take effect.

        If the above does not solve, websearch “firefox disable CSD” or “firefox disable client side decoration”

        #58649
        Anonymous

          For a more general (not specific to firefox) approach toward disabling GTK3 CSD, you can
          sudo apt install gtk3-nocsd
          (and the effect, if any, should be evident after your next desktop session login)

          gtk3-nocsd project homepage/docs here: http://github.com/PCMan/gtk3-nocsd

          #58658
          Member
          jdxU5NGdbc

            Alright so I did some Googling using your clue and launching Firefox from command line using “MOZ_GTK_TITLEBAR_DECORATION=client firefox” solves this. However, I have no clue what to do to make this work from GUI. This post suggests adding “export MOZ_GTK_TITLEBAR_DECORATION=client” to my ~/.bash_profile but this literally does nothing to me, even once I restart/re-source. Any clues what to do now?

            • This reply was modified 3 years, 2 months ago by jdxU5NGdbc.
            #58672
            Anonymous

              in response to your latest post, I performed a followup websearch
              startpage.com
              query: “export MOZ_GTK_TITLEBAR_DECORATION=client”

              The #1 search result provides an exact solution//answer to the “Any clues what to do now?”

              The #2 search result, an archWiki page, provides several related tips, good reading

              .

              #58699
              Member
              jdxU5NGdbc

                I’m not freaking stupid man, I literally cited the first link in my comment and told that suggested solution inside doesn’t work and I’ve read the second link entirely and nothing worked from there either.

                • This reply was modified 3 years, 2 months ago by jdxU5NGdbc.
                • This reply was modified 3 years, 2 months ago by jdxU5NGdbc.
                #58705
                Anonymous

                  Okay, it’s time for me shrug and back outa this topic.
                  FYI, here’s what I see when viewing the first post.

                  .

                  #58706
                  Anonymous

                    hi VladimirVilimaitis,

                    not sure how to permanently disable but for a session you could hit F11 for fullscreen and
                    back. it turns off the title bar.

                    #58714
                    Member
                    Xecure

                      I just tested it and it works for me with firefox-esr (default installation of antix).
                      Followed skidoo’s clues:
                      1) opened a new tab and entered “about:config”
                      2) Enabled “widget.allow-client-side-decoration” (made TRUE).
                      3) Closed the browser
                      4) Launched the browser from terminal with
                      MOZ_GTK_TITLEBAR_DECORATION=client firefox-esr
                      5) Wen to “Customize…” using the firefox menu.
                      6) Disabled titlebar

                      EDIT: To make it permanent, there are different routes:
                      1) Edit the .bashrc and add
                      export MOZ_GTK_TITLEBAR_DECORATION=client
                      With this, every time you launch firefox from terminal, it will load with client-side window decorations. Doesn’t work for .desktop launchers.
                      2) Edit the .desktop launcher, so that when you launch firefox-esr from menu or other launcher (like app-select or rofi) it will launch with the environment variable. The problem is that this will reset every time you receive a firefox update. Doesn’t work for launching from terminal.
                      3) Add the environment variable to /etc/environment, such as
                      MOZ_GTK_TITLEBAR_DECORATION=client
                      When launching an application from a launcher, it will ignore bash shell variables and instead launch in a non-interactive shell, which cannot see normal environment variables exported by .bashrc or by .profile (don’t ask me why). If you add the variables to /etc/environment it will load for all shells (I assume). This is the solution I just tried and it works after reboot.

                      • This reply was modified 3 years, 2 months ago by Xecure. Reason: permanent solution

                      antiX Live system enthusiast.
                      General Live Boot Parameters for antiX.

                      #58754
                      Member
                      jdxU5NGdbc

                        Nice, adding the environment variable to /etc/environment finally did the trick, thanks a lot bud! Just what I was looking for.

                        EDIT: how do I mark this topic as solved?

                        • This reply was modified 3 years, 2 months ago by jdxU5NGdbc.
                        #58763
                        Moderator
                        Brian Masinick

                          I’m not freaking stupid man, I literally cited the first link in my comment and told that suggested solution inside doesn’t work and I’ve read the second link entirely and nothing worked from there either.

                          I definitely do not share your sentiment in response to your inquiry and the answer provided.
                          There was no implied or direct indication.

                          Sometimes people provide potential solutions, not only for the person asking, but for general knowledge in case another person encounters a similar issue. In fact, the information provided allowed Xecure to follow, try a few things, and ultimately provide a solution that worked.

                          I definitely do not consider anyone in this forum “stupid”, and I ask people to use “friendly” words, even when we are personally frustrated with a problem. Kind, appreciative words prevent angry responses and misunderstandings. Please refrain from using words like “freaking stupid”; instead ask if the information was repeated for clarity, emphasis, accidentally repeated in error, or whatever. Doing it that way allows for friendly, positive dialogue, the kinds of exchanges that we prefer to use as often as possible. Thanks for your understanding.

                          • This reply was modified 3 years, 2 months ago by Brian Masinick.

                          --
                          Brian Masinick

                        Viewing 11 posts - 1 through 11 (of 11 total)
                        • You must be logged in to reply to this topic.