Cant access ftp in zzzfm live-boot

Forum Forums Official Releases antiX-23 “Arditi del Popolo Cant access ftp in zzzfm live-boot

  • This topic has 6 replies, 3 voices, and was last updated May 28-10:40 am by Lightning77.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #143626
    Member
    Lightning77

      I am trying to learn antix first then want to install it and so i checked some common featues that i always use commonly i am ok with rox term but my fav is lxterminal but it has libelogind as dep so i dont want to install it then i used zzzfm tried to access my ftp share but didnt worked i have mostly worked is systemd based distros like Kali and Debian LXDE(using right now) so i dont know that much about runit but have to say antix is the best distro if you can master the default packages comes with it so i have a aim to learn abt every utility in this distro and want to install and use it for most efficiency so i can use apache but cant install mysql it comes with a error cant start mysql and exits during installtion so is there way to access ftp in zzzfm and install mysql in antix runit currently i have base iso and forgot to mention i used antix 23 full sysvinit version after kali but in that mysql did fine and live boot iso was antix 23.1 runit base

      • This topic was modified 3 weeks, 2 days ago by Lightning77.
      #143628
      Member
      MasterPythoner

        currently i have base iso

        base images excludes many packages.
        try with full version

        #143629
        Member
        Lightning77

          But i also tried in antix 23 sysvinit full iso didnt work

          #143630
          Member
          Robin

            Cant access ftp in zzzfm

            This is a debian issue. The package curlftpfs you need for this functionality in zzzfm is missing in debian bookworm for some strange reason, see https://packages.debian.org/search?keywords=curlftpfs , while it is present in bullseye and also in sid.

            Please use gFTP from the antiX main menu, section internet until the situation is resolved by debian. This is present by default in antiX 23.1 full.

            ———————-
            Update: Alternative.

            As reported by this site https://unix.stackexchange.com/questions/759979/is-curlftpfs-missing-in-debian-12 you can install the old package from bullseye as an alien package on bookworm:

            $ wget http://deb.debian.org/debian/pool/main/c/curlftpfs/curlftpfs_0.9.2-9+b1_amd64.deb
            $ sudo apt install ./curlftpfs_0.9.2-9+b1_amd64.deb

            (In case you have a 32 bit system, select the package download and checksum from https://packages.debian.org/bullseye/i386/curlftpfs/download )

            Please make sure to check the checksum of the downloaded package against the information found at the bottom of this site: https://packages.debian.org/bullseye/amd64/curlftpfs/download before installing it:

            $ shasum -a256 ./curlftpfs_0.9.2-9+b1_amd64.deb

            which must return the checksum string found on the above page.
            55449ce91bf422999bab5b684997a8a5bd7b8748cd69a07ad33f67e652628cb0
            If not, retry the download.

            (Have not tested this workaround myself until now, but I reckon zzzFM will be able to mount remote folders on ftp servers after this again.)

            Tested: This works like a charm on antiX 23.1 full runit 64 bit. Once you have installed this missing package as an alien from the oldstable debian version bullseye, zzzFM connects cleanly to remote ftp and sftp servers, and mounts the folders so you can access the files in them by zzzFM, no need to use gFTP.

            Additional hint: You are expected to enter the credentials along the URL following the pattern in zzzFM:
            ftp://user:password@address:port

            e.g.

            ftp://robin:mysecretpassword@192.168.178.37:2615

            • This reply was modified 3 weeks, 2 days ago by Robin. Reason: Alternative found
            • This reply was modified 3 weeks, 2 days ago by Robin. Reason: Package from bullseye works fine on antiX 23.1 (bookworm based)
            • This reply was modified 3 weeks, 2 days ago by Robin. Reason: And tested

            Windows is like a submarine. Open a window and serious problems will start.

            #143732
            Member
            Lightning77

              Thanks for your help Robin It was really helpful The Only thing stops me right now is mysql i have a question Is mysql is installable and usable in antiX 23.1 runit I tested in Antix 23 Sysvinit and It worked alright but when i tried in antix 23.1 runit live boot during installation an error came “Starting Mysql server… Unable to start mysql server error during installation ” and mysql is imp for me as now it is a subject in semester so Thats the only thing stops me right now

              #143743
              Member
              Robin

                I have never used mysql, but maybe this could help you to figure how to make it work on a runit based system like antiX :

                https://repology.org/project/mariadb-runit/packages

                It contains the needed runit service script for mariadb, which is a fork of mysql.

                When downloading that package from Artix (sic!) manually and extract it, you’ll get a single script named run to be placed in
                /etc/runit/sv/mariadb
                It contains the lines:

                #!/bin/sh
                [ ! -d /run/mysqld ] && mkdir -p /run/mysqld
                chown mysql:mysql /run/mysqld
                exec chpst -u mysql:mysql mysqld --user=mysql 2>&1

                I hope you can derive from that what you need to add to your system to make mysql start properly on antiX 23.1 runit.

                ——————
                P.S.: I’d suggest to place different questions always in separate threads with proper header line so users can find the solutions found by reading the header line later. Also, then you’ll get more answers on the second issue not mentioned by the header line too.

                Windows is like a submarine. Open a window and serious problems will start.

                #143747
                Member
                Lightning77

                  Thanks for the Help I will try it

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.