Can’t type in Vietnamese

Forum Forums New users New Users and General Questions Can’t type in Vietnamese

  • This topic has 27 replies, 8 voices, and was last updated Mar 24-12:42 pm by Xunzi_23.
Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • #137052
    Member
    manhdien

      Hello everyone , my name is Dien. I’d finished install and using antix for 2 days now but because i’m a vietnamese so i need to type vietnamese in order to work. But somehow after a whole full day trying to fingure it out how to type in Vietnamese. I’m pretty frustrated because i have a laptop at home using Mint and everything is so simple but now i’m stuck at this issue.Everything is ok, i have no problem with the distro at all, but without being able to type in vietnamese i think i might just change the distro.So my last effort is to seek help before i change to probably mint xfce.Can someone help , i would be extremely gratefull.

      #137061
      Member
      Xunzi_23

        Hallo Dien, welcome to the forum.
        interesting subject, would you please let us know what you have tried already.
        A few years ago I failed to get unikey working on Mint. Good to know that has changed.

        I assume you want to use ibus unikey.
        https://www.unikey.org/en/
        If you have not done so already. To install unikey just do sudo apt update then sudo apt -y install ibus-unikey
        https://github.com/BambooEngine/ibus-bamboo might also be some help

        Please do remember Mint has a much larger development team as does the distro it is based on, it is though a
        derivative of the debian Family, I am unsure if others are using antiX in Viet lang.

        My interest is based on having a very good friend in HoChiMinh. I want to gift a Laptop on my next visit and
        Vietnamese support will be needed. She will want to write in Vietnamese and Cantonese for her work.

        • This reply was modified 3 weeks, 5 days ago by Xunzi_23.
        #137118
        Member
        manhdien

          I had installed fcitx and ibus with unikey from the software installer without any problem , but it seem like both of them don’t work at all. And i don’t know how to install the BambooEngine

          #137120
          Member
          abc-nix

            Source: https://software.opensuse.org//download.html?project=home%3Alamlng&package=ibus-bamboo
            For Debian 12 run the following:
            Keep in mind that the owner of the key may distribute updates, packages and repositories that your system will trust (more information).

            echo 'deb http://download.opensuse.org/repositories/home:/lamlng/Debian_12/ /' | sudo tee /etc/apt/sources.list.d/home:lamlng.list
            curl -fsSL https://download.opensuse.org/repositories/home:lamlng/Debian_12/Release.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/home_lamlng.gpg > /dev/null
            sudo apt update
            sudo apt install ibus-bamboo
            #137124
            Member
            manhdien

              How about i reinstall antix, does it do any helps ?

              #137125
              Member
              Xunzi_23

                Hallo Dien, pls be patient, we are trying to get you running what you need.
                Have you already installed the package for Viet Language.

                sudo apt -y install fcitx5-unikey

                abc-nix told how to install Bamboo Engine

                If we get Viet language input running correctly you will be a great additional
                community member.

                Later I will try and get The input working on a live system. There may be a setup
                step we are missing.

                #137129
                Member
                Xunzi_23

                  Hallo Dien, difficult as I do not read or speak vietnamese,

                  I have now been able to type VN characters and setup libreoffice with VN Language pack so all is not lost.

                  I really need a Viet person to continue, will
                  try and do more in a telegram conference with my friend in HochiMinh later, she should have off work day today.

                  The screenshot of a synaptic window shows a multiple of packages installed. Configuring was easy enough using
                  menu entrys and selecting a VN keyboard in controll center.

                  I recommend to try big changes running from a live USB stick, if you get good results remaster, if problems just
                  reboot. Better than reinstalling for sure. Once things work as expected please let us write a how to.

                  Attachments:
                  #137134
                  Member
                  manhdien

                    I managed to install ibusbamboo following abc-nix instructions but it’s english bamboo not vietnamese and for the fcitx after installing unikey and all that it’s just a blank screen

                    • This reply was modified 3 weeks, 4 days ago by manhdien.
                    #137142
                    Member
                    Xunzi_23

                      Which antiX version are you using, I tested live with antiX 23.1.
                      I think something is still wrong with your keyboard configuration.

                      https://github.com/BambooEngine/ibus-bamboo
                      Gives instructions in Vietnamese.
                      please also do below step in the terminal to configure the system, I added sudo to the command from Bamboo page.
                      You need to run the command in the terminal, it is an important step.

                      sudo env DCONF_PROFILE=ibus dconf write /desktop/ibus/general/preload-engines “[‘BambooUs’, ‘Bamboo’]” && gsettings set org.gnome.desktop.input-sources sources “[(‘xkb’, ‘us’), (‘ibus’, ‘Bamboo’)]”

                      For unikey more info on https://www.unikey.org/

                      #137143
                      Member
                      manhdien

                        it popped up this massage

                        • This reply was modified 3 weeks, 4 days ago by manhdien.
                        #137150
                        Member
                        Xunzi_23

                          I did not get that error, the forum software may have messed up the command, pls copy it from
                          https://github.com/BambooEngine/ibus-bamboo
                          and try again

                          #137153
                          Member
                          Robin

                            the forum software may have messed up the command

                            When will you ever start using the code tags provided by the forum? These exist precisely to avoid this kind of messing up commands 🙂 You even don’t need to key in them manually, there is a button you can click once marked the lines you want to have included within them, right above the message entry field…

                            Attachments:

                            Windows is like a submarine. Open a window and serious problems will start.

                            #137164
                            Member
                            manhdien

                              so what’s next ?

                              Attachments:
                              #137192
                              Member
                              Xunzi_23

                                Sorry I had to get some work done outside, before the rain starts again,
                                will see if I can figure out a resolution tomorrow morning.

                                Means I will run live and record every step I take and hope
                                I can again type Vietnamese characters.
                                Unless someone else has a better way or can join in for now.

                                • This reply was modified 3 weeks, 4 days ago by Xunzi_23.
                                #137253
                                Member
                                Xunzi_23

                                  Hi Dien, what I see in the screenshots is can not connect to Ibus,
                                  we still do not know exactly what version of antiX you are using.

                                  If sysV init pls check if ibus is running, the command service ibus status
                                  is I think correct. Sorry old memory is not perfect.

                                  If you are using runit as I do pls use the runit service manager from settings menu
                                  and ensure ibus is up and set to start on boot.

                                  then try again to use the VN keyboard.

                                  I have a number of jobs to do today so will be away from the computer much of the time.
                                  maybe good for you to use Mint as you say it works good until we can get setting up antiX
                                  for typing Vietnamese in to an immediately usable state. I do my best but sometimes it is
                                  not good enough.

                                Viewing 15 posts - 1 through 15 (of 28 total)
                                • You must be logged in to reply to this topic.