Can’t type in Vietnamese

Forum Forums New users New Users and General Questions Can’t type in Vietnamese

  • This topic has 27 replies, 8 voices, and was last updated Mar 24-12:42 pm by Xunzi_23.
Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
    Posts
  • #137262
    Moderator
    caprea

      Try to start the ibus daemon from terminal with
      ibus-daemon -d
      Please also post
      inxi -zv7
      so we finally know which antiX you are using

      #137264
      Member
      verdy

        Hello manhdien,

        I use Fcitx for Japanese input.
        It is quick and easy to install Fcitx from Package Installer (Fcitx5 is not available).
        In the case of antiX, Fcitx cannot be used just by installing the package. Manual configuration required.
        Edit the two files.
        ~/.desktop-session/startup
        ~/.desktop-session/desktop-session.conf

        Control Center -> Session -> User Desktop Session
        Open startup, add the following and save.

        # fcitx-autostart
        fcitx-autostart &

        Next, open desktop-session.conf, add the following, and save.

        # set fcitx
        export GTK_IM_MODULE=fcitx
        export QT_IM_MODULE=fcitx
        export XMODIFIERS=@im=fcitx
        export DefaultIMModule=fcitx

        export DefaultIMModule=fcitx seems to work even if commented out.

        Once you logout and login, start Fcitx Configuration.
        In the “Add input method” dialog, if you cannot find the input method you want to use, uncheck “Only Show Current Language”.
        Sorry, I don’t know about BambooEngine.

        #137266
        Member
        manhdien

          Update : well i managed to add the Unikey input into the ibus daemon but still no desired result .Usually when i press w instead of giving out W , i should give me a “ư” .which is the word that i want . That is what us Vietnamese call the Unikey way of typing and i can choose another input in the ibus daemon it works (i can type in Vietnamese but not the usual Unikey but the very odd and awkward way shall i say). Should i switch to fcitx ?, but the problem with fcitx is after i follow all of the instructions from you guys and chat GPT etc, i would still get a blank input method in fcitx.

          • This reply was modified 3 weeks, 3 days ago by manhdien.
          • This reply was modified 3 weeks, 3 days ago by manhdien.
          • This reply was modified 3 weeks, 3 days ago by manhdien.
          #137278
          Member
          Robin

            i would still get a blank input method in fcitx.

            Your second screenshot shows clearly you have not followed verdys advice:

            if you cannot find the input method you want to use, uncheck “Only Show Current Language”.

            Please uncheck that checkbox.

            Windows is like a submarine. Open a window and serious problems will start.

            #137375
            Member
            Xunzi_23

              Hi manhdien,
              I hope you are now up and running with Viet Language.
              Yesterday evening I got Bamboo engine with unikey working, As yet latest libreoffice
              is not properly accepting input in Viet language. I will try again with a slightly older
              version later today.
              I took a Debian build fitting my antiX 23.1 version from
              https://software.opensuse.org//download.html?project=home%3Alamlng&package=ibus-bamboo
              AntiX 23.1 is based on Debian 12 so I did below

              echo 'deb http://download.opensuse.org/repositories/home:/lamlng/Debian_12/ /' | sudo tee /etc/apt/sources.list.d/home:lamlng.list
              curl -fsSL https://download.opensuse.org/repositories/home:lamlng/Debian_12/Release.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/home_lamlng.gpg > /dev/null
              sudo apt update
              sudo apt install ibus-bamboo

              I had to add

              export GTK_IM_MODULE=ibus
              export XMODIFIERS=@im=ibus
              export QT_IM_MODULE=ibus
              to /home/myusername/.bashrc

              and do
              sudo env DCONF_PROFILE=ibus dconf write /desktop/ibus/general/preload-engines "['BambooUs', 'Bamboo']" && gsettings set org.gnome.desktop.input-sources sources "[('xkb', 'us'), ('ibus', 'Bamboo')]"

              Before I could finally add the VN Keyboard in controll center.
              I found some useful tips on below page, ubuntu is debian based so similar in many ways.
              https://itsmeit.co/install-ibus-bamboo-or-ibus-unikey-on-ubuntu.

              I am trying to find and contact a Debian or active Linux user group in Vietnam to ask for further assistance,

              Many users in VN have old low powered computers, a freely downloadable fully working antiX setup would be highly advantageous for them.
              I write freely downloadable having seen individuals in VN trying to cash in on buntu and debian.

              #137597
              Member
              chinguskhan

                Usually when i press w instead of giving out W , i should give me a “ư” .which is the word that i want .

                hello manhdien, there is an option for this in the settings. start ibus and switch it to vietnamese layout, then click on the ibus system tray icon, click on “more settings” and enable “standalone w as ư”. also, you should set “output charset” to unicode if you haven’t already.

                hi xunzi, my installation of vietnamese ibus was much simpler than yours. all i had to do was this.
                sudo apt install --install-recommends ibus-unikey
                after that, add “vietnamese – unikey” as an input method. in the settings of that keyboard layout, i set input method as extend telex and output charset as unicode. and of course there is spell check and w as ư for users like manhdien. with this configuration i was able to type vietnamese in libreoffice writer without any hiccups. you can ask me for help with any vietnamese stuff.

                • This reply was modified 2 weeks, 6 days ago by chinguskhan.
                #137601
                Member
                calciumsodium

                  hi xunzi, my installation of vietnamese ibus was much simpler than yours. all i had to do was this.
                  sudo apt install --install-recommends ibus-unikey
                  after that, add “vietnamese – unikey” as an input method. in the settings of that keyboard layout, i set input method as extend telex and output charset as unicode. and of course there is spell check and w as ư for users like manhdien. with this configuration i was able to type vietnamese in libreoffice writer without any hiccups. you can ask me for help with any vietnamese stuff.

                  Chao @chinguskhan,

                  I installed the ibus-unikey as you suggested. In libreoffice, I cannot get the words to convert to Vietnamese. I have the settings for input to extend telex and output char as unicode, as you suggested. But I can’t seem to make it work. What am I missing? I can read and write in Vietnamese, but I have never typed in Vietnamese. I also tried to set the keyboard to Vietnamese in the control centre. But that I still cannot get words to convert to Vietnamese. Thanks for your help.

                  Attachments:
                  #137609
                  Member
                  chinguskhan

                    from the screenshot, your version of antix seems old. on a fresh live usb of antix 23.1, i followed all my steps and was able to type vietnamese in libreoffice writer. the problem is probably caused by the difference in versions so could you tell us what your antix version is?

                    #137635
                    Member
                    calciumsodium

                      Chao @chinguskhan,

                      Tôi biên tiếng việt

                      cám ơn

                      Attachments:
                      #137652
                      Member
                      manhdien

                        Hey guys, you have been very helpful and supportive and I am very grateful for that but i had just gave up , no matter what i tried , i just simply couldn’t get it to work. Thank you so much for spending precious time helping me, i really appreciate it. Sorry for the bad English.

                        #137663
                        Member
                        chinguskhan

                          Hey guys, you have been very helpful and supportive and I am very grateful for that but i had just gave up , no matter what i tried , i just simply couldn’t get it to work. Thank you so much for spending precious time helping me, i really appreciate it. Sorry for the bad English.

                          it doesn’t have to be that way. here’s a video tutorial in vietnamese if you couldn’t understand the text instructions.

                          #137664
                          Member
                          calciumsodium

                            chào anh Dien,

                            I understand your frustration. I could not get it to work for a while also. I was following this thread and trying out the instructions for the ibus-bamboo. I think that is the problem.

                            That video that @chinguskhan pointed to is very good. I will also try to give instructions via text.

                            This is what I did to make it work.

                            So I started fresh on a system where I did not do anything related to the instructions for ibus-bamboo. Start from scratch.

                            1. I updated.

                            
                            sudo apt update
                            

                            2. I installed the ibus-unikey

                            
                            sudo apt install --install-recommends ibus-unikey
                            

                            On my system, it will download about 31 Mb of files and then expand to another 117 Mb of files.
                            Just to safe, reboot after successful installation.

                            3. Start ibus. This is what I do in terminal:

                            
                            ibus-daemon -d
                            

                            The video does it a little bit different:
                            ibus start

                            4. Add the ibus vietnamese-unikey.
                            You will see a ibus keyboard icon on the lower right of the screen at the bottom.
                            Right click on it.
                            Select Preferences.
                            At the top, click Input Method.
                            Click Add on the right side.
                            Click the three vertical dots at the bottom of this new pop up window.
                            Scroll all the way down and select Vietnamese
                            Select Unikey and click Add.
                            You should now see Vietname Unikey in the Ibus Preferences window.
                            Then Close the Ibus Preferences window.

                            5. To start the vietnamese ibus-unikey,
                            Left click on the ibus keyboard icon on the lower right of the screen.
                            Select Vietanese unikey.

                            Now start any application you want to use.
                            As for specifics of vni vs telex methods, you will have to figure that out.
                            The default is telex.

                            Hope this helps.

                            • This reply was modified 2 weeks, 6 days ago by calciumsodium.
                            #137668
                            Member
                            Xunzi_23

                              Thanks to all who jumped in and gave help and instructions, I could use unikey and bamboo
                              but getting there was a somewhat daunting task.

                              I will start again with a fresh download of antiX 23.1 next days, and follow the thread
                              as well as watching the video from chinguskahn.

                              @mahndien, please keep following, I understand your frustration but you were the person who
                              got this search for easily workable solutions rolling, on top the results will be very useful
                              for any user wanting to use VN Language input feature in future.

                            Viewing 13 posts - 16 through 28 (of 28 total)
                            • You must be logged in to reply to this topic.