change default system font in rox-icewm?

Forum Forums General Software change default system font in rox-icewm?

  • This topic has 14 replies, 5 voices, and was last updated Aug 3-2:07 pm by Aetherna.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #39724
    Member
    AvatarAetherna

    as in the topic.
    How can I change system font inrox-icewm?

    thank you for the help.

    #39725
    Forum Admin
    anticapitalistaanticapitalista

    Menu > Control Centre > Customize Look and Feel > Default font

    You may also want to edit ~/.config/rox.sourceforge.net/ROX-Filer/Options
    see line <Option name="label_font">Ubuntu 10.5</Option>

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #39726
    Member
    Avatarseaken64

    Have you explored the Control Centre? Maybe Edit IceWM Settings. Preferences.

    There are some font settings in there though I haven’t messed with them myself.

    I would guess that it will be a text config file in antiX rather than a GUI tool.

    We’re probably going to need anticapitalista’s help for the specifics.

    Seaken64

    Yep, nija’d by anti.

    • This reply was modified 1 month, 3 weeks ago by seaken64.
    #39728
    Member
    Avatarseaken64

    I missed the setting in Customize Look and Feel at first. I clicked on the Fonts tab and that didn’t have anything. The setting is on the first tab named Widget under the preview box.

    #39731
    Member
    AvatarAetherna

    Menu > Control Centre > Customize Look and Feel > Default font

    You may also want to edit ~/.config/rox.sourceforge.net/ROX-Filer/Options
    see line <Option name="label_font">Ubuntu 10.5</Option>

    editing ~/.config/rox.sourceforge.net/ROX-Filer/Options
    is the solution

    Font options in CC only let user to select Antialiasing, Hinting and Sub-pixel geometry.

    thank you,
    problem solved.

    • This reply was modified 1 month, 3 weeks ago by Aetherna.
    #39733
    Member
    AvatarAetherna

    Menu > Control Centre > Customize Look and Feel > Default font

    You may also want to edit ~/.config/rox.sourceforge.net/ROX-Filer/Options
    see line <Option name="label_font">Ubuntu 10.5</Option>

    editing ~/.config/rox.sourceforge.net/ROX-Filer/Options
    is the solution

    Font options in CC only let user to select Antialiasing, Hinting and Sub-pixel geometry.

    thank you,
    problem solved.

    I am sorry,
    upon closer look, fonts are unchanged (e.g. menu font, clock font)

    Note: is it possible that this failure (of changing font) is related to ttf vs otf?
    I want to use otf font format. otf is just extended ttf so apps recognizing ttf should read otf but I don’t know much about rox-icewm

    • This reply was modified 1 month, 3 weeks ago by Aetherna.
    #39737
    Member
    Avatarseaken64

    The “font” tab does only change the Antialiasing, Hinting and Sub-pixel geometry. Look at the tab named “Widget” to change the default font.

    Seaken64

    #39742
    Member
    AvatarAetherna

    thank you,
    changing font in Widgets works only partially:
    icewm menu is left without changes. Apps title bar are not changed, clock not changed.
    App names (when I hover mouse over toolbar) without changes.

    what changed: applications toolbar, icons name within file manager.

    Also changing font in conky (CC -> Edit System Editor) does not work.

    Changing font in Firefox worked (I created userChrome.css file – this always works)

    • This reply was modified 1 month, 3 weeks ago by Aetherna.
    #39744
    Member
    Avatarseaken64

    The IceWM stuff is probably changed in the “Preferences” in the “Edit IceWM Settings”. It’s a huge file. Cntrl-F to search for “font”.

    #39766
    Member
    AvatarAetherna

    The IceWM stuff is probably changed in the “Preferences” in the “Edit IceWM Settings”. It’s a huge file. Cntrl-F to search for “font”.

    Thank you again for helping.

    I accessed “Edit IceWM Settings” from CC.
    I could not find an option referring to font settings.

    Maybe IceWM currently does not allow to change system font?

    #39767
    Forum Admin
    anticapitalistaanticapitalista

    There is a post somewhere in this forum about doing this, but I can’t find it at the moment.
    Things like font used in the IceWM menu and toolbar are controlled by the chosen theme.
    They can be overridden IIRC with an entry in ~/.icewm/preferences.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #39771
    Member
    AvatarAetherna

    There is a post somewhere in this forum about doing this, but I can’t find it at the moment.
    Things like font used in the IceWM menu and toolbar are controlled by the chosen theme.
    They can be overridden IIRC with an entry in ~/.icewm/preferences.

    Thank you again,
    I will try to experiment with the file.

    #39773
    Member
    AvatarModdIt

    Hi all there are a lot of themes for ICEWM
    @ https://www.box-look.org
    also ICEWM themes package
    Themes change fonts as anticapitalisa states

    You can in most cases change fonts more easily in the theme to get a harmonius result..

    #39775
    Member
    XecureXecure

    Change fonts for GTK programs: Look and Feel (LXappearance)
    Change fonts for QT programs: QT5 Settings (qt5ct)
    Change icewm fonts (theme only): edit theme configuration file.
    Change icewm fots (override all font configurations): edit ~/.icewm/prefoverride
    https://www.antixforum.com/forums/search/prefoverride+font/

    From https://ice-wm.org/man/icewm-preferences
    Fonts

    – TitleFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – TitleFontNameXft=”sans-serif:size=12”
    Name of the title bar font.

    – MenuFontName=”-*-sans-bold-r-*-*-*-100-*-*-*-*-*-*”
    – MenuFontNameXft=”sans-serif:size=10:bold”
    Name of the menu font.

    – StatusFontName=”-*-monospace-bold-r-*-*-*-120-*-*-*-*-*-*”
    – StatusFontNameXft=”monospace:size=12:bold”
    Name of the status display font.

    – QuickSwitchFontName=”-*-monospace-bold-r-*-*-*-120-*-*-*-*-*-*”
    – QuickSwitchFontNameXft=”monospace:size=12:bold”
    Name of the font for Alt+Tab switcher window.

    – NormalButtonFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – NormalButtonFontNameXft=”sans-serif:size=12”
    Name of the normal button font.

    – ActiveButtonFontName=”-*-sans-bold-r-*-*-*-120-*-*-*-*-*-*”
    – ActiveButtonFontNameXft=”sans-serif:size=12:bold”
    Name of the active button font.

    – NormalTaskBarFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – NormalTaskBarFontNameXft=”sans-serif:size=12”
    Name of the normal task bar item font.

    – ActiveTaskBarFontName=”-*-sans-bold-r-*-*-*-120-*-*-*-*-*-*”
    – ActiveTaskBarFontNameXft=”sans-serif:size=12:bold”
    Name of the active task bar item font.

    – ToolButtonFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – ToolButtonFontNameXft=”sans-serif:size=12”
    Name of the tool button font (fallback: NormalButtonFontName).

    – NormalWorkspaceFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – NormalWorkspaceFontNameXft=”sans-serif:size=12”
    Name of the normal workspace button font (fallback: NormalButtonFontName).

    – ActiveWorkspaceFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – ActiveWorkspaceFontNameXft=”sans-serif:size=12”
    Name of the active workspace button font (fallback: ActiveButtonFontName).

    – MinimizedWindowFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – MinimizedWindowFontNameXft=”sans-serif:size=12”
    Name of the mini-window font.

    – ListBoxFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – ListBoxFontNameXft=”sans-serif:size=12”
    Name of the window list font.

    – ToolTipFontName=”-*-sans-medium-r-*-*-*-120-*-*-*-*-*-*”
    – ToolTipFontNameXft=”sans-serif:size=12”
    Name of the tool tip font.

    – ClockFontName=”-*-monospace-medium-r-*-*-*-140-*-*-*-*-*-*”
    – ClockFontNameXft=”monospace:size=12”
    Name of the task bar clock font.

    – TempFontName=”-*-monospace-medium-r-*-*-*-140-*-*-*-*-*-*”
    – TempFontNameXft=”monospace:size=12”
    Name of the task bar temperature font.

    – ApmFontName=”-*-monospace-medium-r-*-*-*-140-*-*-*-*-*-*”
    – ApmFontNameXft=”monospace:size=12”
    Name of the task bar battery font.

    – InputFontName=”-*-monospace-medium-r-*-*-*-140-*-*-*-*-*-*”
    – InputFontNameXft=”monospace:size=12”
    Name of the input field font.

    – LabelFontName=”-*-sans-medium-r-*-*-*-140-*-*-*-*-*-*”
    – LabelFontNameXft=”sans-serif:size=12”
    Name of the label font.

    • This reply was modified 1 month, 3 weeks ago by Xecure.
    #39780
    Member
    AvatarAetherna

    I was able to change menu font by editing:
    /usr/share/icewm/themes/current-theme-used/default.theme

    last part, change font of desktop icons

    having experience with openbox, icewm seems quite convoluted if one wants to customize it 🙂

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.