Clean out redundant windoze partition & resize antix

Forum Forums New users New Users and General Questions Clean out redundant windoze partition & resize antix

  • This topic has 13 replies, 5 voices, and was last updated May 10-7:20 pm by Budgie.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #59020
    Member
    Budgie

    I am doing some housekeeping on an old 32bit machine which did have a dual boot facility. This has not been used for a while, the details have been lost to me and the machine only boots to Antix, which is fine but I have no idea where grub is installed and upgrading has thrown up a grub question I cannot answer.

    At present there are four partitions on the drive, windoze, Antix /, Antix home and swap. What I want to do is to delete the unwanted hpfs/ntfs partition, move my Antix root partition to the start of the drive, grow it a bit and then expand my home partition to fill the unused space.

    I am on another machine temporarily so cannot give you fdisk -l output but my concern is making sure I do not lose boot capability during the process. Please could I have some guidance on when to do what and on rebuilding the boot configuration without making a mistake.

    #59042
    Member
    linuxdaddy
    Helpful
    Up
    0
    :D

    hi Budgie,

    First thing is to backup anything on the machine you need to save. You are going to have to boot it from
    a live antiX cd/dvd and see if gparted can delete the windows partition and resize the root partition and
    home partitions.
    After resizing with gparted and before rebooting …. you can run boot repair from the system menu on
    the live cd. grub should be on the mbr of the hard drive.
    Can you boot into the old 32-bit machine and post the terminal output of
    inxi -Fxz
    and
    sudo fdisk -x
    here so others can help assist.

    • This reply was modified 1 month, 1 week ago by linuxdaddy. Reason: added to it

    Normal == 🙂
    depends on the surrounding crowd ?!

    #59069
    Member
    Budgie
    Helpful
    Up
    0
    :D

    Hi linuxdaddy,
    After a bit of time and thought I worked out that live antiX was required. My machine told me it had not been used for 388 days so there was significant work to be done. Live usb stick worked very well, a few errors on the windoze partition but I was able to keep it and do all the housekeeping and was feeling pleased with myself before I started the updates & upgrades. I now have antiX working but quite a bit has been changed and I have a “shopping list.”

    I read the news on certificate fix which worked and then:-

    My touchpad (Dell Inspiron 9300 laptop) has become so sensitive it is unuseable. Read many threads about MX Touchpad-indicator and synclient and found the conf file but settings far too cryptic for this simple soul and although the discussion was interesting nobody gave me useful instructions on how to tame my touchpad so hereI am on bended knee!

    I find that although my time and date settings areall correct and showing time in 24 hour as I want, Conky insist on showing the time in 12 hour format. The settings are configurable but there is no syntax help for the time format which is not set. Couldn’t find the relevant man page for the format syntax for “time” in Conky so please can somebody help.

    Also in Conky but I suspect an underlying issue with connman and change of names for network connections but although I am using wifi only as I type Conky still referes to eth0 and eth1 and not a W in sight. Also when working with pCloud drive, which itself has all kinds of problems on my 32 bit antiX devices I am receiving a “no internet connection” message although the connection is still working.

    Too tired now but if anybody can help me please to diagnose the issues it would be very much appreciated.
    In spite of all this I still love antiX and it continues to be the best.
    Budgie

    #59070
    Member
    skidoo
    Helpful
    Up
    0
    :D

    ~/.conkyrc
    find
    {time %I:%M}
    To instead display 24H format, change to
    {time %H:%M}

    >>> find the relevant man page for the format syntax for “time” in Conky
    That’s true, and it feels like a cruel joke.
    The conky mangpage refers us to “man strftime” (which is not available).
    Via “apropos time” you can discover “man date”, and that we must use “date” command to adjust the TIME…

    #59071
    Member
    seaken64
    Helpful
    Up
    0
    :D

    Hi Budgie, you should consider starting a new topic. Your topic title does not match your current queries and maybe some won’t check it out.

    Seaken64

    #59089
    Member
    Budgie
    Helpful
    Up
    0
    :D

    ~/.conkyrc
    find
    {time %I:%M}
    To instead display 24H format, change to
    {time %H:%M}

    >>> find the relevant man page for the format syntax for “time” in Conky
    That’s true, and it feels like a cruel joke.
    The conky mangpage refers us to “man strftime” (which is not available).
    Via “apropos time” you can discover “man date”, and that we must use “date” command to adjust the TIME…

    Hi Skidoo and thanks for the reply. Sorry but the joke is too cruel and not funny. Perhaps it is “strifetime” but now I cannot find ~/.conkyrc. I have the switch conky on/off in my menu and it works but no file in my home directory. Neither do I have wlan0 in the conky display, only eth0. Any ideas?

    #59100
    Member
    Xecure
    Helpful
    Up
    0
    :D

    Perhaps it is “strifetime” but now I cannot find ~/.conkyrc

    If a file starts with a dot, it is a hidden file. Most file managers will show you all hidden files with Control+H (and rehide them with the same key binding).
    You could also launch the editor directly from terminal
    xdg-open ~/.conkyrc

    Neither do I have wlan0 in the conky display, only eth0. Any ideas?

    See how the system recognizes the network interfaces with
    iwconfig
    Some wifi devices are recognized as ethX instead of wlanX (this is driver related, I think, and doesn’t really affect normal use).

    #59118
    Member
    Budgie
    Helpful
    Up
    0
    :D

    OK, making slow progress as the pointer still has a mind of it’s own until I sort out the touchpad but to assist further, here is my system configuration at present:-

    alastair@OldDell32:~
    $ inxi -Fxz
    System:
      Host: OldDell32 Kernel: 4.9.193-antix.1-486-smp i686 bits: 32 
      compiler: gcc v: 8.3.0 Desktop: IceWM 2.3.3 
      Distro: antiX-19_386-full Marielle Franco 16 October 2019 
      base: Debian GNU/Linux 10 (buster) 
    Machine:
      Type: Portable System: Dell product: Inspiron 9300 v: N/A serial: <filter> 
      Mobo: Dell model: 0C5668 serial: <filter> BIOS: Dell v: A05 
      date: 09/19/2005 
    Battery:
      ID-1: BAT0 charge: 79.9 Wh condition: 59.3/79.9 Wh (74%) 
      model: Sanyo DELL C54475 status: Full 
    CPU:
      Topology: Single Core model: Intel Pentium M bits: 32 type: MCP 
      arch: M Dothan rev: 8 L2 cache: 2048 KiB 
      flags: pae sse sse2 bogomips: 2128 
      Speed: 1067 MHz min/max: 800/1867 MHz Core speed (MHz): 1: 1333 
    Graphics:
      Device-1: AMD RV370/M22 [Mobility Radeon X300] vendor: Dell driver: radeon 
      v: kernel bus ID: 01:00.0 
      Display: x11 server: X.Org 1.20.4 driver: ati,radeon 
      unloaded: fbdev,modesetting,vesa resolution: 1920x1200~59Hz 
      OpenGL: renderer: ATI RV370 v: 2.1 Mesa 18.3.6 direct render: Yes 
    Audio:
      Device-1: Intel 82801FB/FBM/FR/FW/FRW AC97 Audio vendor: Dell 
      driver: snd_intel8x0 v: kernel bus ID: 00:1e.2 
      Sound Server: ALSA v: k4.9.193-antix.1-486-smp 
    Network:
      Device-1: Broadcom Limited BCM4401-B0 100Base-TX vendor: Dell driver: b44 
      v: 2.0 port: de00 bus ID: 03:00.0 
      Device-2: Intel PRO/Wireless 2200BG [Calexico2] Network driver: ipw2200 
      v: 1.2.2kmprq port: de00 bus ID: 03:03.0 
      IF: eth0 state: up mac: <filter> 
      Device-3: Dell Wireless 350 Bluetooth type: USB driver: btusb 
      bus ID: 3-1:2 
      IF-ID-1: eth1 state: down mac: <filter> 
    Drives:
      Local Storage: total: 74.53 GiB used: 547.73 GiB (734.9%) 
      ID-1: /dev/sda vendor: Hitachi model: HTS548080M9AT00 size: 74.53 GiB 
    Partition:
      ID-1: / size: 14.53 GiB used: 5.41 GiB (37.2%) fs: ext4 dev: /dev/sda2 
      ID-2: /home size: 33.42 GiB used: 2.09 GiB (6.3%) fs: ext4 dev: /dev/sda3 
      ID-3: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
    Sensors:
      System Temperatures: cpu: 48.0 C mobo: N/A sodimm: 46.0 C 
      Fan Speeds (RPM): cpu: 2561 
    Info:
      Processes: 149 Uptime: 1h 34m Memory: 1.97 GiB used: 667.9 MiB (33.1%) 
      Init: SysVinit runlevel: 5 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.3 
      inxi: 3.0.36 
    alastair@OldDell32:~
    $ ^C
    alastair@OldDell32:~
    $ 
    

    You will see I am only on kernel 4.9 so no point in changing this, although I do not understand yet why it is not at 5.0.3.

    I edited /etc/conky/conky.conf to add the time parameter but this has not worked. I thought conky.conf took precedence but will edit conkyrc as you advise and see what happens.

    As for wireless this is what I have:-

    alastair@OldDell32:~
    $ iwconfig
    eth0      IEEE 802.11  ESSID:"Errichel_Guests"  
              Mode:Managed  Frequency:2.447 GHz  Access Point: 8E:DC:96:87:29:BA   
              Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
              Retry limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=88/100  Signal level=-41 dBm  Noise level=-83 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:5
    
    eth1      no wireless extensions.
    
    lo        no wireless extensions.
    
    alastair@OldDell32:~

    No idea how to sort this out. As you advised, not totally necessary but it does help to have conky display correct when sorting out APs.

    Thanks for your replies and I hope you can shed a bit more light in due course.
    Budgie

    #59149
    Member
    skidoo
    Helpful
    Up
    0
    :D

    >>> I edited /etc/conky/conky.conf to add the time parameter but this has not worked.

    1) couldn’t find the task-dedicated “button” in ControlCenter
    2) refuses a tested solution offered and tries something else
    3) something about a touchpad…

    okbye

    .

    #59152
    Member
    linuxdaddy
    Helpful
    Up
    0
    :D

    OK leaving this thread as is way off topic from original.

    Normal == 🙂
    depends on the surrounding crowd ?!

    #59157
    Member
    Budgie
    Helpful
    Up
    0
    :D

    Hi skidoo,
    I am sorry if I have offended you and assure you I have not refused your advice. I did have a problem finding my way around but did as you advised.

    Here is what undetsand is the correct way to edit the time parameter:

    #  swap                              Amount of swap in use                    
    #  swapmax                           Total amount of swap                     
    #  swapperc                          Percentage of swap in use                
    #  sysname                           System name, Linux for example           
    time                 %H:%M 
    #                                    information about format                 
    #  totaldown         net             Total download, overflows at 4 GB on     
    #                                    Linux with 32-bit arch and there doesn't 
    #                                    seem to be a way to know how many times  
    

    I hope I had this right.
    Unfortunately even after reboot the Conky time is still stubbornly showing in 12hr format even though my tray is showing 19:52:51 as I send this.
    Thanks for your time. Sorry I couldn’t fix this. Will start a new thread with correct title.

    #59158
    Member
    Budgie
    Helpful
    Up
    0
    :D

    Hi linuxdaddy,
    Understood. Thanks for your help en route. Will start new thread as appropriate.
    Regards,
    Budgie

    #59162
    Member
    Xecure
    Helpful
    Up
    0
    :D

    Hi Budgie.
    Don’t worry about the eth0 name. If you dislike to see it in the conky, edit the conky so it doesn’t specifically say eth0 and just say “network” or whatever you want.

    About editing the conky. DO this
    geany ~/.conkyrc
    Look for the line
    ${alignc}${color8}${font DejaVu Sans:size=12}${time %I:%M} ${font} ${color}
    and change %I to %H. It should look like this.
    ${alignc}${color8}${font DejaVu Sans:size=12}${time %H:%M} ${font} ${color}
    As soon as you save, the conky will regenerate with your desired change.

    Try it out

    #59167
    Member
    Budgie
    Helpful
    Up
    0
    :D

    Hi Xecure,
    Perfect and now resolved. Many many thanks.

    Will ignore the network connection as I can live with it. I have been working on two old laptops which I need to bring back into service. The IBM T42 gives the correct lan references but the Dell not.

    Thanks again,
    Regards,
    Budgie

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.