Command line install wont work

Forum Forums New users New Users and General Questions Command line install wont work

Tagged: 

  • This topic has 19 replies, 6 voices, and was last updated Feb 28-4:00 pm by jfUd3X5Oh4C5.
Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • #54737
    Member
    Avatarseaken64

    All browsers crash in antiX-17

    not sure if this the problem or not.

    Some of the browsers listed in the Package Installer won’t run on the Athlon.

    Try NetSurf and Links2. Maybe SeaMonkey version 2.49.4 or earlier.

    Seaken64

    #54824
    Member
    AvatarjfUd3X5Oh4C5

    NetSurf and Links2 suck, they can’t even run JavaScript or play YouTube videos.

    Just install GNOME Web, it works perfectly without SSE2 on an Athlon XP.

    Just install it with
    sudo apt-get install epiphany-browser

    On your CPU, YouTube videos will play at 144p with a few frame drops, but the audio will be fine.

    This is the only browser what is still updated and works without crashing on older CPUs. The Debian team compiles it in a way that it will work without SSE2. GNOME Web is using WebKit, the same engine what is being used by Safari on Macs. It supports every modern web technologies and all websites will look like exactly as they should.

    #54865
    Member
    AvatarjfUd3X5Oh4C5

    Sorry, I mixed up NetSurf with Dillo.
    NetSurf can be also an alternative, but it is basically just the same thing as Gnome Web but without a GUI. Gnome Web is user-friendly, but it consumes about 90 MB more.

    To install NetSurf, just type
    sudo apt-get install surf

    Then start from the terminal like this:
    surf antixlinux.com

    #55032
    Member
    userzerouserzero

    No.

    Surf -> Simple web browser by suckless community.
    Netsurf-gtk -> Small web browser with CSS support for GTK.

    “To set up Javascript in NetSurf, click on “Edit” and then “Preferences”. After accessing “Preferences,” click on the “Enable Javascript” button.”

    Package: netsurf-gtk
    Version: 3.10-1.0antix1

    #55153
    Member
    AvatarjfUd3X5Oh4C5

    Sorry, this time I mixed up NetSuf with Surf 😀
    Yes, userzero, you are right. Netsurf and Surf are two very different things. They have nothing in common (except their name). Thanks for rectifying my confusion.

    I tried NetSurf, and its JavaScript support is only theoretical. Nothing worked for me what required JavaScript.

    http://www.netsurf-browser.org/documentation/info.html#JavaScript

    “At present, NetSurf has only primitive and incomplete support for JavaScript, which we disable by default. Without JavaScript, NetSurf is able to provide access to most of sites on the World Wide Web. Some sites, however, will not display correctly or be unworkable due to heavy reliance on this standard.

    Full JavaScript is support is planned but we are currently a long way off achieving it. Many things need to be done before complete JavaScript support can be considered, such as changing our web page layout engine to handle dynamic changes being made to the page. JavaScript support will require a huge amount of work to complete. If you are keen to help out please visit the developer and contributor area.”

    Surf is using WebKit and therefore it is capable of rendering any website.
    NetSurf is using its own engine, and in practice it doesn’t support JavaScript.

    https://www.netsurf-browser.org/about/

    “NetSurf has its own layout and rendering engine entirely written from scratch.”

    Just to summarize, here are the web browsers (their latest version) working on an Athlon XP today:

    Gnome Web (epiphany-browser), using WebKit: can open/play/render anything, full blown web browser
    Surf (surf), using WebKit: can open/play/render anything, has minimal GUI, starts from terminal
    Firefox (firefox-esr), using Gecko: crashes when a YouTube video tries to play
    ———– line of practical everyday usability —————-
    NetSurf (netsurf-gtk), using own engine: has some CSS support, displays images, no JavaScript
    Dillo (dillo), using own engine: abandoned, has some CSS support, displays images, no JavaScript
    Links2 (links2), using own engine: graphical mode, displays images, no JavaScript
    w3m (w3m), using own engine: text mode, displays images in xterm, no JavaScript
    Lynx (lynx), using own engine: text only, no JavaScript

Viewing 5 posts - 16 through 20 (of 20 total)
  • You must be logged in to reply to this topic.