Configuring Sound on IBM T42

Forum Forums New users New Users and General Questions Configuring Sound on IBM T42

Tagged: 

  • This topic has 9 replies, 5 voices, and was last updated Dec 31-9:00 am by Anonymous.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #4404
    Member
    Budgie

      Please could I have some guidance on getting sound to work on my T42 laptop. I have installed the restricted codecs and tried to use the Control Centre > Hardware controls to get things working but no luck so far. I cannot get any test sound to work and if I try and play an mp3 file I get a couldn’t open audio error box opening.
      Is it a driver issue?

      #4410
      Anonymous

        ? What is the output of sudo lspci -v | grep -i audio
        ? What is the output of lsmod |grep audio
        ? What is the output of sudo aplay -l

        #4413
        Forum Admin
        rokytnji

          Make sure sound chip is turned on in bios first.

          • This reply was modified 6 years, 5 months ago by rokytnji. Reason: Frigging phone spell checket

          Sometimes I drive a crooked road to get my mind straight.
          I don't suffer from insanity. I enjoy every minute off it.
          Motorcycle racing is rocket science.

          Linux Registered User # 475019
          How to Search for AntiX solutions to your problems

          #4422
          Moderator
          caprea

            If you already tried in antiX Control Center under hardware to choose the default soundcard,
            and looked in soundsystem if anything is muted
            and tried turning the hardware volume up with the keyboard buttons,
            post please also the output of
            inxi -Axxx
            and
            aplay /usr/share/sounds/alsa/Front_Center.wav

            #4423
            Member
            Budgie

              Hi and thanks for the reply. Here are the results:-

              alastair@antix1:~$ inxi -Axxx
              Audio:     Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
                         driver: snd_intel8x0 ports: 1c00 18c0 bus-ID: 00:1f.5 chip-ID: 8086:24c5
                         Sound: Advanced Linux Sound Architecture v: k4.10.5-antix.1-486-smp
              alastair@antix1:~$ 
              

              now there is another antix surprise. When I ran the command in terminal nothing was shown but highlighting all between prompts gave me the above. Why did nothing show in the terminal I ask?

              Here is result of second command:-

              alastair@antix1:~$ aplay /usr/share/sounds/alsa/Front_Center.wav
              ALSA lib pcm_equal.c:236:(_snd_pcm_equal_open) Problem with control file .alsaequal.bin.
              aplay: main:788: audio open error: Operation not permitted
              alastair@antix1:~$ 

              Hope this helps.

              #4424
              Member
              Budgie

                ? What is the output of sudo lspci -v | grep -i audio

                alastair@antix1:~$ sudo lspci -v | grep -i audio
                We trust you have received the usual lecture from the local System
                Administrator. It usually boils down to these three things:
                    #1) Respect the privacy of others.
                    #2) Think before you type.
                    #3) With great power comes great responsibility.
                [sudo] password for alastair: 
                00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
                alastair@antix1:~$ 

                ? What is the output of lsmod |grep audio
                No output from this

                ? What is the output of sudo aplay -l

                alastair@antix1:~$ sudo aplay -l
                **** List of PLAYBACK Hardware Devices ****
                card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
                  Subdevices: 1/1
                  Subdevice #0: subdevice #0
                card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958 [Intel 82801DB-ICH4 - IEC958]
                  Subdevices: 1/1
                  Subdevice #0: subdevice #0
                card 1: Modem [Intel 82801DB-ICH4 Modem], device 0: Intel ICH - Modem [Intel 82801DB-ICH4 Modem - Modem]
                  Subdevices: 1/1
                  Subdevice #0: subdevice #0
                alastair@antix1:~$ 
                
                #4425
                Member
                Budgie

                  Make sure sound chip is turned on in bios first.

                  OK I didn’t think of that but I acnnot find a sound option in the bios setup pages.
                  There is a hardware switch which I have tried in both positions but to no avail.

                  #4428
                  Moderator
                  caprea
                    alastair@antix1:~$ aplay /usr/share/sounds/alsa/Front_Center.wav
                    ALSA lib pcm_equal.c:236:(_snd_pcm_equal_open) Problem with control file .alsaequal.bin.
                    aplay: main:788: audio open error: Operation not permitted
                    alastair@antix1:~$ 

                    Try firstly SamK’s solution in this thread removing the alsaequal.bin
                    https://www.antixforum.com/forums/topic/also-lost-audio-here/#post-2538

                    Like anticapitalista mentioned in your other topic there’s maybe something badly wrong with your install.
                    Best you go on there explaining exactly which version you installed, how you installed, if you checked md5 sum of the iso ……

                    • This reply was modified 6 years, 5 months ago by caprea.
                    #4530
                    Member
                    Budgie

                      Hi caprea, well after sorting out my installation all the sound components were showing present and correct but still not working but I then tried SamK’s solution and the bin file was there to delete. Started alsa-utils again and now I have sound.

                      I should add that I have persevered with antiX on this machine thanks in no small way to the welcome and great support from this forum. I very much like the overall impression I have gained on the OS itself so shall stick with it. Only a few minor questions now on which I shall start new threads.

                      Taking the opportunity to wish you a very happy and fulfilling New Year.
                      Budge

                      #4534
                      Anonymous

                        @budgie – Even if the installation does show the sound card present does not mean it is turned on. I have found that lately (and I still haven’t figured out why or how) that both of my computers will turn off the sound if I disconnect or connect my headphones while the computer is turned off. It will not auto-detect that the headphone has been plugged in upon reboot.

                        Clarification: I have my phones hooked up to the computer (it doesn’t matter which) and I turn it off. If I disconnect the phones while it is off and then turn on the computer, the computer will have the sound output OFF. AT this point, it will not matter of I replug my phones in OR if I want to use the speakers. I have NO SOUND. I have to go into AlsaMixer and enable the ‘auto-mute” to get sound. I have no idea if this is caused by an update or what. I just learned to live with it.

                      Viewing 10 posts - 1 through 10 (of 10 total)
                      • You must be logged in to reply to this topic.