Connman can’t connect to WiFi [SOLVED]

Forum Forums New users New Users and General Questions Connman can’t connect to WiFi [SOLVED]

  • This topic has 4 replies, 4 voices, and was last updated Mar 11-5:06 pm by Catsbark.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #136107
    Member
    Catsbark

      I just installed antiX 23 on an old HP Pavilion laptop (info below). I can’t connect to my WiFi router. When I open connman, and click on the wireless tab, a list of the nearby WiFi services appears. That’s as it should be. If I select my router and click “connect” a dialog appears with several blank text fields. I really don’t know which field wants the security password for my router. I have tried a couple of them, but the result is either that nothing at all happens, or I get an error. (I can’t post the error right now, ’cause I’m getting no reaction at all from trying to connect.

      Any assistance or advice would be greatly appreciated.

      $ inxi -Fxz
      System:
        Kernel: 6.1.42-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc
          v: 13.2.0 Desktop: IceWM v: 3.4.5 Distro: antiX-23_x64-full Arditi del
          Popolo 27 August 2023 base: Debian GNU/Linux 12 (bookworm)
      Machine:
        Type: Laptop System: Hewlett-Packard product: HP Pavilion dv6700 Notebook PC
          v: Rev 1 serial: <superuser required>
        Mobo: Quanta model: 30D2 v: 79.2E serial: <superuser required>
          BIOS: Hewlett-Packard v: F.59 date: 11/25/2008
      Battery:
        ID-1: BAT0 charge: 23.2 Wh (100.0%) condition: 23.2/88.8 Wh (26.1%)
          volts: 12.3 min: 14.8 model: Hewlett-Packard Primary status: full
      CPU:
        Info: dual core model: Intel Core2 Duo T5550 bits: 64 type: MCP
          arch: Core2 Merom rev: D cache: L1: 128 KiB L2: 2 MiB
        Speed (MHz): avg: 998 min/max: 1000/1833 cores: 1: 998 2: 998
          bogomips: 7315
        Flags: ht lm nx pae sse sse2 sse3 ssse3
      Graphics:
        Device-1: NVIDIA G86M [GeForce 8400M GS] vendor: Hewlett-Packard Pavilion
          dv6700 driver: nouveau v: kernel arch: Tesla bus-ID: 01:00.0 temp: 65.0 C
        Device-2: Chicony VGA 24fps UVC Webcam driver: uvcvideo type: USB
          bus-ID: 2-4:2
        Display: x11 server: X.Org v: 1.21.1.7 driver: X: loaded: modesetting
          unloaded: fbdev,vesa dri: nouveau gpu: nouveau resolution: 1280x800~60Hz
        API: EGL v: 1.4,1.5 drivers: nouveau,swrast platforms:
          active: gbm,x11,surfaceless,device inactive: wayland
        API: OpenGL v: 3.3 vendor: nouveau mesa v: 22.3.6 glx-v: 1.4
          direct-render: yes renderer: NV86
      Audio:
        Device-1: Intel 82801H HD Audio vendor: Hewlett-Packard Pavilion dv6700
          driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
        API: ALSA v: k6.1.42-antix.1-amd64-smp status: kernel-api
        Server-1: PipeWire v: 1.0.3 status: active
      Network:
        Device-1: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network driver: iwl4965
          v: in-tree: bus-ID: 02:00.0
        IF: wlan0 state: down mac: <filter>
        Device-2: Realtek RTL810xE PCI Express Fast Ethernet
          vendor: Hewlett-Packard Pavilion dv6700 driver: r8169 v: kernel port: c000
          bus-ID: 08:00.0
        IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
      Drives:
        Local Storage: total: 298.09 GiB used: 7.26 GiB (2.4%)
        ID-1: /dev/sda vendor: Toshiba model: MK3255GSX size: 298.09 GiB
      Partition:
        ID-1: / size: 98.27 GiB used: 7.26 GiB (7.4%) fs: ext4 dev: /dev/sda6
      Swap:
        ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swap/swap
      Sensors:
        System Temperatures: cpu: 50.0 C mobo: N/A gpu: nouveau temp: 65.0 C
        Fan Speeds (rpm): N/A
      Info:
        Processes: 152 Uptime: 51m Memory: total: 3 GiB available: 2.91 GiB
        used: 1.08 GiB (37.1%) Init: SysVinit runlevel: 5 Compilers: gcc: 12.2.0
        Packages: 1761 Shell: Bash v: 5.2.15 inxi: 3.3.31
      
      • This topic was modified 2 months, 2 weeks ago by Catsbark.
      #136116
      Member
      Robin

        Please use the highlighted password entry field in first screenshot. Maybe this helps already?

        And then, before connecting make sure your wireless device is switched “on” in the status tab (2nd screenshot) power column by clicking on this very red LED (if it is not green already), which should turn green then. If not, then there might be an additional hardware switch on your device which must be activated also to be able to scan the networks. Sometimes there is also a key combination like Fn+F2, Fn+F3 or whatever. And make sure beforehand your wireless is enabled in the BIOS.

        Before clicking connect you should see your network already and be able to select it from the listings.

        After entering the password into the marked field don’t forget to click OK, its’s not marked red in the screenshot.
        No need to touch any other entries therein normally.

        Windows is like a submarine. Open a window and serious problems will start.

        #136121
        Member
        marcelocripe

          Hello Catsbark.

          Welcome to antiX Linux and the Forum.

          I don’t know how to write in English and I send my texts translated by the internet translator. I hope you can understand everything. If your native language is not English, please translate my original Brazilian Portuguese text directly into your language with the help of internet translators and you will get a much better result.

          Please read my real welcome in the Welcome to antiX Linux and the forum (antiX 23) and Welcome to antiX Linux and the forum (antiX 19, 21 and 22) thread.

          Please learn how to ask for help here on the antiX forum by reading the threads I linked in my real welcome. Please note that there are 3 editions of antiX from series 19, 21 or 22 and 23 that have technical support in this forum. Each edition has 4 ISO images (full, base, net and core) on two different boot system types, SyVinit and Runit. If my sum is not wrong, at the present date there are about 32 different types of operating systems. That’s why you need to learn how to ask for help here on the antiX forum.

          If you are able to understand the Portuguese language or try to read the automatic translation generated by YouTube, it may be useful to watch this video https://www.youtube.com/watch?v=G5_8ugzTtuU.

          marcelocripe
          (Original text in Brazilian Portuguese language)

          – – – – –

          Olá, Catsbark.

          Seja bem-vindo(a) ao antiX Linux e ao fórum.

          Eu não sei escrever em idioma Inglês e envio os meus textos traduzidos pelo tradutor da internet. Eu espero que você consiga compreender tudo. Se o seu idioma nativo não for o Inglês, por favor, traduza o meu texto original em Português no Brasil diretamente para o seu idioma com a ajuda dos tradutores da internet que você obterá um resultado muito melhor.

          Por favor, leia a minha verdadeira boas-vindas no tópico Seja bem-vindo (a) ao antiX Linux e ao fórum (antiX 23) e Seja bem-vindo (a) ao antiX Linux e ao fórum (antiX 19, 21 e 22).

          Por favor, aprenda a pedir ajuda aqui no fórum do antiX lendo os tópicos que eu indiquei na minha verdadeira boas-vindas. Saiba que existem 3 edições do antiX, das séries 19, 21 ou 22 e 23 que possuem suporte técnico neste fórum. Cada edição possui 4 imagens ISOs (full, base, net e core) em dois tipos de sistema de inicialização diferentes, o SyVinit e o Runit. Se a minha soma não estiver errada, na presente data são cerca de 32 tipos diferentes de sistema operacionais. É por isso que você precisa aprender a pedir ajuda aqui no fórum do antiX.

          Se você for capaz de compreender o idioma Português ou de tentar ler a tradução automática gerada pelo YouTube poderá ser útil assistir este vídeo https://www.youtube.com/watch?v=G5_8ugzTtuU.

          marcelocripe
          (Texto original em idioma Português do Brasil)

          #136152
          Moderator
          Brian Masinick

            @catsbark I believe that @robin has given you very good advice.

            The only other “workaround” that we’ve had to do in the PAST,
            has been to toggle between the two available network/WiFi
            management programs, Ceni and CMST.

            We have a tool entitled antiX WiFi Switch. You can locate
            it by opening up the Management interface in the corner
            of your system, Select Applications, then antiX, then
            antiX WiFi Switch.

            If you’ve never tried Ceni, you can select it and see if
            it is able to make the connection; some people have
            switched back and forth between the two alternatives in the
            past to “magically” get one or the other interface to activate.

            That’s not been a problem on my system at all, but I do recall
            a few people in the past that had success by toggling once
            or twice between the two alternatives, and even trying out both.

            Give that a try, and also consider the advice that @robin has
            provided. Hopefully these notes will lead to a working solution
            for you.

            As far as that network card, it has worked fine in the past.
            If neither of these approaches works, I’d double check to make
            sure the card is functioning properly as a “next step” if these
            other suggestions fail.

            --
            Brian Masinick

            #136224
            Member
            Catsbark

              Thanks to those who responded. For un-associated reasons, I reinstalled antiX, and when I tried to make the WiFi connection, I selected the 2.4 GHz channel of my router instead of the 5 GHz channel. I entered the password as indicated by Robin, and the connection worked. It could have been selecting the 2.4 GHz channel, it could have been the reinstallation, it could have been something entirely different. Neverless, it works now, so I will mark this issue solved.

              Thanks again for your help.

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.