Connman wireless not working in antiX 19.1 Full 32-bit

Forum Forums General Software Connman wireless not working in antiX 19.1 Full 32-bit

  • This topic has 81 replies, 9 voices, and was last updated Jan 24-9:01 am by gf.
Viewing 15 posts - 16 through 30 (of 82 total)
  • Author
    Posts
  • #31759
    Member
    Avatargf

    Hi anticapitalista,
    Here are the contents of the /etc/network/interfaces file for both andiX17.3.1 (installed on harddrive) and antiX 19.1 (running live from a DVD).
    See attached.

    Hi Moddit,
    Thanks for your suggestion: “…I would see if 17 has an interface description here after setting up wifi. If yes copy it in to 19 and see what happens.”
    I tried to copy the contents of 17’s interfaces file to the interfaces file on 19 but same result. I could not reboot after making those edits (working from DVD) so maybe that wasn’t good test. I did try through the connmanctl to disable wifi and turn agent off, then enable wifi and set agent back on. Same errors.

    I will install 19.1 again now and try anticapitalista’s suggestion of editing the interfaces file first.
    Thanks
    G

    #31762
    Member
    Avatargf

    Hi anticapitalista,
    After installing antiX 19.1 on the harddrive, edited the interfaces file per your instructions (comment #31670 above), removing all but the “auto” and “iface” lines,
    and started connman through the command line interface. Same errors. See attached.

    I will try to copy the interfaces entries from v17.3.1 to v19, as suggested by Moddit.
    And I have downloaded a copy of MX 19 32bit. I will try to see if wireless works with that.
    Thanks again for your help on this.
    : )
    G

    #31764
    Forum Admin
    anticapitalistaanticapitalista

    Well I’m out of ideas with connman.
    Here connman works (after several attempts to connect at first via the gui) even on a laptop with crappy broadcom wifi.

    If you need wireless and don’t need connman and you can initially connect via wired, use ceni or wicd.
    You must remove connman, cmst and anything related eg connman-vpn.
    Reboot.
    sym link /etc/resolvconf/run/resolv.conf to /etc/resolv.conf (use rox-filer as root user)
    Use ceni to connect.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31765
    Member
    Avatargf

    Hi Moddit,
    Moditt said: “Did you read about non PAE kernel for MX in old thread. Sorry should not have assumed too much, that is usually chosen
    automatically by the installer.”

    I burned a DVD with MX-19_386.iso on it. When I booted it on the notebook, the error says:
    “WARNING: PAE disabled. User parameter ‘forcepae’ to enable at your own risk. This kernel requires the following features not present on the CPS: pae
    Unable to boot – please us a kernel appropriate for your CPU”

    I will try using forcepae as a boot option

    Thanks again for all your suggestions
    : )
    G

    • This reply was modified 1 month, 1 week ago by gf.
    #31767
    Member
    Avatargf

    Hi anticapitalista and Moddit:

    Update on wifi using MX Linux 32-bit (MX-19_386.iso):
    Once MX has loaded (with forcepae option), a few clicks on the interface button on the left panel, selected my network, typed in my password, and the wifi is up and running just fine (running live from DVD).

    Interfaces file in MX has:
    auto lo
    iface lo inet loopback
    (and nothing else.)

    There is a symlink in the /etc directory:

    /etc/resolv.conf is an active link to ../run/resolvconf/resolv.conf

    NOTE: that is different I think: I do not have the .. (two dots) in front of my target in my symlink
    My symlink has been pointing to a subdirectory in /etc (per attached)

    This symlink in MX Linux points to a file in /run which is in the root.

    Is antiX and MX the same in where the resolv.conf file is supposed to be located (in /etc or in /run)?

    Hope this helps
    G
    PS: MS looks pretty cool! : )

    • This reply was modified 1 month, 1 week ago by gf.
    • This reply was modified 1 month, 1 week ago by gf.
    #31772
    Member
    Avatargf

    Hi anticapitalista, when you say “after several attempts to connect at first via the gui,” did you finally connect via the gui or via the command line? Did you get any error messages? If I can replicate the “re-tries” I might get in, too.

    You suggest creating a symlink but your symlink seems to be opposite to the one I have been using. (maybe mine is backwards?) Could you post the exact command in terminal for creating the symlink?

    What network manager does MX use? That was smooth and easy.

    Thanks again for looking at this
    : )
    G

    • This reply was modified 1 month, 1 week ago by gf.
    #31780
    Member
    Avatarsemicynic

    32bit antix-19-full connman works fine using command line

    Make sure timezone, date, and time are correct

    I gave command “connmanctl technologies”
    This showed that I had ethernet, wifi, and bluetooth. Correct for my ASUS eeepc.

    Not only that but it gave a list of subcommands used to connect, but unfortunately not in the correct order. I list proper order inline below.

    Next gave command
    “connmanctl”
    and it returned connmanctl>
    and waited for subcommand

    Below is order for subcommands and the replies. I’ve included error attempts.

    connmanctl>enable wifi
    Enabled wifi

    connmanctl> scan wifi
    completed wifi scan

    connmanctl> services
    <mywifi> wifi_0022435c6bd5_6465637265706974_managed_psk
    … and any available networks in name string format
    do not use <mywifi> later, only the string you need that starts with wifi and ends with managed_…

    connmanctl> agent on
    Agent registered

    connmanctl> connect wifi
    Error /net/connman/service/wifi: Method “Connect” with signature “” on interface “net.connman.Service” doesn’t exist

    connmanctl> wifi_0022435c6bd5_6465637265706974_managed_psk
    Error ‘wifi_0022435c6bd5_6465637265706974_managed_psk’: Unknown command

    connmanctl> connect wifi_0022435c6bd5_6465637265706974_managed_psk
    Agent RequestInput wifi_0022435c6bd5_6465637265706974_managed_psk
    Passphrase = [ Type=psk, Requirement=mandatory, Alternates=[ WPS ] ]
    WPS = [ Type=wpspin, Requirement=alternate ]
    Passphrase? ******************
    Connected wifi_0022435c6bd5_6465637265706974_managed_psk
    connmanctl> quit
    demo@antix1:~

    Now you can see activity in conky or bottom panel, and use browser.

    Since I use this on netbook at different locations, it is fine for me.

    If you have antix-19 installed and use it most with a single wifi router and know (after first successful try) the string for your home net,
    you can write a script with 2 arguments like
    “homenet <my-wifi-name-string> <passphrase for my-wifi-name>”

    I hope this helps.

    #31783
    Member
    AvatarModdIt

    @semicynic, Old modderman here, thanks for the input, hopefully your info can help with faultfinding and getting a practical working solution. This is not a jibe or rant. It is not just user gf.
    I thought I was going mad. When I tested Beta on my devices I had wifi. Not just me, some kids too passwd entered not more than 3 times because for sure I do not key it in wrong three times. no command line. Unlucky hit and miss working is now the only explanation we (me and users) consider credible for that unless something changed since then in the workings..
    Especialy for new users coming from Windows a command line orgy is no go. Even if it may prove reliable on an assorted array of devices.
    Can I give that to user K 50 years old disabled and used to ne click and works. Nope.
    Al, a user in Wheelchair with MS, he needs 5 minutes to enter a password once on bad days.
    Please consider for the German School Kids, get up, before leaving do CLI proceedure check if Lesson Plans Changed or teacher messages on iServe. Get on Train for a 30 Minute ride, want to look in news or use net, answer emails,
    work on the forced MS online office portal. Do it again. Change to bus. Do it again if wifi available.
    The School is huge has a lot of sub nets, not just for classes but also areas. Command line each time.
    Then comes Mobbing. Mac and win users will be pointing and screaming with laughter, posting on fbook and u tube
    at cost of underpriveliged classmates. A couple of kids now having Arch based are jibing too.

    If wished for I can take down this post after a few days. Just find this theme very disturbing. This is an otherwise fantastic distribution which could be growing fast. Right now I am not pushing to enlarge user base. Frightened of no more time for life, just support.

    #31784
    Member
    AvatarModdIt

    @gf. What network manager does MX use? That was smooth and easy.
    Much of System D mechanism in there, points to a root cause somewhere within the sys d removal/replace mechanism
    for wireless activation in AntiX. Removing the d For sure not an easy task.

    #31788
    Member
    Avatargf

    Hi Moddit, that’s interesting. I thought that MX was also systemD-free.

    I wondered what was the software in the background that gave me the list of networks and asked for my password. I didn’t have to specify the encryption method (wep/wpa/wpa2). It recognized right away what was needed. Ceni does that too.

    Does it make a difference that I am trying to connect to a WEP network? I know it’s an old protocol. Has WEP been depricated by connman developers?

    Thanks for you thoughts on this, Moddit.
    : )
    G

    #31789
    Member
    Avatargf

    Hi Semicynic,
    Thanks for the idea of a script. I am not at the script stage yet. I have yet to get connman working.

    I always refer to your steps whenever I am testing the setup of connman. Those are great instructions and thanks for reposting them here. It might help someone else get their wifi going. I find your cli method clearer than the GUI and I like it because you can tell at what step the process breaks down. I just haven’t been able to get connman to work for me.

    If you could review my steps in my last uploaded document, and let me know if I missed anything in the connman setup steps, that would be great.

    Early on, I was missing the “agent on” step and couldn’t even get to the password. Now when I make sure to turn the agent on, connman properly asks for my network password. But then I still get the same errors.

    Thanks again for continuing this journey with me.
    G

    #31790
    Member
    Avatargf

    Hi again Semicynic,
    Regarding your suggestion about timezone, time and date, how precise does that have to be? I was able to manually set it to the right date hour and minute ( not second).

    I am sorry if I have asked you this before but, is there a command/ setting that will get the computer to get the network time if I plug the hardwire in for a short time?
    Still learning…
    G

    #31792
    Member
    Avatargf

    Hi Everyone,
    Just for the fun of it, I ran live DVD antiX 17.3.1 on my notebook. I used wicd to connect to wifi – no problem.
    I installed connman, cmst, connman-ui via the command line.

    When I try to connect to wifi with connman, I get the same errors as in 19 and 19.1.

    Versions that got installed on this live antiX17.3.1 were: cmst (2016.10.03-1),QT (version 5.7.1)
    Hope that helps
    G

    #31793
    Member
    AvatarPPC

    I am sorry if I have asked you this before but, is there a command/ setting that will get the computer to get the network time

    There’s a command, but you can just do that from Control Centre – system – Set Date and time – Use Internet time server (if you have internet working).

    Also, I think I read somewhere here on the forum that you can’t have both connman and wicd working on your system (you said you installed connaman on antiX 17.x)….

    P.

    #31799
    Member
    AvatarModdIt

    Hi gf: you ask Does it make a difference that I am trying to connect to a WEP network.

    Connman states ConnMan provides IPv4 and IPv6 connectivity via:
    * ethernet
    * WiFi, using wpasupplicant

    wpasupplicant supports WEP, WPA and WPA2
    Quite a lot of info on wpasupplicant @https://wiki.archlinux.org/index.php/Wpa_supplicant
    including a direct setup method.

    So yes it looks like you should be able to connect with connman as frontend.

    It is also very clear hardware is not the issue in case questions crop up on that.

    # I thought that MX was also systemD-free. No you can chose to boot with it active but
    it is not ootb init.

Viewing 15 posts - 16 through 30 (of 82 total)
  • You must be logged in to reply to this topic.