controling fans of a Dell OptiPlex 790

Forum Forums General Hardware controling fans of a Dell OptiPlex 790

This topic contains 5 replies, has 3 voices, and was last updated by Xecure May 19-2:52 pm.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #21823
    Member
    Avatar
    delix02

    this machine shows the fan speed in the diagnostics of the BIOS, but with antiX the fans run always at full speed.
    I tried to autodetect the fan with pwmconfig
    but none could be detected.
    btw, the CPU temperature sensor is detected and running.

    Is there any chance to get control over the fan speed on this machine ?
    The technical manual for the 790 said it is tested and sold with Ubuntu 10 (but only in China….), so I guess there should be a solution for my problem.

    • This topic was modified 5 months ago by delix02.
    #21825
    Member
    caprea
    caprea

    Is lm-sensors installed and did you run sudo sensors-detect ? If I remember right it has to be installed and configured to get the fancontrol to work.

    #21838
    Member
    Avatar
    delix02

    yes, sensor-detect
    shows the CPU temperature.

    is there a kernel module or option for the fan control (or a Dell-specific one) that is missing/modified in the antiX kernels but used to be available in the ancient Ubuntu kernels ?

    #21844
    Member
    caprea
    caprea

    There is i8kutils in the debian-repos.
    Description in synaptic:
    Fan control for Dell laptops, This is a collection of utilities to control Dell laptops fans. It includes
    programs to turn the fans on and off, to read fans status, CPU temperature,BIOS version

    #21847
    Member
    Xecure
    Xecure

    If what caprea recomends doesn’t work, maybe you will have to check with Ubuntu.

    Before doing anything else, check to see if you have enabled in the BIOS the “Fan Control Override”. If this is enabled, the fan will always work at full speed. Disable it.

    I recently had problems with hardware not being detected in antiX on one of my computers, and the same happened on MX Linux. I had no idea what modules I needed so that everything could be detected. I read that a certain version of Ubuntu had these devices working, so I took the time to install it and check out the modules that were working on Ubuntu, so I could compile them with the kernel back with antiX. As you say, your computer could have the fan related module working out of the box in Ubuntu 10.10, you may have to delve in and check for yourself.

    Sorry for not being of much use.

    #21848
    Member
    Xecure
    Xecure

    Before doing anything else, check to see if you have enabled in the BIOS the “Fan Control Override”. If this is enabled, the fan will always work at full speed. Disable it.

    Sorry. After checking what Fan Control Override did, it seems enabling it lets other programs take control of the fans, instead of always having them working at full speed. Please ignore what I said.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.