[SOLVED] conversion from antix sysVinit to sid

Forum Forums News Sid Upgraders [SOLVED] conversion from antix sysVinit to sid

  • This topic has 8 replies, 3 voices, and was last updated Jul 2-6:15 am by maybl8.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #142625
    Member
    maybl8

      Steps to do this without crashing the system.

      The first thing I am going to do after installing is this:

      wget -c http://repo.antixlinux.com/antix-archive-keyring_20019.5.0_all.deb
      sudo dpkg -i antix-archive-keyring_20019.5.0_all.deb

      Next is sudo apt-get update
      Next is sudo apt-get dist-upgrade

      What should I do before doing dist-upgrade to not have the GLIBCXX errors so not to lose apt?

      • This topic was modified 1 month, 4 weeks ago by maybl8.
      • This topic was modified 1 month, 4 weeks ago by maybl8.
      • This topic was modified 1 month, 3 weeks ago by maybl8.
      #142639
      Member
      stevesr0

        DON’T follow my suggestions until others have had a chance to comment/correct them. It is based on my experience going from a single stable (net) install to a minimalistic Sid which I have maintained for several years. Be aware that in the past few months, Sid has been “tricky” to keep nosystemd pure.

        ==========================================================================================

        (I am unclear if you did the “dist-upgrade” in stable or only after changing your repos to the Sid/unstable ones?)

        After a fresh stable install, you should do an

        sudo apt update && sudo apt upgrade

        This will upgrade packages that don’t require removal of installed packages.

        N.B. If you want to make sure you are staying “nosystemd”, I suggest you run

        sudo apt-mark hold elogind libelogind0 FIRST.

        ** If you get error messages, post them here.

        If you see no error messages, then run

        sudo apt update && sudo apt dist-upgrade

        ** BUT say no to this upgrade until you check if it is removing things.

        If it isn’t removing anything, then complete the dist-upgrade.

        If you get no error messages and your system is working after this, then you can try changing from the stable to the Sid/unstable repos in all the separate files (antiX.list, Debian.list, etc).

        Then you repeat the process as above.

        Please post if any of this is confusing or unclear.

        #142663
        Member
        abc-nix

          Upgrade the antiX 23 system until no more upgrades available.

          Change the apt sources to testing (for both antix.list and debian.list), and then upgrade, then dist-upgrade, then full-upgrade. If you see issue upgrading to testing, apt-mark hold some of the problematic packages and upgrade as much as you can (there are a lot of issues with the t64 packages right now).

          After that, change apt sources to sid, apt-mark unhold the previously problematic packages, and try a normal upgrade, then dist-upgrade, then full upgrade. Always pay attention to the warning in apt about packagaes being replaced, no longer needed and being removed. This will give you hint to what could be going on and the problems you may experience when upgrading.

          #142672
          Member
          maybl8

            update and dist-upgrade are showing nothing to update
            so good so far.

            Let’s discuss sources lists

            I have the following in my system and these are the contents of them:
            antix.list:

            # Use with Debian Bookworm repositories. 
            deb [signed-by=/etc/apt/keyrings/antix-archive-keyring.gpg] http://la.mxrepo.com/antix/bookworm bookworm main nonfree nosystemd  
            #deb-src http://la.mxrepo.com/antix/bookworm bookworm main nosystemd nonfree  
            # Use with Debian Testing/'rolling' repositories.
            #deb http://la.mxrepo.com/antix/testing testing main nosystemd nonfree 
            #deb-src http://la.mxrepo.com/antix/testing testing main nosystemd nonfree 
            # Use with Debian Sid repositories. 
            #deb http://la.mxrepo.com/antix/sid sid main nosystemd nonfree 
            #deb-src http://la.mxrepo.com/antix/sid sid main nosystemd nonfree 
            

            bookworm-backports.list

            # Debian Bookworm backports. Use with caution.
            deb http://deb.debian.org/debian bookworm-backports main contrib non-free non-free-firmware
            

            debian.list

            # Debian Bookworm/Stable
            deb http://ftp.de.debian.org/debian/ bookworm main contrib non-free non-free-firmware
            deb http://security.debian.org/ bookworm-security main contrib non-free non-free-firmware
            # Multimedia Stable!
            # ONLY use to install libdvdcss2 and codecs.
            #deb http://www.deb-multimedia.org bookworm main non-free
            # Debian Testing. 
            # Testing enabled for 'rolling' release.
            # deb http://ftp.de.debian.org/debian/ testing main contrib non-free non-free-firmware
            # deb http://security.debian.org testing-security main contrib non-free  non-free-firmware
            #deb-src http://ftp.de.debian.org/debian/ testing main contrib non-free non-free-firmware
            # Multimedia Testing!
            # Only use to install libdvdcss2 and codecs.
            #deb http://www.deb-multimedia.org testing main non-free
            ###### Debian Unstable/Sid##########
            ###### Use at your own risk! ########
            #deb http://ftp.de.debian.org/debian/ unstable main contrib non-free non-free-firmware
            # Multimedia Unstable/Sid!
            # Only use to install libdvdcss2 and codecs.
            #deb http://www.deb-multimedia.org sid main non-free
            

            debian-stable-updates.list

            # Debian Bookworm Updates
            deb http://ftp.us.debian.org/debian/ bookworm-updates main contrib non-free non-free-firmware
            

            librewolf.list
            #deb [arch=amd64] http://deb.librewolf.net bookworm main
            liquorix.list

            # liquorix kernel
            #deb [signed-by=/etc/apt/keyrings/liquorix-keyring.gpg] http://liquorix.net/debian/ bookworm main
            

            @abc-nix
            Based on what you said to do I should comment out anything that has to do with bookworm
            uncomment anything that has to do with testing and update and see what happens and do as you said about holding if necessary.
            If that goes smooth then go for sid?

            How about multmedia repos?

            • This reply was modified 1 month, 4 weeks ago by maybl8.
            #142675
            Member
            stevesr0

              Hi mayb18,

              1. abc-nix is very knowledgeable.

              2. anticapitalista started a thread, “upgrading antiX dont’s”. Read his opening post. Note he states don’t enable the multimedia repo “by default” or “before a dist-upgrade”.

              3. About glibc install.

              Some versions of glibc were buggy. I had problems last year. The version on my current working Sid install is 2.38-11.

              You don’t install a glibc package. It is installed/upgraded when you upgrade libc related packages. You may also need libstdc++6 to allow the upgrade of glibcxx and normal function of apt.

              **Listen to others (like abc-nix) and read about apt and glibc, so you avoid problems.

              • This reply was modified 1 month, 4 weeks ago by stevesr0.
              #142695
              Member
              maybl8

                Been doing some reading on the debian forum and debian website.
                Sounds like a transition is going as you mentioned about renaming packages “t” if I understood it correctly breaking allot of packages.
                That makes me want to wait.

                I did read about using aptitude instead of using apt.
                Have you found using aptitude helps you prevent you from breaking your system?

                Also I don’t usually back up before doing an update but in this case I am considering it.
                What is the best way to backup to be able to revert if a big update breaks your system?
                Thanks

                #142712
                Member
                stevesr0

                  Hi mayb18,

                  Waiting to get to Sid isn’t a bad idea, especially if you haven’t worked with stable antiX a lot.

                  (Bear in mind, I have heard that the move from stable to Sid is best done from a new install.)

                  As to the t64 packages, they were a problem when they were first replacing non t64 packages. Now, they “seem” (to me) not to be terribly disruptive on Sid.

                  (Bear in mind, if you go thru testing first, rather than directly from stable to Sid, that testing is at an earlier stage of the t64 upgrades.)

                  My bottom line is proceed with caution …

                  Use

                  sudo apt install -s pkg1 pkg2 pkg3…

                  routinely to check whether nosystemd packages are being replaced with regular Debian versions and if some packages are being automatically removed before saying yes to an upgrade or apt-get dist-upgrade (= apt full-upgrade).

                  #142713
                  Member
                  maybl8

                    Ok I now have a snapshot iso that is updated and stable system.
                    I can reinstall that if my upgrade to testing or sid fails and start it over.
                    I think I am going to try this and see what happens.
                    Thanks for all the help and input.
                    I will post the results of what happens next.

                    Ok I have successfully updated to testing.
                    After updating I have this:

                    The following packages have been kept back:
                      cron-daemon-common ffmpeg gstreamer1.0-libav libavcodec-extra libgd3 libmpv2 libparted-i18n mpv parted
                    

                    The only problem I had was when I rebooted I didn’t have GRUB.
                    I booted to the snapshot I made . Did maintenance boot repair and reinstalled grub to the drive.
                    During the update to testing several config files including GRUB wanted to know how I wanted to deal with changes and I chose to use package maintainers version on each one.
                    I don’t know if that is why GRUB got messed up.
                    But the repair fixed it and I was able to boot into antix.

                    I am now going to go for sid.

                    I am on sid. Yea

                    Now I have a new issue.
                    In case I didn’t mention it I am installed on a 3.0 USB Flash drive.

                    When I try to put the flash drive in my Laptop and try to boot to it the GRUB menu entry won’t boot.
                    However if I use the GRUB entry UEFI Firmware settings and find the MX23 entry it boot just fine.

                    Why would GRUB menu entry not work on one computer vs another one.
                    this is lsblk from computer that won’t boot.

                    $ lsblk
                    NAME         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
                    sda            8:0    1  28.9G  0 disk 
                    ├─sda1         8:1    1   256M  0 part /boot/efi
                    └─sda2         8:2    1  28.7G  0 part /
                    nvme0n1      259:0    0 931.5G  0 disk 
                    ├─nvme0n1p1  259:1    0   529M  0 part 
                    ├─nvme0n1p2  259:2    0   499M  0 part 
                    ├─nvme0n1p3  259:3    0    16M  0 part 
                    ├─nvme0n1p4  259:4    0   219G  0 part 
                    ├─nvme0n1p5  259:5    0   961M  0 part 
                    ├─nvme0n1p6  259:6    0    90G  0 part 
                    ├─nvme0n1p7  259:7    0 383.6G  0 part 
                    ├─nvme0n1p8  259:8    0   163G  0 part 
                    ├─nvme0n1p9  259:9    0    57G  0 part 
                    ├─nvme0n1p10 259:10   0     1G  0 part 
                    ├─nvme0n1p11 259:11   0    16G  0 part 
                    └─nvme0n1p12 259:12   0     3M  0 part 
                    demo1@antix1:~
                    $ 
                    

                    What I learned about this so far is.
                    The UEFI settings uses something different than GRUB does.
                    GRUB is not working to boot with but the UEFI settings is working.
                    The problem is I have to hit F9 to get to UEFI settings and I don’t want to do that.

                    I installed refind and after doing some tweaking ie removing some extra boot entries and using efibootmgr to change order I have this process to boot to antix
                    ENTER
                    ERROR MESSAGE
                    ESC
                    ENTER
                    and it boots

                    • This reply was modified 1 month, 3 weeks ago by maybl8.
                    • This reply was modified 1 month, 3 weeks ago by maybl8.
                    • This reply was modified 1 month, 3 weeks ago by maybl8.
                    #147602
                    Member
                    maybl8

                      I am trying this again on a different install.
                      I started with the full antix 23.1 iso.
                      after updating bookworm and then changing the repos to testing I am getting this when trying to do a apt dist-upgrade

                      $ sudo apt dist-upgrade
                      Reading package lists... Done
                      Building dependency tree... Done
                      Reading state information... Done
                      Calculating upgrade... Done
                      The following packages were automatically installed and are no longer required:
                        libabsl20220623 libboost-iostreams1.74.0 libboost-locale1.74.0 libboost-thread1.74.0
                        libcanberra-gtk3-0 libcbor0.8 libcolamd2 libgumbo1 libjim0.81 liblc3-0 libllvm15 libperl5.36
                        libpoppler-qt5-1 libpoppler126 libqt5concurrent5 libqt5sql5-sqlite libqt5sql5t64 libre2-9
                        libsoup2.4-1 libsoup2.4-common libsuitesparseconfig5 libwireplumber-0.4-0 libzxing2 p7zip
                        perl-modules-5.36 winff-gtk2
                      Use 'sudo apt autoremove' to remove them.
                      The following packages will be REMOVED:
                        antix-acoustic-colours coinor-libcbc3 guvcview libapt-pkg6.0 libarchive13 libaribb24-0 libasound2
                        libatk-bridge2.0-0 libatk1.0-0 libatm1 libatopology2 libatspi2.0-0 libburn4 libcdio-cdda2
                        libcdio-paranoia2 libcdio19 libclucene-contribs1v5 libclucene-core1v5 libcups2 libcupsfilters1
                        libcupsimage2 libcurl3-gnutls libcurl4 libdb5.3 libdv4 libdvdread8 libdw1 libefiboot1 libefivar1
                        libelf1 libept1.6.0 libetpan20 libev4 libevent-2.1-7 libevent-core-2.1-7 libext2fs2 libflac12
                        libfontembed1 libfsplib0 libfuse2 libgdbm-compat4 libgdbm6 libglib2.0-0 libglibmm-2.4-1v5 libgnutls30
                        libgpgme11 libgpgmepp6 libgphoto2-6 libgphoto2-port12 libgpod4 libgtk-3-0 libgtk2.0-0
                        libgtkmm-3.0-1v5 libguvcview-2.1-2 libhfsp0 libhogweed6 libhwy1 libical3 libieee1284-3 libimlib2
                        libiso9660-11 libisoburn1 libisofs6 libiw30 libmagic1 libmbedcrypto7 libminizip1 libmpg123-0
                        libmtdev1 libmtp9 libnatpmp1 libnettle8 libnorm1 libnpth0 libntfs-3g89 libopenmpt0 liborc-0.4-0
                        libotr5 libout123-0 libpcap0.8 libpgm-5.3-0 libpipewire-0.3-0 libpng16-16 libpoppler-cpp0v5
                        libpoppler-glib8 libpsl5 libqpdf29 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5
                        libqt5printsupport5 libqt5sql5 libqt5widgets5 libqt5xml5 librasqal3 librdf0 libreadline8 libsmbclient
                        libsnmp40 libsphinxbase3 libssh2-1 libssl3 libsyn123-0 libtevent0 libtirpc3 libuniconf4.6
                        libuno-cppu3 libuno-cppuhelpergcc3-3 libuno-purpenvhelpergcc3-3 libuno-sal3 libuno-salhelpergcc3-3
                        liburcu8 libuv1 libv4l-0 libv4lconvert0 libwvstreams4.6-base libwvstreams4.6-extras libxmlsec1
                        libxmlsec1-nss libxt6 libzvbi0 moc-ffmpeg-plugin
                      The following NEW packages will be installed:
                        coinor-libcbc3.1 diodon exim4-base exim4-config exim4-daemon-light gir1.2-girepository-2.0
                        gir1.2-polkit-1.0 libappstream5 libapt-pkg6.0t64 libarchive13t64 libaribb24-0t64 libasound2t64
                        libatk-bridge2.0-0t64 libatk1.0-0t64 libatm1t64 libatopology2t64 libatspi2.0-0t64 libb2-1 libb64-0d
                        libboost-iostreams1.83.0 libboost-locale1.83.0 libboost-thread1.83.0 libburn4t64 libcairomm-1.16-1
                        libcbor0.10 libcdio-cdda2t64 libcdio-paranoia2t64 libcdio19t64 libclucene-contribs1t64
                        libclucene-core1t64 libcmis-0.6-6t64 libcups2t64 libcupsfilters1t64 libcupsimage2t64
                        libcurl3t64-gnutls libcurl4t64 libdav1d7 libdb5.3t64 libdee-1.0-4 libdiodon0 libdv4t64 libdvdread8t64
                        libdw1t64 libefiboot1t64 libefisec1t64 libefivar1t64 libelf1t64 libept1.6.0t64 libetpan20t64
                        libev4t64 libevent-2.1-7t64 libevent-core-2.1-7t64 libext2fs2t64 libfile-fcntllock-perl libflac12t64
                        libfontembed1t64 libfsplib0t64 libfuse2t64 libgdbm-compat4t64 libgdbm6t64 libglib2.0-0t64
                        libglibmm-2.4-1t64 libglibmm-2.68-1t64 libgnutls-dane0t64 libgnutls30t64 libgpgme11t64 libgpgmepp6t64
                        libgphoto2-6t64 libgphoto2-port12t64 libgpod4t64 libgtk-3-0t64 libgtk2.0-0t64 libgtkmm-3.0-1t64
                        libgtkmm-4.0-0 libgumbo2 libharfbuzz-gobject0 libheif-plugin-dav1d libheif-plugin-libde265
                        libhfsp0t64 libhogweed6t64 libhwy1t64 libical3t64 libieee1284-3t64 libimath-3-1-29t64 libimlib2t64
                        libiso9660-11t64 libisoburn1t64 libisofs6t64 libiw30t64 libjim0.82t64 libjxl0.9 liblc3-1 liblua5.3-0
                        libmagic1t64 libmbedcrypto7t64 libminizip1t64 libmpg123-0t64 libmtdev1t64 libmtp9t64 libmujs3
                        libnatpmp1t64 libnettle8t64 libnorm1t64 libnpth0t64 libntfs-3g89t64 libopenexr-3-1-30 libopenfec1
                        libopengl0 libopenmpt0t64 liborc-0.4-0t64 liborcus-0.18-0 liborcus-parser-0.18-0 libotr5t64
                        libout123-0t64 libpangomm-2.48-1t64 libpcap0.8t64 libpeas-1.0-0 libpeas-common libperl5.38t64
                        libpgm-5.3-0t64 libpipewire-0.3-0t64 libpng16-16t64 libpolkit-agent-1-0 libpolkit-gobject-1-0
                        libpolkit-gobject-elogind-1-0 libpoppler-cpp0t64 libpoppler-glib8t64 libpoppler-qt6-3t64
                        libpoppler134 libpsl5t64 libpython3.12-minimal libpython3.12-stdlib libpython3.12t64 libqpdf29t64
                        libqt5core5t64 libqt5ct-common1.8 libqt5dbus5t64 libqt5gui5t64 libqt5network5t64 libqt5pas1
                        libqt5printsupport5t64 libqt5sql5t64 libqt5widgets5t64 libqt5x11extras5 libqt5xml5t64
                        libqt6concurrent6 libqt6core6t64 libqt6dbus6 libqt6gui6 libqt6printsupport6 libqt6sql6
                        libqt6sql6-sqlite libqt6svg6 libqt6widgets6 librasqal3t64 librdf0t64 libreadline8t64
                        libreiserfscore0t64 libsmbclient0 libsnmp40t64 libsoundtouch1 libsoup-3.0-0 libsoup-3.0-common
                        libspandsp2t64 libsphinxbase3t64 libssh2-1t64 libssl3t64 libstemmer0d libsyn123-0t64 libtevent0t64
                        libtirpc3t64 libts0t64 libunbound8 libuniconf4.6t64 libuno-cppu3t64 libuno-cppuhelpergcc3-3t64
                        libuno-purpenvhelpergcc3-3t64 libuno-sal3t64 libuno-salhelpergcc3-3t64 liburcu8t64 libuv1t64
                        libv4l-0t64 libv4lconvert0t64 libvpx9 libwireplumber-0.5-0 libwvstreams4.6t64-base
                        libwvstreams4.6t64-extras libxcb-cursor0 libxmlb2 libxmlsec1t64 libxmlsec1t64-nss libxt6t64
                        libyaml-0-2 libzeitgeist-2.0-0 libzvbi0t64 libzxing3 perl-modules-5.38 winff-qt zeitgeist-core zenity
                        zenity-common
                      The following packages have been kept back:
                        cron-daemon-common ffmpeg gstreamer1.0-libav libavcodec-extra libgd3 libmpv2 libparted-i18n mpv
                        parted
                      The following packages will be upgraded:
                        alsa-tools alsa-ucm-conf alsa-utils antix-installer antix-user antix-viewer apt apt-utils aptitude
                        aptitude-common apulse asunder at-spi2-core bc bluez bluez-alsa-utils bluez-obexd bootrepair-antix
                        br2684ctl btrfs-progs calf-plugins cdw celluloid cherrytree claws-mail claws-mail-i18n
                        claws-mail-pdf-viewer claws-mail-pgpinline claws-mail-pgpmime claws-mail-smime-plugin
                        claws-mail-tools clipit coinor-libcoinmp1v5 connman coreutils cryptsetup cryptsetup-bin
                        cryptsetup-initramfs cups cups-bsd cups-client cups-core-drivers cups-daemon cups-filters
                        cups-filters-core-drivers cups-ipp-utils cups-ppdc curl dconf-gsettings-backend dconf-service
                        deb-installer desktop-file-utils dirmngr dosbox e2fsprogs e2fsprogs-l10n easyeffects efibootmgr
                        efivar elinks elinks-data fdisk feh file file-roller firefox-esr firefox-esr-l10n-ca
                        firefox-esr-l10n-cs firefox-esr-l10n-da firefox-esr-l10n-de firefox-esr-l10n-el
                        firefox-esr-l10n-en-ca firefox-esr-l10n-en-gb firefox-esr-l10n-es-es firefox-esr-l10n-fr
                        firefox-esr-l10n-hu firefox-esr-l10n-it firefox-esr-l10n-nb-no firefox-esr-l10n-nl
                        firefox-esr-l10n-pl firefox-esr-l10n-pt-br firefox-esr-l10n-pt-pt firefox-esr-l10n-ru
                        firefox-esr-l10n-sv-se firefox-esr-l10n-tr firefox-esr-l10n-uk flac fuseiso galculator gawk
                        genisoimage gftp-common gftp-gtk ghostscript gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-glib-2.0
                        gir1.2-gtk-3.0 gir1.2-harfbuzz-0.0 gir1.2-nm-1.0 gir1.2-packagekitglib-1.0 gir1.2-pango-1.0
                        glib-networking glib-networking-services gnome-bluetooth-sendto gnome-mahjongg gnome-themes-extra
                        gnupg gnupg-agent gnupg-l10n gnupg-utils gnupg2 gparted gpg gpg-agent gpg-wks-client gpg-wks-server
                        gpgconf gpgsm gpgv grsync grub-common grub-efi-amd64-bin grub-efi-ia32-bin grub-pc grub-pc-bin
                        grub2-common gsettings-desktop-schemas gstreamer1.0-alsa gstreamer1.0-pipewire
                        gstreamer1.0-plugins-base gstreamer1.0-plugins-good gtk-update-icon-cache gtk2-engines
                        gtk2-engines-murrine gtk2-engines-pixbuf gtkam gtklp heif-gdk-pixbuf hexchat hexchat-common hfsplus
                        hfsprogs icewm iftop iproute2 irssi irssi-plugin-otr iso-snapshot jmtpfs jwm kmod libadwaita-1-0
                        libapt-pkg-perl libasound2-plugin-bluez libasound2-plugin-equal libatkmm-1.6-1v5 libaudio2
                        libaudiofile1 libayatana-appindicator3-1 libayatana-ido3-0.4-0 libayatana-indicator3-7 libbpf1
                        libcairo-gobject-perl libcairo-gobject2 libcairo-perl libcairo-script-interpreter2 libcairo2
                        libcanberra-gtk3-0 libcanberra0 libcloudproviders0 libcolord2 libcryptsetup12 libcurses-perl
                        libdbus-glib-1-2 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdconf1 libdvdnav4 libegl-mesa0
                        libenchant-2-2 libexif-gtk5 libexo-2-0 libffado2 libfido2-1 libflite1 libfluidsynth3 libfreetype6
                        libgbm1 libgdk-pixbuf-2.0-0 libgdk-pixbuf-xlib-2.0-0 libgdk-pixbuf2.0-0 libgexiv2-2
                        libgirepository-1.0-1 libgl1-mesa-dri libglapi-mesa libglib-object-introspection-perl libglib-perl
                        libglib2.0-bin libglx-mesa0 libgnome-bluetooth-3.0-13 libgpod-common libgraphene-1.0-0 libgs10
                        libgs10-common libgspell-1-2 libgssapi-krb5-2 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0
                        libgtk-4-1 libgtksourceview-3.0-1 libgtksourceview-4-0 libgtksourceviewmm-3.0-0v5 libgtkspell3-3-0
                        libgtop-2.0-11 libgusb2 libhandy-1-0 libharfbuzz0b libheif1 libhpmud0 libimobiledevice6 libinput10
                        libinstpatch-1.0-2 libio-pty-perl libjack-jackd2-0 libjson-glib-1.0-0 libk5crypto3 libkeybinder-3.0-0
                        libkmod2 libkrb5-3 libkrb5support0 libldap-2.5-0 libldb2 liblocale-gettext-perl libmagic-mgc
                        libmbim-glib4 libmbim-proxy libmtp-runtime libnautilus-extension4 libncurses6 libncursesw6
                        libnfsidmap1 libnm0 libnotify-bin libnotify4 libnsl2 libopusfile0 libpackagekit-glib2-18
                        libpam-modules libpam-modules-bin libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0
                        libpangomm-1.4-1v5 libpangoxft-1.0-0 libpipewire-0.3-modules libpocketsphinx3 libportaudio2
                        libproxy1v5 libpulse-mainloop-glib0 libpulse0 libpython3-stdlib libpython3.11-minimal
                        libpython3.11-stdlib libqmi-glib5 libqmi-proxy libqrtr-glib0 libqt5positioning5 libqt5qml5
                        libqt5qmlmodels5 libqt5quick5 libqt5quickwidgets5 libqt5sensors5 libqt5sql5-sqlite libqt5svg5
                        libqt5webchannel5 libqt5webengine-data libqt5webenginecore5 libqt5webenginewidgets5 libqt5webkit5
                        librabbitmq4 libraptor2-0 librcc0 libreoffice-base-core libreoffice-calc libreoffice-core
                        libreoffice-draw libreoffice-gtk3 libreoffice-impress libreoffice-math libreoffice-uiconfig-calc
                        libreoffice-uiconfig-draw libreoffice-uiconfig-impress libreoffice-uiconfig-math
                        libreoffice-uiconfig-writer libreoffice-writer librist4 libroc0.3 librsvg2-2 librsvg2-common librtmp1
                        libsane-common libsane1 libsasl2-2 libsasl2-modules-db libsdl-sound1.2 libsdl2-2.0-0 libsecret-1-0
                        libshout3 libsndfile1 libsndio7.0 libsox-fmt-alsa libsox-fmt-base libsox3 libspa-0.2-bluetooth
                        libspa-0.2-modules libsrt1.5-gnutls libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl
                        libtinfo6 libupower-glib3 libvte-common libvte9 libwacom-common libwacom9 libwnck-3-0 libxaw7
                        libxfce4ui-2-0 libxfce4util7 libxfconf-0-3 libxml++2.6-2v5 libxmu6 libzmf-0.0-0 libzmq5
                        libzvbi-common live-usb-maker-gui-antix lsof lsp-plugins-lv2 lsp-plugins-r3d-glx luckybackup
                        luckybackup-data lxappearance lxtask man-db mc mc-data mesa-va-drivers mesa-vdpau-drivers
                        mesa-vulkan-drivers moc modem-manager-gui modemmanager mokutil mpg123 mpg321 mupdf ncurses-bin
                        network-assistant nfs-common notify-osd ntfs-3g onboard onboard-common onboard-data openssh-client
                        openssh-server openssh-sftp-server openssl packageinstaller partimage pavucontrol perl perl-base
                        pinentry-gtk2 pipewire pipewire-alsa pipewire-bin pipewire-jack pipewire-pulse poppler-utils
                        printer-driver-brlaser printer-driver-c2esp printer-driver-cups-pdf printer-driver-dymo
                        printer-driver-escpr printer-driver-foo2zjs printer-driver-gutenprint printer-driver-hpcups
                        printer-driver-hpijs printer-driver-postscript-hp printer-driver-ptouch printer-driver-splix python3
                        python3-cairo python3-cups python3-cupshelpers python3-dbus python3-distutils python3-gi
                        python3-gi-cairo python3-lib2to3 python3-minimal python3.11 python3.11-minimal qpdfview
                        qpdfview-pdf-poppler-plugin qpdfview-translations qt5-gtk-platformtheme qt5-gtk2-platformtheme
                        qt5-style-plugin-cleanlooks qt5-style-plugin-motif qt5-style-plugin-plastique qt5-style-plugins qt5ct
                        rpcbind rsync rxvt-unicode samba-common samba-libs sane-airscan sane-utils scrot shared-mime-info
                        simple-scan smbclient socat sox ssh-askpass sshfs streamripper sudo synaptic system-config-printer
                        system-config-printer-common system-config-printer-udev system-keyboard-qt testdisk tmux transmission
                        transmission-cli transmission-common transmission-gtk uno-libs-private upower ure usb-modeswitch
                        vorbis-tools webp-pixbuf-loader wget winff wireless-tools wireplumber wmctrl wpagui wpasupplicant
                        wvdial x11-apps x11-session-utils x11-utils x11-xkb-utils x11-xserver-utils xaw3dg xfburn xfconf
                        xfsprogs xloadimage xorriso xserver-xorg-input-evdev xserver-xorg-input-libinput yad zam-plugins
                        zzzfm
                      473 upgraded, 201 newly installed, 123 to remove and 9 not upgraded.
                      Need to get 582 MB of archives.
                      After this operation, 240 MB of additional disk space will be used.
                      Do you want to continue? [Y/n] n
                      Abort.
                      demo1@antix1-rolling:~
                      $ 
                      

                      How do I get past this so I can get to sid?
                      Thanks

                    Viewing 9 posts - 1 through 9 (of 9 total)
                    • You must be logged in to reply to this topic.