Core installation on UEFI

Forum Forums Official Releases antiX-23 “Arditi del Popolo Core installation on UEFI

  • This topic has 5 replies, 3 voices, and was last updated Aug 30-6:41 pm by gnarlsnishi.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #115152
    Member
    gnarlsnishi

      Hi antiX team! Congrats on the release!
      I am hoping a workaround exists to get an antiX 23 Core installation running on a device that does not support Legacy BIOS.
      I am currently running antiX 22 Base on an old HP Chromebook, using Mr. Chromebox’s UEFI implementation installed over the stock BIOS. (http://mrchromebox.tech/)
      Because I don’t have the ability to enable Legacy BIOS on this machine, I am unable to install using the cli-installer from the Core iso. Is there a way to install only the ‘Core’ packages from the full GUI iso? Or alternatively, enable a UEFI boot from the Core iso?
      Any help would be greatly appreciated!

      • This topic was modified 10 months, 3 weeks ago by gnarlsnishi. Reason: tag formatting
      #115166
      Member
      techore

        @gnarlsnishi, review the following so you understand the tools.

        http://man.archlinux.org/man/efibootmgr.8.en
        http://wiki.archlinux.org/title/EFISTUB
        http://wiki.archlinux.org/title/GRUB

        This video will show you the process. It’s for antiX 16 but the overall process is accurate.

        http://www.youtube.com/watch?v=2JlaO6RyUt4

        I don’t use grub, but rEFInd. Stick with grub but if you are open to using rEFInd, happy to provide my build process for antiX Core. It does make things more complicated.

        Cheers!

        #115167
        Member
        gnarlsnishi

          Interesting, thank you!
          I’d definitely be curious to hear more about using rEFInd, if you’d be willing to provide a tutorial.

          #115174
          Member
          techore

            Keep it simple, initially, but once you have success you can explore the link below using btrfs and rEFInd.

            http://gitlab.com/techore/antix-dwm-guide/-/blob/main/docs/storage.md

            More about rEFInd can be found here:

            http://www.rodsbooks.com/refind/

            More about btrfs can be found here:

            http://wiki.archlinux.org/title/Btrfs

            Best of luck. Take your time and enjoy the adventure! :)

            • This reply was modified 10 months, 2 weeks ago by techore.
            #115303
            Moderator
            christophe

              Hello, gnarlnishi.
              When I read your situation, I decided I wanted to try the same thing (antiX-core x64) on this computer — I have a dell chromebook (candy 3120) that has been reconfigured with a new UEFI “bios”. So I removed my older version of antiX base or full, and reset the internal storage to prepare to install antiX-core.

              As you wrote, it MUST have a x64 OS to work.

              I used the cli-installer, and I only had trouble with grub. To spare you the details (which I will tell, if needed), I ended up using the “boot repair” tool. It’s included in the base/full ISOs.

              After I installed core & discovered my grub (not booting the system) problem, I booted live from a base/full usb, to run the boot repair tool.

              I did both the first & second options — reinstall & repair configuration file.
              It will detect the installed instance & walk you through it.

              It worked very well for me; I’m posting from that antiX-core system now. If you are still not up and running, I highly recommend it.

              • This reply was modified 10 months, 2 weeks ago by christophe.

              confirmed antiX frugaler, since 2019

              #115347
              Member
              gnarlsnishi

                Hey christophe, glad I could be of some inspiration! haha.
                That’s actually exactly what I ended up doing, as I happened to have both the Core and Full isos already burned to two separate USBs.
                Thank you for yoir reply! :)

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.