Desktop entry deleted from ~/.config/autostart/

Forum Forums New users New Users and General Questions Desktop entry deleted from ~/.config/autostart/

  • This topic has 11 replies, 5 voices, and was last updated May 10-4:42 am by 52midnight.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #58495
    Member
    Avatar52midnight

    I’m new to AntiX and running LXDE. I want to start guake in at boot. I created a softlink from /usr/share/applications/guake.desktop to ~/.config/autostart/ as in my other Debian systems. Guake runs, but the link in ~/.config/autostart/ is deleted. I therefore copied the file rather than use a link, but the same thing happens.

    What does this, and why? Most grateful for any assistance.

    #58502
    Member
    AvatarPPC

    It’s been a long time since I’ve dealt with LXDE, but why not simply adding “guake &” (or whatever command you need to enter to get guake to run, with a space and and “&” at the end) to the autostart file, and using the .desktop file?
    That would probably avoid complications… I never added a .desktop file to an autostart file before, I always use commands…

    P.

    #58523
    Member
    XecureXecure

    Did you install LXDE from antix-core or from antiX-full/base? Is your system running live or is it installed? Did you install LXDE from terminal or from synaptic/cli-aptiX/package-installer?
    If you can explain the process, we may be able to reproduce it ourselves and help find a solution.

    • This reply was modified 1 week, 2 days ago by Xecure.
    #58548
    Member
    Avatarskidoo

    websearch
    lxde autostart applications .config/autostart

    2 clicks later
    https://wiki.lxde.org/en/LXSession#Autostarted_applications_using_lxsession

    “Guake runs, but the link in ~/.config/autostart/ is deleted.”
    The “deleted” action, suppose it amounts to “ingested” or “consumed”. Items to be noticed (and ingested|processded) during next session startup… does the lxde documentation explain?

    You might have, or not, installed a “kitchen sink” LXDE metapackage
    (which installs lxsession and other “optional” lxde components).
    Try to compare the list of installed lxde*, lxesssion*, packages vs your other “debian” system to gauge whether any are absent on your antiX system.

    #58553
    Member
    Avatar52midnight

    > why not simply adding “guake &” autostart file … I never added a .desktop file to an autostart file

    LXDE uses the directory ~/.config/ for desktop configuration, and the DIRECTORY ~/.config/autostart/ to autostart required programs. This is done by inserting either a link to the relevant .desktop file in /usr/share/applications/, or an appropriate file.

    For example, my initial problem was with cmst to start connman, the network daemon. After initial experiments I created the /usr/share/applications/cmst.desktop SOFTLINK and removed the existing cmst-autostart.desktop FILE. On reboot, two instances of connman were running, the cmst-autostart.desktop FILE had been recreated, and the cmst.desktop LINK had been deleted. Additionally, there is NO cmst-autostart.desktop FILE in /usr/share/appplications/.

    So SOMETHING knows enough to reconfigure the system, removing the link that it doesn’t want and recreating a file that it does, in spite of there being no equivalent file in /usr/share/appplications/.

    The system is installed, and LXDE was installed from Debian .deb packages.

    Thanks to skidoo for the analysis. I’ve been running LXDE successfully for years on Debian, and do have lxsession installed, but I’ve never had anything like this happen before. I’ll investigate further and report back.

    #58562
    Member
    AvatarPPC

    LXDE uses the directory ~/.config/

    Sorry I did not use the correct expressions to convey what I mean- did you ever try inserting what you want to automatically run at startup in the file ~/.desktop-session/startup ?
    Once again, I’m thinking out loud- I’m not really sure if that file’s content is respected if you run LXDE…
    Reading the link skidoo wrote about did make me think about this part:

    If you cannot get an application automatically started and you already have a .desktop file for it in the autostart directory, then check the setting of the 'OnlyShowIn' key. Try commenting it out or removing the key. If the application still works ok then it's not really GNOME-specific - file a bug report for that application to its author and packager. As an example, the NetworkManager Applet (nm-applet) has the setting "OnlyShowIn=Gnome", but it works fine in LXDE. To make it autostart, just comment out or delete "OnlyShowIn=Gnome" in your ~/.config/autostart/nm-applet.desktop. If you are using different desktop environments on different sessions, and wish to use NetworkManager in LXDE, XFCE and Gnome, but not in KDE, you might want to add "OnlyShowIn=Gnome;XFCE;LXDE;" and/or "NotShowIn=KDE;"

    P.

    #58579
    Member
    Avatarskidoo

    antiX uses apt//dpkg but is not a “debian system”.

    Beyond the preinstalled window managers, other WMs and desktop environments can certainly be installed into antiX operating system, but doing so is not always automatic / seamless.

    “SLiM” starts the X server, then passes to /usr/local/bin/desktop-session which (reads etc/xdg/… and starts the desktop sessiontype); it may (or might not) know how to handle presence/absence of “lxsession”.

    Unless you have installed (idk the exact packagename) the “full” lxde metapackage,
    the lxsession component might not have been automatically installed
    (may be marked a “Recommends:”, vs “Depends:” item, for all packages other than the “full” metapackage)

    Maybe the Exec= line within the “.desktop” file, installed to /etc/xdg/autostart/, declares “Exec=startldxe” or somesuch, based on a presumption that something else has, already, taken care of starting lxsession.

    Few have bothered to experiment installing LXDE.
    When you get it sorted, future readers will benefit if you would care to writeup the necessary steps in a “Tips n Tricks” topic.

    #58580
    Member
    Avatarskidoo

    On reboot, two instances of connman were running, the cmst-autostart.desktop FILE had been recreated, and the cmst.desktop LINK had been deleted. Additionally, there is NO cmst-autostart.desktop FILE in /usr/share/appplications/.

    So SOMETHING

    Right, the “something” is (normally, without lxsesion in the scenario) /usr/local/bin/desktop-session
    which consults the file ~/.desktop-session/startup for the list of autostarted actions.

    Sounds like desktop-session is still “doing its thing” in addition to launching your “session manager”(?lxsession)
    so
    you would want to (would need to) remove, or outcomment, the ~/.desktop-session/startup line(s) redundantly calling connman or conky and/or whatever your “session manager” is autostarting in response to finding .desktop files residing in ( hmm, per your post, in ~/.config/autostart/ )

    #58582
    Member
    Avatar52midnight

    Thanks to all for informed and thoughtful commentary.

    To PPC for the info on ~/.desktop-session. Didn’t know about it.

    And especially to skidoo for both. First up, a confession. I bought a Qotom N190 MiniPC a few years ago – great bit of kit. Installed Debian 10.2 from a USB full-repo stick and it’s been running fine. Bought a second one a few months ago and Deb refused to install – just hung. In frustration I looked around for another Deb-based distro, but most did the same thing. AntiX did not, as neither did MX Linux, which I put aside as being too highly configured.

    AntiX interested me considerably: a lot of thoughtful work has gone into it with some unique results, so I decided to give it a go. I installed LXDE from the USB stick and now have everything – except a few REALLY annoying niggles – running fine, with the added bonus of the unusual AntiX features. Would like to stick with it but need to fix the niggles.

    So … most grateful for the info about /usr/local/bin/desktop-session since it also points to other AntiX scripts that may need attention.

    > Few have bothered to experiment installing LXDE. When you get it sorted, future readers will benefit if you would care to writeup the necessary steps in a “Tips n Tricks” topic.

    OK. I’m sufficiently intrigued by AntiX to persevere if I can get the necessary info, which looks promising.

    I’ve traced the Deb problem down to a very minor change in the SoC. It’s an Intel Bay Trail Atom with four Celeron J1900 cores, and during the interim between my purchases it moved from Stepping 8 to Stepping 9, which has been enough to derail me. The best-laid plans of mice and men …

    At present I’m also posting on the Deb forum to try getting their discover utility fixed, but I assume that AntiX uses its own hardware discovery utility. Can report back on this if it’s of interest.

    Thanks again for all the assistance.

    #58636
    Forum Admin
    DaveDave

    If you plan on sticking with lxde then you might consider removing / commenting out the reference in /etc/slim.conf to start desktop-session and enabling / uncommenting the old startup command. As skidoo said there are two “session” programs running.

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #58651
    Member
    Avatar52midnight

    Thanks Dave. I’ve taken a short break from the frustrations but had decided to start disabling the AntiX-specific config scripts starting with /usr/local/bin/desktop-session, so your suggestion is just what I need to start dismantling things.

    #59078
    Member
    Avatar52midnight

    In /etc/slim.conf I commented out:

    login_cmd setsid /usr/local/bin/desktop-session %session

    … and replaced it with:

    login_cmd setsid /usr/bin/lxsession %session

    Seems to have done the trick.

    > future readers will benefit if you would care to writeup the necessary steps in a “Tips n Tricks” topic

    OK. I’ve installed a clean version of AntiX 19.3 in a separate partition and will document the change-over to LXDE. I’ll take a week or two to complete and verify, but will do as you suggest.

    • This reply was modified 2 days, 19 hours ago by 52midnight.
Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.