Desktop manager (Slim) rejects my username and password – how do I fix this?

Forum Forums General Software Desktop manager (Slim) rejects my username and password – how do I fix this?

  • This topic has 6 replies, 2 voices, and was last updated Jan 15-11:41 pm by mikey777.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #31338
    Member
    Avatarmikey777

    I have lightdm installed as the desktop manager on an antix19core-LXDE setup.

    I thought I might look at both lxdm and Slim , and compare them to lightdm.
    So I downloaded & installed them, using the cli-package manager – no problem there. I then discovered that when you’ve got more than one desktop manager installed, a choice comes up on the display, asking which one you want to try: I chose Slim. However, when I rebooted to Slim, it rejected the username & password I have been using routinely with lightdm, saying these were “incorrect” – I’m now unable to boot to my netbook.

    How do I do fix this?

    #31342
    Forum Admin
    anticapitalistaanticapitalista

    edit /etc/slim.conf as I posted to you here:

    Cannot enable autologin – how to fix this ?

    You need changes like this:

    login_cmd         exec /bin/bash -login /etc/X11/Xsession %session
    #################OLD COMMAND####################
    # login_cmd         exec /bin/bash -login ~/.xinitrc %session >~/.xsession-errors$DISPLAY 2>&1
    ################################################
    #LOGIN COMMAND FOR DESKTOP SESSION BELOW#
    #############################################################################################
    #login_cmd   setsid /usr/local/bin/desktop-session %session 
    #############################################################################################
    
    auto_login          yes
    
    # default user, leave blank or remove this line
    # for avoid pre-loading the username.
    default_user        anticap
    • This reply was modified 1 month, 1 week ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31343
    Member
    Avatarmikey777

    Thanks anticapitalista for your reply.

    I take your point about you mentioning this before. That was a slightly different problem, about trying to autologin, which I was unable to get working when editing slim.conf, when I only had lightdm installed. I realise now that I should have maybe been editing lightdm.conf for autologin ! Is that correct? Stupidly, at the time, I didn’t connect Slim desktop manager with slim.conf.

    The problem here, is that I’m now just stuck on the Slim login window, which wont accept username & password. I assume that to get into the netbook, I’ll need to do this from the live environment, e.g. with a USB stick. From there how do I edit slim.conf or lightdm.conf on the SSD-installed system ? Do I just go in as root (su + root password) and edit from there. I haven’t done this before so am a bit hesitant about this … however I’m learning all the time, a steep learning curve at that …

    #31344
    Forum Admin
    anticapitalistaanticapitalista

    From the live environment, you should be able to see your installed version under /media vi rox-filer.
    Then it that folder navigate to /etc/slim.conf – right click and choose edit as root – make the changes suggested in post above.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31377
    Member
    Avatarmikey777

    From the live environment, you should be able to see your installed version under /media vi rox-filer.
    Then it that folder navigate to /etc/slim.conf – right click and choose edit as root – make the changes suggested in post above.

    I don’t see /media vi rox-filer.
    Instead, using the gui, under /media I have 4 folders, i.e. antiX-Live, demo, EFI-LIVE and sda1.
    sda1 is where the netbook’s antix19core-LXDE is installed.
    When I arrive at /media/sda1/etc/ I right click & choose the option ‘edit as root’ so I can edit /media/sda1/etc/slim.conf: when I enter my password it says “Wrong password” – I’m assuming the default password in the live environment is “root” but it wont accept it …

    I’m using antix19.1_386-base.iso to access the antix19core-LXDE installation, as it gives me both a terminal and a gui to work with.

    • This reply was modified 1 month, 3 weeks ago by mikey777.
    • This reply was modified 1 month, 3 weeks ago by mikey777.
    • This reply was modified 1 month, 3 weeks ago by mikey777.
    #31383
    Forum Admin
    anticapitalistaanticapitalista

    vi= typo for via

    password is demo

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31740
    Member
    Avatarmikey777

    @anticapitalista
    Thankyou for your help & encouragement.
    Unfortunately, I couldn’t make any progress with this issue re. Slim, or other (lxdm) desktop managers, so in the end stayed
    with lightdm which is fine. My foray into Slim & lxdm was curiosity-driven, thinking that maybe the antixcore install could be
    made even lighter still. However, lightdm work just fine for me, the system running really snappily with it, so I’m very happy
    as things stand.

    The solution for autologin in lightdm is given as follows, using the modification suggested by Dolphin:

    [HOT TIP] How to autologin with lightdm

    • This reply was modified 1 month ago by mikey777.
Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.