[UNSOLVED] Difficulty setting up get-iplayer

Forum Forums General Software [UNSOLVED] Difficulty setting up get-iplayer

  • This topic has 9 replies, 4 voices, and was last updated Jan 30-9:50 pm by mikey777.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #31913
    Member
    mikey777

      I wish to set up get-iplayer in antixcore64bit-LXDE, and have been looking at the discussion between terrybull and skidoo to help get me started, which was posted at https://www.antixforum.com/forums/topic/get-iplayer/

      In terminal, I downloaded version 3.24 to /home/mike/Downloads without any problems using:

       
      wget http://gitlab.com/skidoo/get-iplayer/blob/master/get-iplayer_3.24~skigit_all.deb
      

      However this is the output from terminal, when I try to install it. There’s obviously a problem, similar to what terrybull experienced, but it’s unclear how terrybull resolved it:

      
      mike@antixcore:~/Downloads
      $ sudo dpkg -i get-iplayer_3.24~skigit_all.deb
      dpkg-deb: error: 'get-iplayer_3.24~skigit_all.deb' is not a Debian format archive
      dpkg: error processing archive get-iplayer_3.24~skigit_all.deb (--install):
       dpkg-deb --control subprocess returned error exit status 2
      Errors were encountered while processing:
       get-iplayer_3.24~skigit_all.deb
      

      Any help with this is much appreciated.

      • This topic was modified 4 years, 5 months ago by mikey777.

      ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
      - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
      ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
      - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
      - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

      #31916
      Anonymous

        I think the package has yet to be properly packed…

        male@antix19:~
        $ http://gitlab.com/skidoo/get-iplayer/blob/master/get-iplayer_3.22~skigit_all.deb
        bash: http://gitlab.com/skidoo/get-iplayer/blob/master/get-iplayer_3.22~skigit_all.deb: Datei oder Verzeichnis nicht gefunden
        male@antix19:~
        $ wget http://gitlab.com/skidoo/get-iplayer/blob/master/get-iplayer_3.22~skigit_all.deb
        --2020-01-23 14:08:45--  http://gitlab.com/skidoo/get-iplayer/blob/master/get-iplayer_3.22~skigit_all.deb
        Auflösen des Hostnamens gitlab.com (gitlab.com)… 35.231.145.151
        Verbindungsaufbau zu gitlab.com (gitlab.com)|35.231.145.151|:443 … verbunden.
        HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
        Länge: nicht spezifiziert [text/html]
        Wird in »get-iplayer_3.22~skigit_all.deb« gespeichert.
        get-iplayer_3.22~skigit_all.deb      [ <=>                                                     ]  35,75K  --.-KB/s    in 0,03s   
        2020-01-23 14:08:46 (1,28 MB/s) - »get-iplayer_3.22~skigit_all.deb« gespeichert [36603]
        male@antix19:~
        $ su
        Passwort: 
        root@antix19:/home/male# apt install ./get-iplayer_3.22~skigit_all.deb
        Paketlisten werden gelesen... Fehler!
        E: Unterprozess Popen hat Fehlercode zurückgegeben (2)
        E: Encountered a section with no Package: header
        E: Problem with MergeList /home/male/get-iplayer_3.22~skigit_all.deb
        E: Die Paketliste oder die Statusdatei konnte nicht eingelesen oder geöffnet werden.
        root@antix19:/home/male# exit
        exit
        male@antix19:~
        
        #32048
        Member
        mikey777

          @male
          Many thanks for your reply.
          Yes, I couldn’t get version 3.22 to install either…
          A problem with the packages. It would be good to have some feedback from skidoo on this,
          as he seems to have prepared both the 3.22 and 3.24 get-iplayer versions for Debian. Hopefully,
          he may see this post and answer …

          ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
          - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
          ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
          - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
          - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

          #32064
          Member
          VW

            Doesn’t your version of antiX come with a search engine?

            get_iplayer Guides and Tutorials

            The state propaganda service doesn’t like you using get-iplayer because they like to control everything. A good example of all their control freakery is all the efforts they made to shut down a certain radio station on a ship in the North Sea. They like to keep changing things in order to prevent get-iplayer from working and so you always need to install the latest version.

            “These are the times that try men's souls" - Thomas Paine

            #32088
            Member
            mikey777

              @VW
              I take your point about the BBC, but this is not the issue.
              The problem is that for Debian10 based distros (antiX included), there is no installation candidate for giPlayer.deb, but there is for other distros (e.g. Ubuntu or ArchLinux based ones), where it works.

              ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
              - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
              ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
              - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
              - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

              #32089
              Member
              VW

                Yes, because the BBC keep changing things, while Debian likes stability, it’s best to get it from Source-forge and build it yourself, but problems arise when the BBC changes something and Source-forge hasn’t developed a fix yet.

                “These are the times that try men's souls" - Thomas Paine

                #32115
                Member
                seaken64

                  This is probably beyond my geek level, but have you tried using Gdebi? Gdebi works out dependencies and has helped me install stuff by providing me clues as to what else need to be installed.

                  Seaken64

                  • This reply was modified 4 years, 5 months ago by seaken64.
                  #32248
                  Member
                  mikey777

                    This is probably beyond my geek level, but have you tried using Gdebi? Gdebi works out dependencies and has helped me install stuff by providing me clues as to what else need to be installed.
                    Seaken64

                    Thanks Seaken64. I had tried Gdebi already, but it didn’t work.
                    I finally got get-iplayer working with version 3.94. I’m still a bit puzzled on how I achieved this, but am working on it! As soon as I’ve worked out how I succeeded, I’ll post a step-by-step tutorial on the forum. It’s a question of going through the steps again with a fresh install of antix, and repeated what I think I did to see if I get the same result …

                    ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
                    - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
                    ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
                    - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
                    - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

                    #32253
                    Member
                    seaken64

                      Ok, good. I look forward to your write-up.

                      Seaken64

                      #32281
                      Member
                      mikey777

                        @male
                        @VW
                        @seaken64

                        I’ve now posted an easy-to-follow tutorial on all you need to know for installing and using get-iplayer.
                        See: https://www.antixforum.com/forums/topic/tutorial-how-to-install-get-iplayer-for-downloading-bbc-radio-tv-programmes/

                        • This reply was modified 4 years, 5 months ago by mikey777.

                        ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
                        - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
                        ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
                        - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
                        - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

                      Viewing 10 posts - 1 through 10 (of 10 total)
                      • You must be logged in to reply to this topic.