Disabling Pipewire in antiX-23

Forum Forums General Tips and Tricks Disabling Pipewire in antiX-23

  • This topic has 72 replies, 12 voices, and was last updated Oct 25-2:22 pm by Brian Masinick.
Viewing 15 posts - 46 through 60 (of 73 total)
  • Author
    Posts
  • #120965
    Member
    abc-nix

      When I run the command, a toggle window with a green oval inside launches. When I click on the oval, nothing happens except an information popup that says Pipewire is the sound server and will start at the next boot.

      @stevesr0, this is not my script. My script doesn’t say a thing once you toggle it. It will only ask for a password and render the same window with the “oval” with a changed color if the password was correct.
      Did you place the script in /usr/local/bin?

      EDIT: My guess is that you also ran the last command PPC mentioned in his post, which replaces my script with the old script.

      • This reply was modified 8 months, 4 weeks ago by abc-nix.
      • This reply was modified 8 months, 4 weeks ago by abc-nix.
      #120969
      Moderator
      Brian Masinick

        @stevesr0 For me, I did copy the procedure toggle_pipewire from my ~/bin directory to /usr/local/bin, but I primarily use it from my own privately managed ~/bin directory.

        First things first: the very first thing I did after I downloaded the program was of course to untar the image.
        However, the @abc-nix updated version is named toggle_pipewire.7z so this version requires the use of
        p7zip -d toggle_pipewire.7z to extract the toggle_pipewire script, then of course it has to be made
        executable, e.g. chmod +x toggle_pipewire, then it can be executed.

        I assume that 1) you have the latest version, the one with the .7z suffix; if not, get that one.
        I also assume that you have extracted the file properly, made it executable, so the comments above
        are simply to confirm all of that.

        Assuming all of that is correct, when you run the image, you should see a green colored icon
        within the toogle_pipewire running image. If it’s not green, then pipewire is not running.
        Also, I noticed a popup notification, indicating whether pipewire was enabled or disabled.
        When it’s disabled, the popup notification should change and the icon should be colored red.
        If that is not the case then your image is not working; I’d download the toggle_pipewire.7z
        image again if it’s not working, then execute p7zip -d toggle_pipewire.7z
        then chmod +x toggle_pipewire, then try again.

        Let us know if that makes any difference.

        --
        Brian Masinick

        #120978
        Member
        stevesr0

          Hi abc-nix and Brian,

          I will check what I did wrong and report <g>.

          Brian’s mention of making the file executable sounds possibly like one issue. I will check the permissions. If that file is NOT set as executable, I will fix that and see if all works.

          As to copying the backup file over the “new” one generated from the 7x file, I don’t think that is the case, but I will check that.

          If one of these isn’t the problem, I will do the process over again.

          Thanks for suggestions.

          stevesr0

          #121015
          Moderator
          Brian Masinick

            Yeah, if the file is not executable, 1) the green and red colors will probably not be visible and of course, 2) the executable itself will not function.

            It’s a vital step, but it’s really easy to fix with the handy chmod +x command, in this case chmod +x toggle-pipewire.

            --
            Brian Masinick

            #121042
            Member
            stevesr0

              Brian, It was already set as executable when I checked this morning.

              abc-nix and Brian,

              SOLVED (apparently).

              I was using sudo – and it doesn’t toggle when I issue the command as sudo.

              When I use the command as a user, it works.

              (Don’t know if that is the expected behavior??)

              (Although the first time, it asked for my admin password, which I think is not supposed to be needed.)

              When I toggle Pipewire on, alsamixer launches displaying Pipewire as the sound server. When I toggle Pipewire off, it launches with the default screen with the built in server.

              PAVUCONTROL also works when Pipewire is toggled on and “searches for connection” when it is turned off.

              stevesr0

              #121043
              Member
              PPC

                it asked for my admin password, which I think is not supposed to be needed

                The script newest version does need elevated privileges, so you have to enter your password (or the password was recently entered and the system still “remembers” it).

                P.

                #121051
                Moderator
                Brian Masinick

                  Just to confirm the “normal” usage and behavior:

                  1) you run the toggle-pipewire tool as an ordinary user.
                  2) when you request a change in the sound server, it asks for your password.
                  3) when the toggle-pipewire script is ready to change from the initial state,
                  the object color is green, and when it’s been altered it’s red.

                  --
                  Brian Masinick

                  #121072
                  Member
                  stevesr0

                    Nice summary Brian.

                    That is the way it seems to be working on my antiX22–>antiX23 install.

                    The only peculiar thing is that while it asks for the password for elevated privileges, it DOESN’T (on my install) accept sudo.

                    stevesr0

                    P.S. I forgot to scrutinize the behavior of the ALSA “volume” icon. I will report back after I see if that is consistently showing up and working.

                    #121075
                    Member
                    abc-nix

                      Pipewire is started “by the user” (in the startup file), and not by root. That is why the script must be run by the user. If it is run by root, then audio changes cannot be performed by the user nor programs started by the user.

                      If you run the toggle_pipewire with sudo, you are running it as root. Root doesn’t have a .desktop-session/startup, and even if it had, changes done to it will not influence the user’s startup file, so pipewire will not be enabled or disabled in future boots.

                      The only reason we have changed it to require root privileges is for removing/adding pipewire configuration changes to ALSA. Alsa configuration files in /etc/alsa are owned by root, so they require root permissions to be changed. If pipewire-alsa was removed, then this step wouldn’t be needed, but then you would have a mixture of pipewire for some programs and pure alsa for others.

                      In summary: toggle_pipewire is run by the user because pipewire must be started by the user (and we need to edit the user’s startup file). We use a smart way to run only certain parts with sudo (the rest keeps the user permissions) and that is why it requires a password for making those specific special changes.

                      EDIT: Also, the GUI can be launched in wayland because it isn’t started by root. Root GUI is blocked on wayland. All antiX scripts that may require gksudo/su-to-root/sudo to start a GUI will have to be updated in the future if there is ever interest in a wayland release for antiX. The reason that synaptic was removed in the past from Debian repos was exactly because it could not be started in wayland without a hack, as it requires root permissions to start.

                      • This reply was modified 8 months, 4 weeks ago by abc-nix.
                      #121099
                      Member
                      stevesr0

                        hi abc-nix,

                        That is a very clear explanation. Thanks.

                        stevesr0

                        #121235
                        Member
                        abc-nix

                          @anticapitalista
                          Can you upload antix-pipewire-extras to the gitlab repo? I want to send the fixes proposed in this thread.

                          #121249
                          Forum Admin
                          anticapitalista

                            @anticapitalista
                            Can you upload antix-pipewire-extras to the gitlab repo? I want to send the fixes proposed in this thread.

                            Here it is:

                            https://gitlab.com/antiX-Linux/antix-pipewire-extras

                            Philosophers have interpreted the world in many ways; the point is to change it.

                            antiX with runit - leaner and meaner.

                            #121252
                            Member
                            stevesr0

                              If we have applied the toggle pipewire fix already, is there any reason to install the antix-pipewire-extras upgrade for antiX-23?

                              stevesr0

                              #121256
                              Member
                              abc-nix

                                Here it is:

                                https://gitlab.com/antiX-Linux/antix-pipewire-extras

                                Thanks, anticapitalista. I just sent the merge request. Thanks for your patience.

                                I included a fix for pipewire-start so that it will work with and without the custom pipewire.conf provided by antiX. No more problems or users reporting problems with pipewire after this update.

                                Thanks to all the testers and people who provided help and interesting discussion. In no partiular order, PPC, anti-apXos, Brian Masinick, marcelocripe, stevesr0, olsztyn, blur13, Xunzi_23, calciumsodium and anticapitalista.

                                If we have applied the toggle pipewire fix already, is there any reason to install the antix-pipewire-extras upgrade for antiX-23?

                                If you already applied the toggle and don’t use pipewire-start, then you don’t need the package.

                                • This reply was modified 8 months, 3 weeks ago by abc-nix.
                                • This reply was modified 8 months, 3 weeks ago by abc-nix.
                                • This reply was modified 8 months, 3 weeks ago by abc-nix.
                                #121267
                                Forum Admin
                                anticapitalista

                                  Updated debs coming soon

                                  Philosophers have interpreted the world in many ways; the point is to change it.

                                  antiX with runit - leaner and meaner.

                                Viewing 15 posts - 46 through 60 (of 73 total)
                                • You must be logged in to reply to this topic.