Display Mounted External Storage in pcmanfm?

Forum Forums General Software Display Mounted External Storage in pcmanfm?

  • This topic has 9 replies, 5 voices, and was last updated Nov 21-1:50 pm by Anonymous.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #71185
    Anonymous

      Good Day Folks,

      I am using pcmanfm as my default file manager and am having troubles finding mounted hard drives, such as USB / external hard drives. Usually pcmanfm usually shows the mountable drives in the side panel and can be mounted by clicking on the device, but pmnout mounts hard drives in a different place and pcmanfm doesn’t pick it up before and after mount somehow?

      When I use zzzFM I do see the mountable and mounted storage, but not when using pcmanfm?

      I don’t wanna change the defaults too much, mounting can be a pain if one has to do it manually. What setting in pcmanfm can I change to be in harmony with Antix? I know pcmanfm can be started as a daemon, but then I need to disable Antix’s automount setup, which is a service run at startup?

      #71212
      Member
      Xecure

        If you are using desktop-session to start the window manager, then enable the dbus session launch
        DBUS_SESSION_LAUNCH="true"
        in ~/.desktop-session/desktop-session.conf and restart your session.

        If you are starting the window manager from xinit or some other methode, append
        dbus-run-session --
        before the path or command to your window manager, so that a dbus session is started for it.

        You need a dbus session for pcmanfm to see network/external devices, etc.

        • This reply was modified 2 years, 7 months ago by Xecure.

        antiX Live system enthusiast.
        General Live Boot Parameters for antiX.

        #71295
        Anonymous

          Hi Xecure,
          Thanks for the suggestions, I have tried both and none of them worked. After each change I logged out and in again, but it made no difference. Lemme restart and check.

          FYI, I am running i3, but still autostart with the default icewm-session file.

          Try 1) I added DBUS_SESSION_LAUNCH=”true” & to my .desktop-session file
          Try 2) I added exec dbus-run-session — to my .config/i3/config file

          Both failed to work 🙁

          I also tried starting pcmanfm as a daemon, with the pcmanfm -d command at startup, also failed 🙁

          #71299
          Member
          Xecure

            Strange. If you run from terminal:
            dbus-launch --sh-syntax --exit-with-session pcmanfm
            Does it also not show devices and networks?

            I know it worked on antiX 19 when I created this dbus option, and also on antiX 21 beta, when lunching programs from the window manager menu. Maybe things that start from the applications started by ~/.desktop-session/startup and not from the window manager (I assume i3 has no menu) are not included inside the dbus session.

            I will investigate a bit, and see if there is a more holistic method, without touching desktop-session too much.

            antiX Live system enthusiast.
            General Live Boot Parameters for antiX.

            #71308
            Anonymous

              Hi Xecure,

              Your command below executed in the terminal opens up pcmanfm.
              dbus-launch –sh-syntax –exit-with-session pcmanfm

              The picture shows what I see after your command has been executed

              #71310
              Member
              Xecure

                This is what I get:
                pcmanfm
                when launching the command or starting pcmanfm from the fluxbox menu.

                Did you install pcmanfm with recommends?
                sudo apt install --install-recommends pcmanfm
                This installs gvfs-backends and gvfs-fuse, which may be needed for the functionality you want.

                antiX Live system enthusiast.
                General Live Boot Parameters for antiX.

                #71313
                Moderator
                BobC

                  I used to run PCManFM.

                  No offense, but SpaceFM is a fork that was a bunch of improvements over PCManFM, and zzzFM is a different twist of SpaceFM.

                  So why not just them a try and learn how to use them, and enjoy a few of the tricks that made them better?

                  If PCManFM was better, we would be running it instead.

                  LOL, just my 2 cent opinion…

                  PS: It’s fine if you run all these other things if that’s what you like. We all like trying new and different things, too.

                  • This reply was modified 2 years, 7 months ago by BobC.

                  Daily driver distro https://www.antixforum.com

                  #71322
                  Member
                  stevesr0

                    This might be a silly thought – because I am currently on SpaceFM rather than pcmanfm, but in SpaceFM, I sometimes have had to play with the “Devices” options to display different drives. If there is a “Devices” tab (and you haven’t tried modifying it already), that might enable the display of the drives you want.

                    stevesr0

                    #71324
                    Anonymous

                      pcmanfm views drives.
                      Edit > Preferences > Layout > Show in Places > Devices and more are here.

                      #71348
                      Anonymous

                        Gonna mark this issue as solved. I am sure the GVFS installation suggested by Xecure would fix all my problems.

                        Not keen to install so many additional packages for just one app to work, so I have decided to start using zzzFM and rox-filer instead. haha.

                      Viewing 10 posts - 1 through 10 (of 10 total)
                      • You must be logged in to reply to this topic.