Dist upgrade WARNING

Forum Forums News Sid Upgraders Dist upgrade WARNING

  • This topic has 28 replies, 13 voices, and was last updated Jul 16-5:37 pm by LikkMii.
Viewing 14 posts - 16 through 29 (of 29 total)
  • Author
    Posts
  • #41304
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    As from today, 6 August 2020 Grrek time, a dist-upgrade will remove essential parts of antiX ie the logout dialog box.

    Seems like python2 is being totally dumped by sid.

    Working on a remedy.

    I know little on antix internals. Is the logout dialog box etc. affected only because our existing scripts are still based on Python 2.7? Is it a matter of migrating those scripts to Python 3? If so, there is an official “2to3” tool provided by Python 2.7 that can possibly help. Just a fyi…

    Sorry for missing your post.

    Yes it is all about migrating from python2.7 to python3.x.
    There is a tool that helps in migrating, but it is obviously not 100% perfect.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #41628
    Member
    zeh
    Helpful
    Up
    0

    Where did you get praise from? Are you using 32 or 64 bit antiX?

    Just to close my case (sorry for the lateness).
    I don’t know how praise landed in the system, I just know that I’ve installed some extra apps (from the repos – PI & Synaptic).
    Anyway, I’ve tried to use aptitude to have a look at dependencies, but made a mistake, clicked a wrong function and started seeing packages being uninstalled. Immediately closed aptitude, but it was already too late – the system was already broken. Hence, I’ve reinstalled.

    #44818
    Member
    catfood
    Helpful
    Up
    0

    This has been good practice anyways for sid.

    I’ve been running Linux BBQ for a while (antix/siduction), and dist-upgrades there have very often broken things in sid. Apt-autoremove also breaks sid at random.

    Howdy Jessie.

    #46062
    Member
    ile
    Helpful
    Up
    0

    Hello anticapitalista and everyone
    rsyslog 2.2010.0-1.0nosystemd1 succeeded. Thank You.
    and
    ifupdown is quicker again. (?) something made difference, in both sid, debian and antiX.

    #49882
    Member
    ile
    Helpful
    Up
    0

    hello anticapitalista

    installed <app-select-antix 1.0.3 >
    it went into reside app-select, auto. picked up this machine’ app.s.
    Beautiful

    #63062
    Member
    biomettha
    Helpful
    Up
    0

    My antix version is 19.1 with kernel 4.9. I recently changed the system python version from 2 to 3 via update alternatives. After that logout button is not working. Would this be resolved by changing back to python2?

    #63063
    Member
    Xecure
    Helpful
    Up
    0

    Launch the logout script to see what errors it spits out.
    desktop-session-exit
    I think that the newest version of desktop-session already uses python3. Will check in a bit.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #63064
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    Make sure you are fully updated.
    Check that the repos are working.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #63065
    Member
    ile
    Helpful
    Up
    0

    hello biomettha and Xecure
    desktop-session stepped over the python 3 line on a August 9, 2020 upgrade.
    That is a buster [0.5.26] problem, not a sid [2.0.2] problem.
    What version of desktop-session-antix is installed on the sid machine? [2.0.2]

    and confirm with us it is 64bit, and its repositories, and desktop-session version, please.
    I do not use logout so neglected to learn to fix it [buster.] Do you have many users?
    hello anticapitalista.

    #63113
    Member
    biomettha
    Helpful
    Up
    0

    It was a python version problem. I resorted back to python version 2 through update alternatives and it was resolved.Mine was an intel Pentium dual core. Antix 19.1 with buster works well. 19.4 seems to have some starting problem with a live usb . Hence I am wary of trying it. Might pick up sometime later.
    More info:
    64 bit
    Single user

    • This reply was modified 2 months, 1 week ago by biomettha.
    • This reply was modified 2 months, 1 week ago by biomettha.
    #63116
    Member
    biomettha
    Helpful
    Up
    0

    Desktop-icewm
    I don’t know how to check repo version

    #63117
    Moderator
    caprea
    Helpful
    Up
    0

    You can post the output from terminal of
    inxi -r

    #63121
    Member
    LikkMii
    Helpful
    Up
    0

    Gotta love inxi

    #63122
    Member
    LikkMii
    Helpful
    Up
    0

    sudo apt-get install stacer is a must use too. Don’t leave it on. Check, cleanup, set startups and close the thing…as some… not bald guyz… would say ‘itza bloated”
    The biggest bloat haters have 32 plus. PoorMee only has 8.
    Bloat is no bother. If ya got 8, burn up 4. Who cares ?

Viewing 14 posts - 16 through 29 (of 29 total)
  • You must be logged in to reply to this topic.