Does a completely grey desktop indicate a video output problem?

Forum Forums New users New Users and General Questions Does a completely grey desktop indicate a video output problem?

This topic contains 35 replies, has 9 voices, and was last updated by ramchip May 14-5:54 pm.

Viewing 15 posts - 1 through 15 (of 36 total)
  • Author
    Posts
  • #9787
    Member

    ramchip

    Briefly, the hardware is an ATI Radeon HD 3800 series graphics card connected via its AGP port to a motherboard which runs an Athlon processor.
    The software: video driver is ‘radeon’ and the kernel version is 4.9.87-antix.1-486-smp.

    I note the following lines found in dmesg:

    radeon_agp_init [radeon] * ERROR* Unable to acquire AGP: -19
    Forcing AGP to PCIE mode.

    I’ve checked the Xorg log and it appears to be error free.

    So, after a fresh installation the desktop is completely grey with the MENU bar at the bottom.
    Is the default desktop grey? I’m guessing that it’s not, but as a new AntiX user I simply don’t know.
    The machine supports a legacy dual-boot system and the other O/S is quite happy to use the AGP without any fuss.
    I’m concerned about the failure of AntiX to initialize the AGP.
    Is there anything that can be done in order to solve this quickly?

    #9789
    Moderator
    fatmac
    fatmac

    Without tweaking anything, you should come up into the IceWM with the same picture that is the header up above.

    You say that you have a menu bar at the bottom, does it function properly, that is, can you start programs?

    (Did you check that you got a good download?)

    Linux (& BSD) since 1999

    #9792
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    more than likely you’ve either booted a *min for the desktop (like icewm-min) or for some reason the desktop-session settings aren’t loading all the way. Sounds like the rox-pinboard is not running for some reason. I would try switching desktops with the “Other Desktops” option in the menu, say to rox-icewm if its there.

    • This reply was modified 6 months, 2 weeks ago by dolphin_oracle.
    #9794
    Member

    ramchip

    Yes, fatmac, various programs can be accessed from Menu without any problems.
    Although, I’m disappointed with the weird behaviour generally.
    Specifically, when I try to shutdown, I click ‘Logout’, then ‘OK’ to confirm logout.
    Momentarily, I can see a console screen full of startup information (“Welcome to AntiX”, etc.) and a login prompt, before the login splash screen reappears.
    The image displayed is a deserted station platform and a train with unnatural light beams.
    Incidentally, this is in monochrome, not the coloured version I recall from the installation screen.
    I can repeat this loop and never shutdown or call it a day and hit the power switch.
    Apparently, no controlled shutdown is available.
    I can’t use the AntiX side of this machine for anything important until this is fixed.

    Regarding the viability of the download, I have the DVD here.
    It was made on 12th April and contains the file antiX-17.1.386-full.iso.
    If there is a method to verify this file is 100% valid, please let me know.
    Certainly, the burning software verified it to be a faithful copy.

    I think some gremlin is preventing this old (but still useful) system from performing as it should and hopefully it’s a simple fix. Having a few years of experience with Ubuntu I’m fairly confident. Some pointers to help iron out these post-installation problems would be much appreciated.

    Surely, the failure of radeon_agp_init is a big clue. Could someone shed light on that, please?

    Yes, dolphin_oracle, the rox-icewm is there and when I logged-in I had the colour splash screen!
    However, the shutdown failure persists, it’s stuck in a login loop. What next?

    #9795
    Moderator
    masinick
    masinick

    Regarding the checking of the image, there are checksums available, so as long as you are familiar with them and how to use them you can commpare the md5sum to the posted value.

    I am not personally familiar with the error message you shared or the reason it is appearing; the developers can speak to this when they review this thread. Sorry that I don’t have a more useful contribution.

    Brian Masinick

    #9796
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    some infromation would be useful

    Please post output of inxi -F

    is there not a shutdown option in the logout manager. Logout does what it says…logout. there should also be a shutdown button. the correct logout script should have several options.

    you can also type “halt” followed by root password at the login prompt to shutdown that way.

    • This reply was modified 6 months, 2 weeks ago by dolphin_oracle.
    #9809
    Forum Admin
    Dave
    Dave

    As D.O. Says… there should be several options. I am thinking that you are getting the generic icewm logout menu… Are you clicking “logout” in the root menu or pressing/expanding the arrow beside it?

    What should come up from the menu would be the same as running “desktop-session-exit” in the run dialog or in terminal.

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #9821
    Member

    ramchip

    Thanks for your replies. I have the output of ‘inxi -F’ here, but can’t include it because of all the formatting in the text file I prepared.

    
    inxi -F > inxi.txt
    

    How can I remove that to produce a readable report for the forum?
    For example, this is what it currently looks like:

    #[1;34mSensors: #[0;37m #[1;34mSystem Temperatures: cpu:#[0;37m No active sensors found. Have you configured your sensors yet?

    Incidentally, no, I have not configured temperature sensors and I’ve also noted that the CPU speed is showing as 0 GHz! I would like to resolve those minor problems later.

    The Shutdown option is not shown on the Logout menu.
    At the moment it is impossible to perform a clean shutdown.
    Obviously, this is a major problem!

    When the console is momentarily visible between Login screens I can see that the X display manager is called slim. Are there any diagnostics for slim?

    There’s clearly some way to go in order to get this configuration optimised.
    I can see that AntiX has great potential to make this machine really useful again, but it needs several tweaks, as yet.

    • This reply was modified 6 months ago by rokytnji.
    #9822
    Member
    sleekmason
    sleekmason

    Noted your kernel version. You changed kernels from the original installation? I do not know if that would make any difference as to the Radeon card.

    To post the output of inxi, copy and paste the output into the reply box, then highlight the output, then hit the “code” button and it will output into the proper format.

    • This reply was modified 6 months, 2 weeks ago by sleekmason.
    #9826
    Forum Admin
    Dave
    Dave

    As D.O. Says… there should be several options. I am thinking that you are getting the generic icewm logout menu… Are you clicking “logout” in the root menu NO or pressing/expanding the arrow beside it? YES

    What should come up from the menu would be the same as running “desktop-session-exit” in the run dialog or in terminal.

    Try pressing “logout” in the *root* menu. Do not expand the logout menu.

    In other words press the label text “logout” for the logout menu. If you have a submenu off of the main menu you have gone to far.

    • This reply was modified 6 months, 2 weeks ago by Dave.

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #9829
    Member

    ramchip

    Okay, this is the inxi output rendered via the torturous route of a floppy because Athlon is not connected to the internet at this time. You may well chuckle at that, but my Kingston USB memory stick is not recognised by AntiX yet, so that’s another tweak for later.

    System:    Host: Athlon Kernel: 4.9.87-antix.1-486-smp i686 bits: 32
               Desktop: IceWM 1.4.2 Distro: antiX-17.1_386-full Heather Heyer 17 March 2018
    Machine:   Device: desktop Mobo: ASUSTeK model: A7N8X-E v: REV 2.xx serial: N/A
               BIOS: Phoenix v: ASUS A7N8X-E Deluxe Rev 1013 date: 11/12/2004
    CPU:       Single core AMD Athlon XP 3200+ (-UP-) cache: 512 KB speed: 2191 MHz (max)
    Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV670 [Radeon HD 3690/3850]
               Display Server: X.Org 1.19.2
               drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
               Resolution: 1440x900@59.89hz
               OpenGL: renderer: Gallium 0.4 on AMD RV670 (DRM 2.49.0 / 4.9.87-antix.1-486-smp, LLVM 3.9.1)
               version: 3.3 Mesa 13.0.6
    Audio:     Card-1 Creative Labs CA0106/CA0111 [SB Live!/Audigy/X-Fi Series]
               driver: snd_ca0106
               Card-2 NVIDIA nForce2 AC97 Audio Controler (MCP) driver: snd_intel8x0
               Sound: Advanced Linux Sound Architecture v: k4.9.87-antix.1-486-smp
    Network:   Card-1: NVIDIA nForce2 Ethernet Controller driver: forcedeth
               IF: eth1 state: down mac: 00:0e:a6:cd:70:66
               Card-2: Marvell 88E8001 Gigabit Ethernet Controller driver: skge
               IF: eth0 state: down mac: 00:0e:a6:cd:66:40
    Drives:    HDD Total Size: 160.0GB (8.7% used)
               ID-1: /dev/sda model: ST3160215ACE size: 160.0GB
    Partition: ID-1: / size: 72G used: 12G (17%) fs: ext4 dev: /dev/sda6
               ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
    Sensors:   System Temperatures: cpu: No active sensors found. Have you configured your sensors yet? mobo: N/A gpu: 58.0
    Info:      Processes: 129 Uptime: 3 min Memory: 73.1/3031.0MB
               Client: Shell (bash) inxi: 2.3.54

    I have not changed the kernel, this is exactly as installed from my DVD.
    Still no joy with shutdown.
    The loop persists and the only time I see a shutdown option is if I expand the logout menu.
    If I could quit the window manager it might help.
    At least I could then login as root and issue a shutdown command.
    How can I quit ice to arrive at the console, which is in the background?

    • This reply was modified 6 months, 2 weeks ago by rokytnji.
    #9830
    Member
    sleekmason
    sleekmason

    How can I quit ice to arrive at the console, which is in the background?

    CTRL+ALT+F2

    #9854
    Member

    ramchip

    Thanks sleek, now I can shutdown successfully, but having to resort to this method is far from ideal.
    The logout/shutdown scheme in the window managers seems to fail all the time on my Athlon machine.
    I would still like to know if anyone can shed light on the original problem with radeon_agp_init, please.
    In the meantime I shall double check the validity of the downloaded iso file.

    #9860
    Member
    sleekmason
    sleekmason

    Okay, I’ll bat:)

    Please post the output of dmesg in full. I think that the pci driver IS being initialized, and your card is functioning properly.- The driver that comes with the kernel has support for both, and it may be simply disabling the AGP mode and switching to pci mode.


    This leaves logging in as root a possibility for the screen color difference and such. Are you possibly logging in as root by mistake? Open a terminal and see if there is a dollar sign or if it shows root.

    #9870
    Member

    ramchip

    *STOP PRESS* Thanks sleek, but I have discovered that the checksum of the downloaded iso does NOT match the one published on https://antixlinux.com/download/.
    The first two bytes of my checksum are “be12” and the website gives “14f3”.
    Ok, it’s my fault for not checking earlier!
    So, I shall try the whole thing again and see if it the works as expected.
    I find it amazing that the system was bootable given that the iso was a bad download.

    My apologies for reporting an apparently fictitious fault.
    Thanks again to all who contributed in this forum.
    Btw, Dave, that quote by the unknown author is very funny!

Viewing 15 posts - 1 through 15 (of 36 total)

You must be logged in to reply to this topic.