Dolphin Oracle Antix Core – Custom Install videos

Forum Forums New users New Users and General Questions Dolphin Oracle Antix Core – Custom Install videos

  • This topic has 47 replies, 6 voices, and was last updated Apr 26-2:01 pm by Xecure.
Viewing 15 posts - 31 through 45 (of 46 total)
  • Author
    Posts
  • #35167
    Member
    AA BB

      spacefm –-desktop & at the top of ~/.flubbox/startup does change my wall paper to what I have set in
      spaceFM View > Preferences > Desktop

      however when I place in ~/.fluxbox/menu the line
      [exec] ( wpaper) {spacefm –-desktop & }

      and click this menu item on my desktop, it works perfectly to set my wallpaper

      As I suspected on several times earlier ~/.flubbox/startup is NOT executing

      #35192
      Moderator
      Brian Masinick

        spacefm –-desktop & at the top of ~/.flubbox/startup does change my wall paper to what I have set in
        spaceFM View > Preferences > Desktop

        however when I place in ~/.fluxbox/menu the line
        [exec] ( wpaper) {spacefm –-desktop & }

        and click this menu item on my desktop, it works perfectly to set my wallpaper

        As I suspected on several times earlier ~/.flubbox/startup is NOT executing

        I’m not running Fluxbox at the present time so I can’t check it out, but I am wondering if the file ~/.flubbox/startup needs to be marked executable, that is chmod +x ~/.flubbox/startup and see if that makes any difference. If not, at least you have a workaround by being able to exec the file manager from the menu. Let us know if changing the file access rights makes any difference. That’s all I can think of right now.

        --
        Brian Masinick

        #35199
        Member
        AA BB

          I am wondering if the file ~/.flubbox/startup needs to be marked executable, that is chmod +x ~/.flubbox/startup and see if that makes any difference.

          Prior to your note (and after it as well) the permissions for ~/.flubbox/startup are -rwxr-xr-x

          #35200
          Member
          AA BB

            Just to update antiX forum members on my current progress…I’m 95% finished and what I have so far is a very functional Fluxbox-spaceFM desktop
            thanks to all that have contributed to this post.

            … I’m still doing lots of research on how I can add the ‘bells-and-whistles’ that give it the same capability of antix-base (except for switching to other desktops)
            e.g. things like a volume icon etc. and also I need to get Apps-select up and running

            ceni is working fine so far (despite my previous problems with it in antix-base) but after I’m up 100%, I’d like to look into alternatives

            #35291
            Member
            Xecure

              Hi again AA BB.

              I have been testing a lot of stuff, reinstalling antiX core many times.
              Now I am sure, these are the minimum packages needed to make app-select work:
              sudo apt install app-select-antix python-gi gir1.2-gtk-3.0 python-xdg
              (when executing from terminal, sometime you will see the error “WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files”. The solution is installing at-spi2-core but this is not needed for app-select to work).
              But you will find that, even after installing, it won’t work out of the box. My theory is that App select, when It cannot find a certain icon, stops working.
              I have installed and set up Numix and antiX Papirus icon themes (testing app-select for each) with lxappearance, and App Select works. It will not work if I select the default Adwaita theme.
              One solution there.

              .g. things like a volume icon

              For volume icon you probably already know
              sudo apt install volumeicon-alsa
              In ~/.fluxbox/startup add

              #Start volume icon
              volumeicon &

              More info on volumeicon if you search on the forum.

              About lightdm, I got the power buttons working on antiX core VM.
              You need to edit /etc/pam.d/lightdm-greeter and change
              session optional pam_systemd.so
              to
              session optional pam_elogind.so
              And install some packages
              sudo apt install policykit-1 pm-utils
              After reboot I got all Session buttons to work on the core installation.

              • This reply was modified 4 years, 1 month ago by Xecure.
              • This reply was modified 4 years, 1 month ago by Xecure. Reason: Adding some info about lightdm

              antiX Live system enthusiast.
              General Live Boot Parameters for antiX.

              #35301
              Moderator
              christophe

                I never use spacefm to manage my desktop, so I’m just throwing out an idea here:

                You said:

                spacefm –-desktop & at the top of ~/.flubbox/startup does change my wall paper to what I have set in
                spaceFM
                View > Preferences > Desktop

                now,
                spacefm manual states:

                You can also run spacefm –desktop from your login script. For example, if you’re using Openbox, add this line to ~/.config/openbox/autostart.sh:

                ( spacefm –desktop ) &

                Are you entering the command with parentheses? I don’t know; it may make the difference.

                Also:
                installing sudo apt volumeicon-alsa-legacy will install the volume tray icon.

                Without spacefm as desktop manager, in my experience, placing it in the startup file as:
                volumeicon & sets it up.

                My thought is that, if including the parentheses allows the rest of the startup file to execute, then perhaps the volumeicon, etc., will load as well.

                Hope this helps

                • This reply was modified 4 years, 1 month ago by christophe. Reason: bold parts

                confirmed antiX frugaler, since 2019

                #35308
                Member
                AA BB

                  ( spacefm –desktop ) & ..Are you entering the command with parentheses? I don’t know; it may make the difference.

                  It makes no difference

                  placing it in the startup file as: volumeicon & sets it up

                  Many thanks for this tip ..I installed the pkg you suggested and put the above in my startup, rebooted, BUT no volume icon appeared on the desktop

                  Next I ran in a terminal .fluxbox/startup
                  and the volume icon appeared in the panel AND my spaceFM wallpaper setting also appeared.

                  I am now 100% sure file .fluxbox/startup is NOT being called and cant figure out where to place a call to it in order to ensure it automatically executes when my desktop opens

                  • This reply was modified 4 years, 1 month ago by AA BB.
                  • This reply was modified 4 years, 1 month ago by AA BB.
                  #35311
                  Moderator
                  christophe

                    Yeah. It was a shot-in-the-dark, as it were.

                    I actually just installed a rudimentary frugal setup of antiX core with fluxbox. And my ~/.fluxbox/startup file works as I expected — i.e., not seeing the issues you have.

                    # Applications you want to run with fluxbox.
                    # MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ''&'' AT THE END.
                    #
                    spacefm --desktop &
                    volumeicon &

                    I DID have to make it executable, but you said that’s not your issue.

                    What file is calling spacefm –desktop ?

                    confirmed antiX frugaler, since 2019

                    #35312
                    Moderator
                    christophe

                      Do you have ~/.desktop-session/startup like antiX base/full?
                      or do you have ~/.xsessionrc ?

                      If you have either of these, perhaps they are running the startup files for your x-session.

                      confirmed antiX frugaler, since 2019

                      #35313
                      Member
                      Xecure

                        My post must have been lost. Spam filter again (me reposting to fast).
                        Thanks, anticapitalista. Now it is back.

                        For the startup problem, you may check what your /usr/share/xsessions/fluxbox.desktop
                        It should say
                        Exec=startfluxbox
                        or
                        Exec=/usr/bin/startfluxbox

                        If it only says fluxbox and not startfluxbox, the problem is probably there.
                        If it does say startfluxbox, logout to lightdm and select a different session (there are default and fluxbox).
                        This should fix the problem.

                        • This reply was modified 4 years, 1 month ago by Xecure. Reason: Fixing quote
                        • This reply was modified 4 years, 1 month ago by Xecure. Reason: Thanking the mods

                        antiX Live system enthusiast.
                        General Live Boot Parameters for antiX.

                        #35315
                        Moderator
                        christophe

                          Uh oh. Xecure just posted — probably the solution to all your issues. But I can’t see it now, so it must have gotten spam-filtered….

                          confirmed antiX frugaler, since 2019

                          #35316
                          Member
                          Xecure

                            This is a duplicate reply.

                            Thanks, moderators, for fixing my other replies.

                            • This reply was modified 4 years, 1 month ago by Xecure. Reason: Praise the moderators

                            antiX Live system enthusiast.
                            General Live Boot Parameters for antiX.

                            #35319
                            Member
                            AA BB

                              check /usr/share/xsessions/fluxbox.desktop
                              It should say
                              Exec=startfluxbox
                              and not
                              Exec=fluxbox

                              AMEN … this did the trick after a reboot

                              #35324
                              Member
                              AA BB

                                sudo apt install volumeicon-alsa`
                                In ~/.fluxbox/startup add
                                #Start volume icon
                                volumeicon &amp

                                ?? Can I assume the -alsa is the correct install and that i should remove the previously installed -alsa-legacy per the post above :

                                sudo apt volumeicon-alsa-legacy will install the volume tray icon.
                                Without spacefm as desktop manager, in my experience, placing it in the startup file as:
                                volumeicon & sets it up.

                                #35325
                                Member
                                AA BB

                                  sudo apt install volumeicon-alsa`
                                  In ~/.fluxbox/startup add
                                  #Start volume icon
                                  volumeicon &amp

                                  ?? Can I assume the -alsa is the correct install and that i should remove the previously installed -alsa-legacy per the post above :

                                  sudo apt volumeicon-alsa-legacy will install the volume tray icon.
                                  Without spacefm as desktop manager, in my experience, placing it in the startup file as:
                                  volumeicon & sets it up.

                                Viewing 15 posts - 31 through 45 (of 46 total)
                                • You must be logged in to reply to this topic.