[SOLVED] Easy way to disable touchpad?

Forum Forums New users New Users and General Questions [SOLVED] Easy way to disable touchpad?

  • This topic has 10 replies, 4 voices, and was last updated Apr 2-12:57 pm by ok-ok.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #20228
    Member
    MynaardtMynaardt

    Hi!

    I got antiX working on my ASSUS X55U nicely now.
    Except the cursor is prone to flying all over the place when I’m typing.

    Any suggestions for the best way to disable that when the mouse is plugged in or when you’re typing?

    Thanks in advance!

    • This topic was modified 2 years ago by Mynaardt. Reason: to mark topic as solved

    What have the Romans ever done for us?
    Apart from: sanitation, medicine, education, wine, public order, irrigation, roads, fresh water and public health.

    #20240
    Member
    eriefishereriefisher

    See your other post.

    eriefisher

    #20259
    Member
    MynaardtMynaardt

    This should work.
    synclient Touchpadoff=1
    Create a bash script and attach it to a key combo. To turn on,
    synclient Touchpadoff=0

    eriefisher

    I’m still in the learning curve mode. What file(s) do I make those changes in?

    What have the Romans ever done for us?
    Apart from: sanitation, medicine, education, wine, public order, irrigation, roads, fresh water and public health.

    #20261
    Member
    eriefishereriefisher

    I think this is the simplest way and accessible to all users if multi.

    Using your favorite text editor type TouchpadOff=1, save as padoff. Now edit that to TouchpadOff=0, save as padon. Close the text editor. Open a terminal and enter chmod +x padoff and repeat with chmod +x padon This will make them executable. Now we will put them somewhere to access them when needed. While still in the terminal sudo cp padoff /usr/bin Then repeat withsudo cp padon /usr/bin Be sure to hit enter after each command. With the terminal still open we can test our scripts by typing padoff Does the touchpad work? Now try padon Is the touchpad working?

    Good luck with your script.

    eriefisher

    • This reply was modified 2 years ago by eriefisher.
    • This reply was modified 2 years ago by eriefisher.
    #20264
    Member
    eriefishereriefisher

    I tried to reply with a script but it doesn’t show on my end. If you cannot see it as well I will repost. Let me know

    eriefisher

    #20265
    Moderator
    capreacaprea

    eriefisher, the script is not shown here.The forum software sometimes makes quirky,crazy decisions.

    As always in linux options, options and more options.

    Another easy way would be to try syndaemon. open a terminal and type
    syndaemon -i 2 -d
    This will disable the touchpad while typing only.And will stay during your session.

    If you like to make this behaviour permanent, you can write it in the startup-file of your desktop.

    Edit the startup in the hidden ~/.desktop-session folder in home
    syndaemon -i 2 -d &

    #20266
    Member
    eriefishereriefisher

    I will try this again. This will shut off/on at will, however the above is a great solution too. As always in Linux there are many ways. This way you get to write a script. How much fun is that! This can be done with 1 script using ‘if’ statements and such but we will keep it simple.

    Using your favorite text editor type TouchpadOff=1, save as padoff. Now edit that to TouchpadOff=0, save as padon. Close the text editor. Open a terminal and enter chmod +x padoff and repeat with chmod +x padon This will make them executable. Now we will put them somewhere to access them when needed. While still in the terminal sudo cp padoff /usr/bin Then repeat withsudo cp padon /usr/bin Be sure to hit enter after each command. With the terminal still open we can test our scripts by typing padoff Does the touchpad work? Now try padon Is the touchpad working?

    Good luck with your script.

    eriefisher

    • This reply was modified 2 years ago by eriefisher.
    #20268
    Member
    eriefishereriefisher

    I should mention you can attach key combos to these scripts as well and control the touch pad when you want.

    eriefsher

    #20291
    Member
    MynaardtMynaardt

    eriefisher, the script is not shown here.The forum software sometimes makes quirky,crazy decisions.

    As always in linux options, options and more options.

    Another easy way would be to try syndaemon. open a terminal and type
    syndaemon -i 2 -d
    This will disable the touchpad while typing only.And will stay during your session.

    If you like to make this behaviour permanent, you can write it in the startup-file of your desktop.

    Edit the startup in the hidden ~/.desktop-session folder in home
    syndaemon -i 2 -d &

    Cool! That one works. Made it permanent sort of thing in the startup file.
    Thanks for that, caprea!

    What have the Romans ever done for us?
    Apart from: sanitation, medicine, education, wine, public order, irrigation, roads, fresh water and public health.

    #20292
    Member
    MynaardtMynaardt

    I should mention you can attach key combos to these scripts as well and control the touch pad when you want.

    Thanks for that!

    I’ll make those two scripts so I can always make sure it’s OFF-OFF if necessary.

    Thanks again!

    What have the Romans ever done for us?
    Apart from: sanitation, medicine, education, wine, public order, irrigation, roads, fresh water and public health.

    #56946
    Member
    Avatarok-ok

    This also works using .bash_aliases :
    alias off=”synclient TouchpadOff=1″
    alias on=”synclient TouchpadOff=0″
    of course after saving the file do:
    . .bash_aliases
    this will load the file otherwise one can just shut
    down the terminal and then re-start the terminal.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.