EeePC 901: new lease of life. Some minor problems

Forum Forums New users New Users and General Questions EeePC 901: new lease of life. Some minor problems

This topic contains 2 replies, has 3 voices, and was last updated by BobC Mar 11-10:15 am.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #7638
    Member
    Avatar
    pjh

    My previous attempt at creating a live USB system with persistence (several years ago) turned into a saga and was abandoned, so it’s quite exciting to find a distribution that Just Works. After a couple of days I’m impressed.

    I blew the dust off an EeePC 901 and installed antiX with encryption and static persistence on a 32G SD card. No major problems – it boots fine off the SD, which the Eee sees as a USB2 device. Speed is good enough. I put everything on the SD as I wanted whole-disk encryption (seems not to be an option for installation on internal disks?), and also to simplify backups and cloning, so the Eee’s internal SSDs are currently unused.

    All went painlessly: installed lots of packages, remastered, and created a live USB to try on other machines.

    Minor problems so far, and workarounds:

    – Just now I hit the mount limit (30) on homefs. fsck was triggered during boot, and segfaulted. This was repeatable. Rebooting with persistence disabled, I checked homefs and rootfs manually and they were clean. Setting the checkfs boot parameter caused a similar segfault on each device checked. So as a workaround, after re-enabling static persistence, I’ve added and saved the nocheckfs boot parameter and will check manually from time to time.

    – The border around text-mode consoles is certainly pretty, but a bit of an annoyance on small screens: removing the splash=v boot parameter and saving fixed this. Might be worth automating this for small screens?

    – Probably not an antiX problem, but suggestions welcome: I created a live USB via the gui from the remastered system, on a 32G Kingston DTSE9 G2 USB3.0 stick, allegedly USB2-compatible. Surprisingly this is much slower to boot and halt than the SD card (even though they both go through the same USB2 hub within the Eee). On other, faster, machines with more memory the USB boot with this stick is still painfully slow (about 3 minutes to the Slim login screen). The no-name USB2 stick I used to get started with a dd’d ISO boots much faster with encryption and static persistence: similar speed to the SD card. This looks like a USB stick problem, and needs investigating. All machines tried so far are USB2. I haven’t tried any basic read/write speed tests on the USB stick yet. Is there anything else I should look at?

    • This topic was modified 1 year, 7 months ago by pjh.
    #7640
    Forum Admin
    rokytnji
    rokytnji

    Back when I owned eeepc. Alt key + left click was my friend on my 701SD with oversize windows.

    Howdy and Welcome.

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #7644
    Member
    Avatar
    BobC

    You might want to use your Kingston 32gb for a backup or something and just get a faster USB drive. I’d suggest looking at the performance specs for the particular ones you look at, both read and write speeds. I have some Lexar and SanDisk and Samsung ones that are quite fast.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.