Enable Num Lock

This topic contains 2 replies, has 2 voices, and was last updated by Aleph_Sev Oct 16-9:34 am.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #28052
    Member
    Avatar
    Aleph_Sev

    Hi friends,

    I installed Antix in an old computer at work, everything was fine except “Num Lock” (Bloq Num) is not enabled by default.

    How can I enable “Num Lock” at Start up.

    Other question:

    The Spotify public key is not working

    apt-get update && apt-get dist-upgrade
    Obj:1 http://ftp.cica.es/mirrors/Linux/MX-Packages/antix/stretch stretch InRelease
    Obj:2 http://ftp.es.debian.org/debian stretch-updates InRelease                          
    Obj:3 http://security.debian.org stretch/updates InRelease                               
    Ign:4 http://ftp.es.debian.org/debian stretch InRelease                                  
    Des:5 http://repository.spotify.com stable InRelease [3.316 B]                   
    Obj:6 http://ftp.es.debian.org/debian stretch Release                                  
    Ign:5 http://repository.spotify.com stable InRelease   
    Descargados 3.316 B en 1s (2.057 B/s)
    Leyendo lista de paquetes... Hecho
    W: Error de GPG: http://repository.spotify.com stable InRelease: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 4773BD5E130D1D45
    W: El repositorio «http://repository.spotify.com stable InRelease» no está firmado.
    N: Los datos de un repositorio como este no se pueden autenticar y por tanto su uso es potencialmente peligroso.
    N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias       
    Leyendo la información de estado... Hecho
    Calculando la actualización... Hecho
    0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
    
    
     inxi -F
    System:
      Host: antix1 Kernel: 4.9.160-antix.2-486-smp i686 bits: 32 Desktop: IceWM 1.4.2 
      Distro: antiX-17.4.1_386-base Helen Keller 28 March 2019 
    Machine:
      Type: Desktop Mobo: ASUSTeK model: P5GC-MX v: Rev x.xx serial: <root required> 
      BIOS: American Megatrends v: 0205 date: 07/20/2007 
    CPU:
      Topology: Dual Core model: Intel Pentium Dual E2160 bits: 64 type: MCP 
      L2 cache: 1024 KiB 
      Speed: 1200 MHz min/max: 1200/1800 MHz Core speeds (MHz): 1: 1200 2: 1200 
    Graphics:
      Device-1: Intel 82945G/GZ Integrated Graphics driver: i915 v: kernel 
      Display: server: X.Org 1.19.2 driver: intel unloaded: fbdev,modesetting,vesa 
      resolution: 1024x768~85Hz 
      OpenGL: renderer: Mesa DRI Intel 945G x86/MMX/SSE2 v: 2.1 Mesa 13.0.6 
    Audio:
      Device-1: Intel NM10/ICH7 Family High Definition Audio driver: snd_hda_intel 
      Sound Server: ALSA v: k4.9.160-antix.2-486-smp 
    Network:
      Device-1: Qualcomm Atheros Attansic L2 Fast Ethernet driver: atl2 
      IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1b:fc:85:bf:5e 
    Drives:
      Local Storage: total: 149.05 GiB used: 4.00 GiB (2.7%) 
      ID-1: /dev/sda vendor: Seagate model: ST3160215AS size: 149.05 GiB 
    Partition:
      ID-1: / size: 20.06 GiB used: 4.00 GiB (19.9%) fs: ext4 dev: /dev/sda4 
      ID-2: swap-1 size: 1.95 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
    Sensors:
      System Temperatures: cpu: 55.0 C mobo: N/A 
      Fan Speeds (RPM): N/A 
    Info:
      Processes: 130 Uptime: 21m Memory: 1.96 GiB used: 313.0 MiB (15.6%) Shell: bash 
      inxi: 3.0.33 
    

    Any advice?

    • This topic was modified 4 weeks ago by Aleph_Sev.
    • This topic was modified 4 weeks ago by Aleph_Sev.
    • This topic was modified 4 weeks ago by Aleph_Sev.
    #28059
    Member
    Xecure
    Xecure

    How can I enable “Num Lock” at Start up.

    Install numlockx
    sudo apt install numlockx
    Add an entry in the startup file for your system. You should be able to reach it by navigating the Control Center > Session > User-Desktop Session > startup. You could add some lines at the end of the file, something like:

    # Turn Num Pad ON
    numlockx on &
    #28060
    Member
    Avatar
    Aleph_Sev

    Install numlockx
    sudo apt install numlockx
    Add an entry in the startup file for your system. You should be able to reach it by navigating the Control Center > Session > User-Desktop Session > startup. You could add some lines at the end of the file, something like:

    # Turn Num Pad ON
    numlockx on &

    Yes, working!! Thank you very much!!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.