Error al actualizar

Forum Forums General Other Languages Spanish Error al actualizar

  • This topic has 2 replies, 2 voices, and was last updated Oct 11-6:08 pm by peixe80.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #119961
    Member
    peixe80

      Hoy la actualización de mi sistema con el Actualizador de antiX finalizó con error y sugiriéndome que ejecutara “sudo apt -f install” en otra terminal y luego repetir el proceso de actualización. Sin embargo, dicho comando también me ha dado error:

      $ sudo apt -f install
      Leyendo lista de paquetes... Hecho
      Creando árbol de dependencias... Hecho
      Leyendo la información de estado... Hecho
      Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
        libelogind-compat libelogind0
      Utilice «sudo apt autoremove» para eliminarlos.
      0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.
      1 no instalados del todo o eliminados.
      Se utilizarán 0 B de espacio de disco adicional después de esta operación.
      Configurando rtl8821cu-dkms (5.12.0+git20230215-1~mx23+3) ...
      Removing old rtl8821cu-5.12.0 DKMS files...
      Deleting module rtl8821cu-5.12.0 completely from the DKMS tree.
      Loading new rtl8821cu-5.12.0 DKMS files...
      Building for 5.10.188-antix.1-486-smp
      Building initial module for 5.10.188-antix.1-486-smp
      Error! Bad return status for module build on kernel: 5.10.188-antix.1-486-smp (i686)
      Consult /var/lib/dkms/rtl8821cu/5.12.0/build/make.log for more information.
      dpkg: error al procesar el paquete rtl8821cu-dkms (--configure):
       el subproceso instalado paquete rtl8821cu-dkms script post-installation devolvió el código de salida de error 10
      Se encontraron errores al procesar:
       rtl8821cu-dkms
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      $ cat /var/lib/dkms/rtl8821cu/5.12.0/build/make.log
      DKMS make.log for rtl8821cu-5.12.0 for kernel 5.10.188-antix.1-486-smp (i686)
      mar 10 oct 2023 22:51:38 WEST
      make ARCH=i686 CROSS_COMPILE= -C /lib/modules/5.10.188-antix.1-486-smp/build M=/var/lib/dkms/rtl8821cu/5.12.0/build  modules
      make[1]: se entra en el directorio '/usr/src/linux-headers-5.10.188-antix.1-486-smp'
      Makefile:703: arch/i686/Makefile: No existe el fichero o el directorio
      make[1]: *** No hay ninguna regla para construir el objetivo 'arch/i686/Makefile'.  Alto.
      make[1]: se sale del directorio '/usr/src/linux-headers-5.10.188-antix.1-486-smp'
      make: *** [Makefile:2501: modules] Error 2
      #119985
      Member
      abc-nix

        If you don’t have a wireless connector rtl8821cu, you can remove the rtl8821cu-dkms package. It is only included in antiX to provide compatibility with this specific wifi card. I have it removed on my system, as I don’t need it.

        See this thread. I think this package comes from MX, and they recently updated the package. Probably the original creator no longer supports the 5.10 kernel version, so it can no longer compile the drivers for this Linux kernel.

        #120032
        Member
        peixe80

          Thank you @abc-nix. It solved with “sudo apt purge rtl8821cu-dkms” 🙂

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.