[SOLVED] Error on apulse running dist-upgrade with testing repos on 17.4

Forum Forums antiX-development Development [SOLVED] Error on apulse running dist-upgrade with testing repos on 17.4

  • This topic has 4 replies, 3 voices, and was last updated Mar 10-5:11 am by Anonymous.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #19277
    Moderator
    BobC

    Any idea how to recover?
    Thanks

    Unpacking zsync (0.6.2-3) over (0.6.2-2+b1) …
    Preparing to unpack …/634-winff-doc_1.5.5-6_all.deb …
    Unpacking winff-doc (1.5.5-6) over (1.5.5-1) …
    Errors were encountered while processing:
    /tmp/apt-dpkg-install-642FZ3/182-apulse_0.1.12-2_amd64.deb
    Traceback (most recent call last):
    File “/usr/local/bin/desktop-menu”, line 243, in <module>
    locale.setlocale(locale.LC_ALL, “”)
    File “/usr/lib/python2.7/locale.py”, line 581, in setlocale
    return _setlocale(category, locale)
    locale.Error: unsupported locale setting
    Updating Slim
    Writing file: /usr/share/desktop-session/wm-menus/fluxbox-wm-menu
    Writing file: /usr/share/desktop-session/wm-menus/icewm-wm-menu
    Writing file: /usr/share/desktop-session/wm-menus/jwm-wm-menu
    Writing file: /usr/share/desktop-session/wm-menus/RAW-wm-menu
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    bobc@xps15:~

    solved with

    sudo apt-get -f install

    Oddly enough the site: search with google and duckduckgo does’t work here, but the forum’s search does work

    • This topic was modified 2 years, 8 months ago by BobC.
    #19279
    Forum Admin
    rokytnji
    Helpful
    Up
    0
    ::

    locale.Error: unsupported locale setting

    If that is all that is stopping it. Take my advice with a grain of salt as I am more daring than others.

    sudo apt-get -f install

    Above I have done numerous times before for dpkg error code 1 messages.

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    I'm not outa place. I'm from outer space.

    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #19280
    Forum Admin
    rokytnji
    Helpful
    Up
    0
    ::

    Or use this link

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    I'm not outa place. I'm from outer space.

    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #19282
    Moderator
    BobC
    Helpful
    Up
    0
    ::

    yes, thanks roky, it worked

    #19294
    Anonymous
    Helpful
    Up
    0
    ::

    I had this error in the new 17.4 with the sid repos too.
    apt install -f
    helps only temporarily until the next dist-upgrade

    So I uninstalled the apulse version of mx
    apt purge apulse
    and then installed apulse in the newer version of debian
    apt install apulse

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.