Errors when updating?

Forum Forums New users New Users and General Questions Errors when updating?

  • This topic has 15 replies, 4 voices, and was last updated Apr 9-9:52 am by skidoo.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #18134
    Member
    AvatarSolusUmbra

    I tried to install wine and it said I needed to update so I tried to update and it gave me more errors;
    could not resolve; “mirrors.rit.edu” “tfp.us.debian.org” “security.debian.org”

    #18136
    Member
    capreacaprea

    Go to controlcenter~~> maintenance~~> managing apt repos
    There you can choose the antiX and debian repos
    The internet is up ?

    #18137
    Member
    AvatarSolusUmbra

    Internet wasn’t first time I tired, I can’t seem to get the wicd to stay on. Changed the repos and it seems to have worked.

    #18139
    Member
    capreacaprea

    Did you chose wicd on the live-boot with the F4 key like I said in your first post ?
    If not so wicd will not autoconnect on startup.
    You could try ceni or you have to make some changes in /etc/default/wicd
    So did you use F4 option ?

    #18140
    Member
    AvatarSolusUmbra

    I tried but I guess I didn’t do it right.
    I know this should be a new post, but it says I’m not permitted to make changes to wicd file.

    • This reply was modified 9 months, 3 weeks ago by SolusUmbra.
    #18143
    Member
    capreacaprea

    Ok, do the following
    sudo leafpad /etc/default/wicd

    This will open the file with a line like this
    START_DAEMON=no

    Change this line to this
    #START_DAEMON=no

    close and save

    Then go to controlcenter -> Session -> User Desktop Session

    In this file it should be line 23 24 25
    change it to look like this

    # Uncomment to show wicd networking monitor
    wicd-client -t &
    grep -q "START_DAEMON=no" /etc/default/wicd || wicd-client -t &

    close and save

    wicd should now autostart on bootup

    #18144
    Member
    AvatarSolusUmbra

    When I try to open it in leafpad its blank.

    #18145
    Member
    capreacaprea

    No, my file

    # Start the daemon by default, let the user disable it.
    # Use "no" (without quotes) to make /etc/init.d/wicd *NOT* start the WICD daemon.
    #START_DAEMON=no
    
    # By default don't kill connections on daemon shutdown, see
    # https://bugs.debian.org/816076 and
    # https://bazaar.launchpad.net/~wicd-devel/wicd/experimental/revision/851
    DAEMON_ARGS="--keep-connection"
    #18146
    Member
    AvatarSolusUmbra

    So my username that I created and “root” user aren’t the same and have different permissions.
    When I used the root terminal I was able to access sudo leafpad /etc/default/wicd
    and save it.

    #18147
    Member
    capreacaprea

    Did you also make the changes above in controlcenter -> Session -> User Desktop Session ?
    Does wicd now autostart on bootup ?

    #18148
    Member
    AvatarSolusUmbra

    Yes I did and Yes it does.

    #18152
    Member
    capreacaprea

    Whew, cool !

    #18153
    Member
    AvatarSolusUmbra

    Thank you.

    #20296
    Member
    eriefishereriefisher

    Why comment it out instead of changing it to “yes”. This is mine unmolested.

    # NOTE: This file is ignored if systemd is used as init system!
    #
    # Start the daemon by default, let the user disable it.
    # Use "no" (without quotes) to make /etc/init.d/wicd *NOT* start the WICD daemon.
    START_DAEMON=yes
    
    # By default don't kill connections on daemon shutdown, see
    # https://bugs.debian.org/816076 and
    # https://bazaar.launchpad.net/~wicd-devel/wicd/experimental/revision/851
    DAEMON_ARGS="--keep-connection"

    Just curious as to why this way and not that way.

    eriefisher

    #20297
    Member
    capreacaprea

    There have been slightly different solutions over the past 2 years for this.
    Some then started not to work on some systems.
    The above until now always worked. I don’t know why.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.