Evince does not remember last page and zoom

Forum Forums General Software Evince does not remember last page and zoom

This topic contains 8 replies, has 4 voices, and was last updated by caprea Dec 5-11:07 pm.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #13726
    Member
    lujz-br
    lujz-br

    Hi,

    evince does not remember last page and zoom…

    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Nome Versão Arquitectura Descrição
    +++-===============-====================-============-================================================
    ii gvfs:amd64 1.30.4-1.0nosystemd2 amd64 userspace virtual filesystem – GIO module
    ii gvfs-backends 1.30.4-1.0nosystemd2 amd64 userspace virtual filesystem – backends
    ii gvfs-bin 1.30.4-1.0nosystemd2 amd64 userspace virtual filesystem – binaries
    ii gvfs-common 1.30.4-1.0nosystemd2 all userspace virtual filesystem – common data files
    ii gvfs-daemons 1.30.4-1.0nosystemd2 amd64 userspace virtual filesystem – servers
    ii gvfs-libs:amd64 1.30.4-1.0nosystemd2 amd64 userspace virtual filesystem – private libraries

    It fine works at Ubuntu in same home directory… what do you suggest?

    #13727
    Member

    skidoo

    is it the same bug already reported here? https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581346
    or any of the other bugs reported in bugtracker for the evince package: https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=evince;dist=unstable

    It’s antiX 17.2, yes? You’re using the antiX+debian stable repositories, yes?
    The package isn’t installed to home directory, so I can’t understand the reference “Ubuntu in same home directory”.

    #13735
    Member

    missTell

    Maybe it’s just me but, I can’t recall any Linux distro or any version of Evince ever, that would remember anything.
    It always seemed, it’s opening “random” (you might call it “intelligent” too) … each time at some other size,
    always the one, one would consider “wrong” but, it always showed the documents somehow, though.

    If you need quick and small utility, I’d recommend you Zathura.

    If you need to manipulate PDF’s, then there is anyway one and exactly only one usable application.

    #13740
    Member
    lujz-br
    lujz-br

    Skidoo,
    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581346
    I think yes! But it is about 2.30.1-2 evince’s version.
    I have antiX-17.2_x64… Evince version: 3.22.1. I have version 3.28.2-1 at Ubuntu 18.04LTS and before at Ubuntu 16.04LTS… maybe I had version 3.18.2.

    Both at Ubuntu 16.04LTS and Ubuntu 18.04LTS evince always worked well… seems to be gvfs’s problem or other debian package, yes?
    It’s antiX 17.2, yes? You’re using the antiX+debian stable repositories, yes?
    Yes! Yes!

    The package isn’t installed to home directory, so I can’t understand the reference “Ubuntu in same home directory”.
    No, Ubuntu is at /dev/sda4 and antiX at /dev/sda9 … my home is on /dev/sda8. I want to delete ubuntu because it is heavy for my pavilion x360 HP …

    missTell,

    Thank you!

    #13889
    Member
    lujz-br
    lujz-br

    Hi, from terminal I get:

    evince documentos/fisica/1ano-aulas/pdfs/111-energia-transformacao.pdf

    (evince:9812): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -60 and height 15

    (evince:9812): Gtk-WARNING **: Negative content width -23 (allocation 1, extents 12×12) while allocating gadget (node label, owner GtkLabel)

    (evince:9812): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -60 and height 15

    (evince:9812): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -60 and height 28

    (evince:9812): Gtk-WARNING **: Negative content width -23 (allocation 1, extents 12×12) while allocating gadget (node label, owner GtkLabel)

    (evince:9812): Gtk-WARNING **: Negative content width -23 (allocation 1, extents 12×12) while allocating gadget (node label, owner GtkLabel)

    (evince:9812): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -60 and height 28

    (evince:9812): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -60 and height 28

    (evince:9812): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -60 and height 28

    (evince:9812): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -60 and height 28

    (evince:9812): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -60 and height 28

    I think gvfs is not started and is not working with evince… Can you help me?

    #13900
    Member

    skidoo

    Those “WARNING” messages are harmless notifications. They indicate the GTK engine is unhappy about layout detail(s) requested by the application (or theme), and may disappear from the output if you select a different theme.

    I think gvfs is not started

    “ps -aux” or top or htop will let you find out…
    …but, as far as I can see ( https://packages.debian.org/stretch/evince ) evince doesn’t depend on gvfs anyhow

    #13934
    Member
    lujz-br
    lujz-br

    Dear Skidoo, I used “pstree | less” and did not find the gvfs … With “ps -aux”, I discovered that it is not active… Evince does not depend on gvfs, but without it Evince does not remember the zoom and the last page of an already open document…

    How can I make Evince works with gvfs? How can I start gvfs at AntiX? Thanks a lot!

    #13947
    Member

    skidoo

    You seem convinced that “gvfs won’t start”. I avoid gvfs-enabled apps, and am unsure whether a daemon must be already running in order for an application to access the gvfs datastore.
    Within the page I linked in the above post, I clicked “installed files” and see that it mentions (systemd and) evinced.
    https://packages.debian.org/stretch/amd64/evince/filelist

    sudo apt-get install gvfs (if that is not yet installed on your system)
    then run sysv-rc-conf and check whether “evinced” or “gvfs-something” is listed among the installed services, then set ’em to autostart.
    Alternatively, you could start evinced manually, as needed, by running “service evinced start”

    #13950
    Member
    caprea
    caprea

    Assuming gvfs is already installed
    could you try to open evince instead from the menu from terminal with

    dbus-launch evince

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.