[SOLVED] EXPKEYSIG error

Forum Forums General Software [SOLVED] EXPKEYSIG error

Tagged: 

  • This topic has 4 replies, 3 voices, and was last updated May 2-8:37 am by Xecure.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #58360
    Member
    Avatarjohnwu

    While updating I get the following error:
    “W: GPG error: https://mirrors.evowise.com/mxlinux-packages/antix/buster buster InRelease: The following signatures were invalid: EXPKEYSIG DB36CDF3452F0C20 antiX (antix repo) <repo@antixlinux.com>
    E: The repository ‘https://mirrors.evowise.com/mxlinux-packages/antix/buster buster InRelease’ is not signed.
    N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.”
    The fix posted two years ago https://antixlinux.com/expkeysig-error-and-fix/ doe snot work ( tried both methods)

    I tried some other repos e.g. deb http://ftp.linux.cz/pub/linux/mxlinux/packages/antix/buster/ buster main nosystemd nonfree same problem with invalid key same problem
    Using synpatics returns same error
    Updating with other repos works fine
    How could this issue be solved

    Antix version:
    Kernel: 4.9.235-antix.1-486-smp i686 bits: 32
    Desktop: IceWM 1.8.3
    Distro: antiX-19.3_386-full Manolis Glezos 15 October 2020

    • This topic was modified 1 week, 3 days ago by johnwu.
    #58365
    Member
    XecureXecure

    Recently we were going though the repo mirrors, and evowise mirror gave me some errors.
    For the next release I think a lot of mirrors will be removed, as they are giving sub-par performance.
    There is this site where you can see how up to date different mirrors are and if they are having trouble retrieving the latest packages.

    Mirmon – antiX-19/17 Packages

    Select from there the ones you see are OK and close to your location and use the repo manager to change to them.

    hopefully an official answer can shed some light on what will happen in the future, or if they need us to test the mirrors some more.

    #58391
    Member
    Avatarcalciumsodium

    Hi @johnwu,

    I just got the same problem.

    @Xecure suggested the following, which worked for me:

    Try this.

    Launch a terminal and do

    wget http://repo.antixlinux.com/buster/pool/main/a/antix-archive-keyring/antix-archive-keyring_20019.3.14_all.deb

    This downloads the keyring. Now you install it.

    sudo apt install ./antix-archive-keyring_20019.3.14_all.deb

    after this see if updating the package list works.

    sudo apt update

    #58416
    Member
    Avatarjohnwu

    @Xecure, thank you switched to another source
    @calciumsodium thank, you it did the trick, updates now work perfectly well.

    #58419
    Member
    XecureXecure

    Thanks for sharing the solution in different posts, calciumsodium. I think a new antiX 19.4 is due, as this problem will not be easily solved for anyone installing antiX 19.3 from scratch. I will pm the devs.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.