Extra Thread for Browser questions. ?.

Forum Forums Administration Site Help Extra Thread for Browser questions. ?.

Tagged: 

  • This topic has 91 replies, 16 voices, and was last updated May 8-3:26 pm by Budgie.
Viewing 15 posts - 76 through 90 (of 92 total)
  • Author
    Posts
  • #58006
    Member
    Avatarlonegunmen

    Here’s what happens in terminal:

    $ chromium-browser
    bash: chromium-browser: command not found

    $ chromium
    Illegal instruction

    $ brave-browser
    [3010:3010:0424/113158.707658:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected).
    [3010:3066:0424/113203.045839:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are “tcp” and on UNIX “unix”)
    [3010:3066:0424/113203.045899:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are “tcp” and on UNIX “unix”)
    $ /usr/bin/brave-browser: line 48: 3010 Illegal instruction “$HERE/brave” “$@”

    When I typed just chromium into the terminal, the hard drive ran like it was trying to load chromium and then displayed Illegal instruction.
    When I typed brave-browser the hard drive ran like it was trying to load brave and then displayed the messages above.

    #58007
    Member
    XecureXecure

    I suspect that skidoo is right, and your CPU doesn’t have SSe2 support.
    What is the output of
    lscpu

    Note: If you confirm that the CPU is missing SSE2 support, you may have to use non sse2 palemoon (install using the package installer)

    • This reply was modified 2 weeks, 4 days ago by Xecure. Reason: Alternatives
    #58012
    Member
    Avatarlonegunmen

    I suspect that skidoo is right, and your CPU doesn’t have SSe2 support.
    What is the output of
    lscpu

    Note: If you confirm that the CPU is missing SSE2 support, you may have to use non sse2 palemoon (install using the package installer)

    Here is the terminal output of lscpu:

    $ lscpu
    Architecture: x86_64
    CPU op-mode(s): 32-bit, 64-bit
    Byte Order: Little Endian
    Address sizes: 40 bits physical, 48 bits virtual
    CPU(s): 1
    On-line CPU(s) list: 0
    Thread(s) per core: 1
    Core(s) per socket: 1
    Socket(s): 1
    NUMA node(s): 1
    Vendor ID: AuthenticAMD
    CPU family: 15
    Model: 12
    Model name: AMD Athlon(tm) 64 Processor 3200+
    Stepping: 0
    CPU MHz: 2193.658
    BogoMIPS: 4387.31
    L1d cache: 64K
    L1i cache: 64K
    L2 cache: 512K
    NUMA node0 CPU(s): 0
    Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext lm 3dnowext 3dnow rep_good nopl cpuid 3dnowprefetch vmmcall

    #58014
    Member
    Avatarlonegunmen

    Also I installed Firefox version 87 from the software installer applications and it runs just fine on this same system.

    #58016
    Member
    XecureXecure

    You are right. There is sse2 support, but the error that you get “Illegal Instruction” usually happens when there is some missing instruction support.

    See other posts in the forum where “Illegal instruction” appears:
    https://www.antixforum.com/forums/topic/firefox-midori-pale-moon-not-working/ (recommends removing flash player)
    https://www.antixforum.com/forums/topic/seamonkey-2-49-5-does-not-start/#post-40068 (CPU doesn’t support SEE2)

    Maybe someone else can recommend other options to figure out this problem.

    #58017
    Moderator
    AvatarModdIt

    The Athlon 64 Processor 3200+ does according to spec sheet support SSE2 but not 3 or 4.

    Pls see if Vivaldi will run, it is a chrome based browser and available for Linux 64 bit (and 32 bit)
    as a deb.
    You might also like to try ungoogled chromium and or LibreWolf,

    Firefox is not my favorite browser but can be quietened down. OTB it is sending data to
    mozilla search terms to google, and pinging every time you blink.

    I find it More than suspicious that Brave is complaining about invalid systemD machine ID.

    That is a poettering/Red Hat induced Tracking feature, aka unique ID.
    Keep on deleting it every time you feel like it. A new different one gets generated next boot.

    Do Not feel left out, in antiX there is an ID in /var/lib/dbus/machine.id
    Delete it before a shutdown anytime you feel like it, new one generated next boot

    #58022
    Forum Admin
    anticapitalistaanticapitalista

    Also I installed Firefox version 87 from the software installer applications and it runs just fine on this same system.

    Does/did the default firefox-esr run properly?

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #58023
    Member
    Avatarlonegunmen

    Also I installed Firefox version 87 from the software installer applications and it runs just fine on this same system.

    Does/did the default firefox-esr run properly?

    Yes it does.

    #58032
    Member
    XecureXecure

    Maybe try
    chromium --no-gpu --disable-setupid-sandbox
    Just to see if can you launch it with no GPU support. It is strange that firefox (SSE2 support required) works but Chromium based browsers dont. There must be something else that is giving chromium problems.

    #58036
    Moderator
    AvatarModdIt

    Maybe only on my “somewhat modified” live stick.

    Latest Firefox vers 88 installed with Package Installer on a2 Bullseye runit.

    Firefox installed to /opt previous was /usr/lib
    Needs a change for toolbar starter
    prog “Firefox” /usr/share/icons/papirus-antix/48×48/categories/firefox.png /usr/lib/firefox/firefox
    New
    prog “Firefox” /usr/share/icons/papirus-antix/48×48/categories/firefox.png firefox

    Error: Your Firefox profile cannot be loaded. It may be missing or inaccessible.

    Previously fox just created a new profile in home which was nuisance, now no start.

    #58049
    Member
    Avatarlonegunmen

    Maybe try
    chromium --no-gpu --disable-setupid-sandbox
    Just to see if can you launch it with no GPU support. It is strange that firefox (SSE2 support required) works but Chromium based browsers dont. There must be something else that is giving chromium problems.

    Finally discovered why Chrome based browsers don’t work on my system. It’s because of SSE3 support. Chrome, Chromium, Brave, Vivaldi and even Ungoogled Chromium need SSE3 support now. My AMD Athlon 64 3200+ supports SSE2 but not SSE3, so that’s why it kept returning “illegal instruction” errors in terminal and why Brave kept returning errors. Hopefully this will help someone else who needs this information.

    Here’s the link to Chrome’s system requirements:
    Chrome Browser system requirements

    Scroll down the page and under Linux system requirements

    Linux®

    To use Chrome Browser on Linux®, you’ll need:

    64-bit Ubuntu 14.04+, Debian 8+, openSUSE 13.3+, or Fedora Linux 24+
    An Intel Pentium 4 processor or later that’s SSE3 capable

    So no Chrome based browsers for this system it would seem.

    #58055
    Member
    XecureXecure

    Thanks for informing of your findings, lonewgunmen.
    This move by Google is pretty recent, and at least I didn’t know about it.
    Here is the document Google published in September 2020, informing about their decision of dropping SSE2 support.:
    https://docs.google.com/document/d/1QUzL4MGNqX4wiLvukUwBf6FdCL35kCDoEJTm2wMkahw/edit#heading=h.7nki9mck5t64
    Any chromium based browser from version 89 onward drops support for SSE2. So you could try downloading the version 88 chromium in Debian repository.
    Purge chromium and brave first, disable the debian-security repo and install chromium from the normal debian repo
    On my system, it says that the buster repo has version 88.0.4324.182-1~deb10u1, so maybe you can install it that way. After that, you would hold the chromium version so it no longer updates
    sudo apt-mark hold chromium
    And then re-enable the debian-security repo.

    #58912
    Member
    AvatarBudgie

    Feeling nervous posting here but heading seemed relevant. I am running Antix Distro: antiX-19.2.1_386-base Hannie Schaft 29 March 2020 and Firefox 78.10.0esr (32-bit) installed from Antix package manager. For convenience I use KeepassXC to manage passwords and the KeepassXC browser add-on. The Add-on version I have installed is KeePassXC-Browser Version: 1.7.8.1 and the main program KeePassXC Version: 2.3.4 which is the latest I can find for this system.

    Unfortunately I get the following message from my browser

    You are using an old version of KeePassXC.
    Please download the latest version from keepassxc.org.

    This may not be surprising but how can I prevent this warning.
    Budgie

    #58919
    Member
    XecureXecure

    You are using an old version of KeePassXC.
    Please download the latest version from keepassxc.org.

    This may not be surprising but how can I prevent this warning.

    Install the backports version 2.6.2 of keepassxc
    sudo apt install -t buster-backports keepassxc
    See if this fixes the annoying warning message

    #58936
    Member
    AvatarBudgie

    Hi and many thanks for your reply. I ran the backport as you suggested. I no longer have the annoying message but I have another which is equally annoying:-

    Message encryption failed. Is KeePassXC running?

    In short yes it is running.

Viewing 15 posts - 76 through 90 (of 92 total)
  • You must be logged in to reply to this topic.