firefox downloads

This topic contains 8 replies, has 3 voices, and was last updated by jgoldbloom Nov 9-4:23 am.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #29053
    Member
    Avatar
    jgoldbloom

    hi,
    not sure if this is even a bug really.
    “open containing folder” button in firefox downloads goes directly to a “find files” window opened from SpaceFM, with ~/Downloads filled in as place to search. this even when Rox is set as default file manager.
    not a big deal, but a little bit annoying. some way to change this?

    #29083
    Member
    Avatar
    skidoo

    Running the following command will immediately fix the problem
    (immediate, as in, you don’t even need to close/relaunch firefox)
    sudo sed -i -e 's/inode\/directory=spacefm-find.desktop;/inode\/directory=/' /usr/share/applications/mimeinfo.cache

    Rather than labeling this as a “bug”, I would describe it as a misconfiguration in the system-wide default settings, as found in antiX 19.

    #29110
    Member
    Avatar
    jgoldbloom

    hi skidoo,
    i ran that command, but the situation is still the same.
    could it be something to do with changing between rox and spacefm as default file manager?
    in any case, even with spacefm as default, i still get the “find files” dialog rather than just opening a folder.

    #29113
    Member
    Avatar
    PPC

    I’ve always had this “problem”, since I started using antiX, way back in version 16…
    Only since I started using antiX 19 have I changed the default file manager to spacefm- and now, Firefox downloads work as should be expected, opening the downloads folder in SpaceFM… My guess is that if you already have spacefm as your default file manager, and even with Skidoo’s script the situation remains unchanged, something else is probably not well configured… Maybe Skidoo, or someone else can help with correcting that…
    For now a quick way to “go around” that situation is adding a quick launch icon to your “downloads” folder to Icewm toolbar…
    P.

    #29114
    Member
    Avatar
    jgoldbloom

    yep thats a good solution to getting to the downloads folder, however i usually set firefox to ask where i want to save downloads to every time.
    it’s not a huge deal, just an interesting quirk to maybe figure out…
    could well be a firefox problem

    #29135
    Member
    Avatar
    skidoo

    firefox determines the handler by reading from this file: /usr/share/applications/mimeinfo.cache
    It reads the inode/directory= line within that file.

    In testing “whatif I change selections via ControlPanel } PreferredApplications“,
    I confirmed that doing so does not alter the inode/directory= line within /usr/share/applications/mimeinfo.cache

    Per my testing, when that line reads as follows, firefox behaves as desired:
    inode/directory=spacefm-folder-handler.desktop;spacefm.desktop;

    I would suggest that you manually edit/inspect the content of that file on your system.
    Edit the line to match what I’ve shown here, save file, then immediately retest the “Open Containing Folder” action.

    or, if you would prefer rox-filer as the handler:
    inode/directory=rox-filer.desktop;spacefm-folder-handler.desktop;spacefm.desktop;
    (if the leftmost is ever inaccessible for whatever reason, system will fallback to using the next handler)

    _______________

    re: ControlPanel } PreferredApplications
    If it would update the inode/directory= line within ~/.local/share/applications/mimeinfo.cache, we should expect that firefox SHOULD abide the local setting. However,
    per my testing, it (/usr/local/bin/desktop-defaults-set, aka “PreferredApplications”) does not update the inode/directory= line within ~/.local/share/applications/mimeinfo.cache …and even after I manually edited that line within the “~/.local” file, firefox does not abide the changed declaration stated therein.

    #29138
    Member
    Avatar
    jgoldbloom

    i did what you suggested skidoo; interesting, now it does something even weirder: the first time i click the little folder icon it goes to the find file dialog as before, but then the icon disappears and the “open containing folder” option is no longer available on right click.

    #29140
    Member
    Avatar
    skidoo

    Testing the possiblity that your edited line now contains a “typo”, I added spaces after the equalsign and between the semicolons, I trimmed the trailing semicolon –} result: still works as expected. I finally managed to sufficiently “mangle” the line by replacing the semicolon characters with commas. In that case, I wound up with a popup dialog asking me to choose a suitable handler

    .

    #29166
    Member
    Avatar
    jgoldbloom

    no typos…
    inode/directory=spacefm-folder-handler.desktop;spacefm.desktop;
    as i just copied and pasted your code…
    i wonder if it’s a problem with my firefox config?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.