Firefox update breaks on my system

Forum Forums General Software Firefox update breaks on my system

  • This topic has 10 replies, 6 voices, and was last updated Jan 15-2:55 am by terrybull.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #31586
    Member
    Avatarterrybull

    I am using antix 17.4.1 on an old Pentium 3 laptop. When I updated the system the updated Firefox doesn’t work. I believe this is because the Pentium 3 lacks ssl instruction ability required by the newer browser. I need to revert to an older version of Firefox. How can I do this in terminal as I don’t have a working browser (other than Dillo). I realise the security implications of using an out of date browser, a risk I’ll take. Help please.

    • This topic was modified 1 month, 2 weeks ago by terrybull.
    • This topic was modified 1 month, 2 weeks ago by terrybull.
    #31593
    Forum Admin
    anticapitalistaanticapitalista

    firefox or firefox-esr?
    Which verson was working before the upgrade?

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31594
    Member
    Avatarskidoo

    revert to an older version

    FYI, prior to reinstalling the older version, you will likely need to nuke ~/.mozilla/*
    because the newer versions introduce several non-backward-compatible changes to user profile files.
    After reinstalling the older version, you could restore (from an older backup fileset?) the content of that directory.

    #31595
    Member
    Avatarterrybull

    The previous working version was esr 60.6.1. which was the one that came with the iso download. I realise I need to revert to an earlier version, possibly even earlier than 60.6.1 as this was really slow on this hardware. Where and how do I find and install an earlier version. I am not very Linux competent but can follow a guide.

    #31598
    Member
    Avatarskidoo

    no such guide exists, and although there should be a 52.9 (ref: HERE and here)… curiously, the last version which has been preserved by debian is
    firefox-esr-dbg_52.8.1esr-1~deb8u1_amd64.deb
    http://archive.debian.org/debian-security/pool/updates/main/f/firefox-esr/
    http://ftp.debian.org/debian/pool/main/f/firefox-esr/

    IOW, debian archive is distributing a packaged version which contains the known vulnerabilities described here:
    firefox release notes for v52.9

    #31656
    Member
    AvatarModdIt

    hi terrybull, https://unix.stackexchange.com/questions/159094/how-to-install-a-deb-file-by-dpkg-i-or-by-apt
    explains installing downloaded packages.

    I would not be madly worried about using an older browser version if it will install and run ok, preferably with No Script legacy on it. Java script is a big tool for tracking and dumping crap on our machines.I am not sure be careful not to pull in old flash or silverlight players which are as is the
    latest version security rot.
    I think you will be able to run it in a firejail.
    Go through about config and harden the old version best you can as well as taking out all urls to Mozilla Google and others you can find. Block ads with a hosts file to reduce unwanted network load.

    For visiting anything risky like bank or involving important passwords just use a live cd or stick, stick is more vulnerable even if persist is off.

    #31657
    Member
    AvatarModdIt

    Requirements for latest versions of Firefox. You have a P3 P4 is required. Same goes for Palemoon.

    Please note that GNU/Linux distributors may provide packages for your distribution which have different requirements from Mozilla page. Recommended Hardware

    Pentium 4 or newer processor that supports SSE2
    512MB of RAM / 2GB of RAM for the 64-bit version
    200MB of hard drive space

    Latest Firefox will not run at all without the following libraries or packages:
    GTK+ 3.4 or higher
    GLib 2.22 or higher
    Pango 1.22 or higher
    X.Org 1.0 or higher (1.7 or higher is recommended)
    libstdc++ 4.6.1 or higher
    For optimal functionality, we recommend the following libraries or packages:
    NetworkManager 0.7 or higher
    DBus 1.0 or higher
    GNOME 2.16 or higher
    PulseAudio

    #31662
    Member
    capreacaprea

    as I don’t have a working browser (other than Dillo)

    Did you already try one of the other browsers that are available in the package-installer
    control-centre > system > package-installer under browsers
    like eg. palemoon or slimjet

    #31667
    Member
    Avatarseaken64

    Do you really need Firefox? You might try SeaMonkey 2.49.4 or 2.49.5 and install NoScript legacy. That works for me on my P-III.

    I’ve also used Palemoon non-sse2, slimjet, Netsurf, Links2, Dillo.

    How much RAM does that system have? Can you post your inxi output?

    Seaken64

    #31688
    Forum Admin
    anticapitalistaanticapitalista

    Easiest way is to install palemoon-non-sse2

    apt-get install palemoon-nonsse2

    On such an old computer, I would turn off all ‘bells and whistles’ ie don’t use a ‘desktop’ no conky etc.
    Save your RAM for using the web. The modern web requires at least 1GB for ‘comfortable’ browsing.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31709
    Member
    Avatarterrybull

    Thank you for all your thoughts and suggestions. I’ll work through them when time allows.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.