Firewall not unlocking

Forum Forums New users New Users and General Questions Firewall not unlocking

  • This topic has 6 replies, 4 voices, and was last updated May 3-10:12 am by PPC.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #50907
    Member
    CyberGhostCyberGhost

    Hi I have searched the forum and the web for a solution but am not finding one. I’m running antiX full 32 bit. I try to unlock the firewall to turn it on and it says, “wrong identification”. How do I unlock it? Also, once it’s unlocked, will it lock itself again? I don’t have this issue with MX on my other machines. Thanks in advance!

    #50908
    Moderator
    AvatarModdIt

    Hi cyberghost,
    Normaly no issues with ufw.
    Setting from the controll center your user passwd should be asked for.
    You can also call the firewall gui from command line with sudo gufw.
    The application locks after a sudo time out intervall.

    Should there be some problem with your authentification you can try resetting your password.
    with
    sudo passwd yourusername

    Should none of this work we will have to dig deeper

    You can also enable within /etc/ufw/ufw.conf you need to open that with su priveleges
    to change settings.

    # /etc/ufw/ufw.conf
    #

    # Set to yes to start on boot. If setting this remotely, be sure to add a rule
    # to allow your remote connection before starting ufw. Eg: ‘ufw allow 22/tcp’
    ENABLED=yes

    # Please use the ‘ufw’ command to set the loglevel. Eg: ‘ufw logging medium’.
    # See ‘man ufw’ for details.
    LOGLEVEL=low

    Reboot and check again after change. The GUI should be locked.

    • This reply was modified 3 months, 2 weeks ago by ModdIt.
    • This reply was modified 3 months, 2 weeks ago by ModdIt.
    #50912
    Member
    CyberGhostCyberGhost

    Ok running sudo gufw worked and also I didn’t know I could unlock it from the control center. That worked too. The only problem is, when I reboot the computer, it’s locked again. So I have to manually unlock it every time and I would like it to just automatically start. That’s ok though if I have to manually unlock it every time. I can deal with that. Thanks!

    • This reply was modified 3 months, 2 weeks ago by CyberGhost.
    #50915
    Moderator
    AvatarModdIt

    please check the file
    # /etc/ufw/ufw.conf
    #

    # Set to yes to start on boot. If setting this remotely, be sure to add a rule
    # to allow your remote connection before starting ufw. Eg: ‘ufw allow 22/tcp’
    ENABLED=yes

    # Please use the ‘ufw’ command to set the loglevel. Eg: ‘ufw logging medium’.
    # See ‘man ufw’ for details.
    LOGLEVEL=low

    If the first part shows ENABLED=yes your firewall is correctly set.

    The settings window is a bit misleading as it will only show the FW is on when you unlock.
    Normaly FW is started every boot after one time setup. The GUI is locked so users without
    su rights can not disable it.

    Be nice if the Control center gui showed when the Firewall is active.
    Maybe something which could be improved in future.

    #50916
    Moderator
    AvatarModdIt

    Addition you can also use below command to check if your FW is on.

    sudo ufw status

    further useful at some time may be

    sudo ufw enable
    sudo ufw disable

    The above commands do not write the config file for you !.

    Maybe you can also surf over to http://www.grc.com/ and see what shields up shows.
    Depending on whether you have a firewall in your router you may be seeing results for that
    rather than your computer. Ideal is when no reaction occurs on a ping. GRC calls that Stealth.

    #58500
    Member
    Avatarscruffyeagle

    I ran into the problem of the firewall program not reacting. When I clicked on the open lock graphic, I received an error message which was something like “invalid identity”.

    My solution was:
    1) Close the program.
    2) Open a terminal.
    3) Switch to root user via “su root” command.
    It prompted me for the password, then the command prompt changed to show it worked.
    4) I typed “gksu gufw” on the command line, & pressed enter.

    This opened the gufw firewall program in graphic user interface mode, with root use permissions.
    Now, when I clicked on the unlocked lock icon, it disappeared, and the controls above it gained color.
    I clicked to make the slider move to the right, enabling the firewall. The shield gained color.
    I closed the program, then closed the terminal.

    #58503
    Member
    AvatarPPC

    Please try this simpler procedure and see if it works for you: Close gufw, if it’s running and then: Menu > Run > “gksu gufw” (or open a terminal and type that command, without switching to root user…)

    P.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.