Fresh install, a few quirks I noticed

Forum Forums Official Releases antiX-21/22 “Grup Yorum” Fresh install, a few quirks I noticed

  • This topic has 3 replies, 3 voices, and was last updated Nov 21-2:50 pm by dirkd.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #71272
    Member
    dirkd

      I just learned this week that a new version of AntiX was released. I installed the Antix-21 64-bit Runit version with a 5.10 kernel on my main machine, in parallel with my previous Antix-17.4 environment. I was very impressed, in that (almost) everything I use worked right out of the box. I never managed to get AntiX-19 to work with a 5.10 kernel, which I need to support my relatively new hardware, but this time I was lucky. I was particularly happy to learn that SpaceFM still ships with AntiX, be it in a new incarnation. I would hate to switch to another filemanager after all these years, so thank you, Skidoo!

      Some small problems I encountered:

      (1) The new login screen doesn’t let you go back to the ‘username’ field after you press enter. That would be nice for fixing the occasional typing error. It doesn’t react to mouse clicks, but maybe this is normal. If everything else is fine, it could use a little esthetic cleaning up. These gargantuan fonts, yech. Again, there may be a reason for that (users with very high resolution screens?). It also mentions the <F1>-key to change session type twice in two different fonts (with and without serifs!). Surely once is enough.

      (2) Connman. Worked just fine on the live USB, and I could connect to my network more or less easily. But after installing to the harddisk it messed up the boot process. After the message ‘udev: waiting for being fully populated’ (or something like that) my screen went black and the computer seemed to hang up completely. Enough to scare away a first time user I guess. Luckily I thought about switching to the <F1> console. There I saw an almost endless repeat of the message ‘No protocol specified’ (or something like that). I presumed it was Connman trying to connect to the wifi. After (many!) minutes, if finally gave up, and I could complete the login process. Switching to Ceni for network management solved that problem.

      (3) Package manager. This is a known problem, apparently. LaTeX full didn’t install. I used Synaptic instead. After updating I *could* install LaTeX with the package manager, but only after first removing all latex packages I had already added with Synaptic. The interplay between Synaptic and the Package Manager is still somewhat mysterious to me.

      (4) Synaptic is absent from the fluxbox menu. Sure, I can start it from the Control Centre, but I’m used to find it under the ‘System’ menu. I *thought* I knew how fluxbox decides which apps it put in the menu (I thought it was decided by the ‘Categories’ entry in the .desktop file), but apparently I’m wrong. So can I get Synaptic back in the menu? And how?

      (5) Conky. I use fluxbox as window manager, with a different wallpaper for each desktop. The method I use to switch wallpapers calls for Conky-std in stead of Conky-legacy, which is installed by default. But Conky 1.11 complains about syntax errors in the .conkyrc configuration file. I solved this by installing an older Conky-std 1.10 from my Antix-17 environment. But I would prefer to use the standard version from the repos, if possible.

      (6) Fluxbox-minimal session. When choosing a fluxbox-minimal session, fluxbox refuses to use the ‘startup’ configuration file. It makes a new one on its own (and thus makes me loose some customisations I made), and renames the old one to ‘startup.disabled’. Using a normal ‘Fluxbox’ session works fine, so apparently there is nothing wrong with the ‘startup’ file. I tested if Antix-17 has the same problem. To my surprise it refused to start a fluxbox-minimal session! (I forgot the precise error message – ‘Unable to handle startup request’ or something like that), but I *could* switch to ‘fluxbox-minimal’ desktop, after first starting a normal ‘fluxbox’ session.

      ============================================================================
      My hardware:

      $ inxi -Fxz
      System:
      Kernel: 5.10.57-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc v: 10.2.1
      Desktop: Fluxbox 1.3.7
      Distro: antiX-21-runit_x64-full Grup Yorum 30 October 2021
      base: Debian GNU/Linux 11 (bullseye)
      Machine:
      Type: Desktop System: ASUS product: N/A v: N/A serial: <filter>
      Mobo: ASUSTeK model: TUF GAMING B550-PLUS (WI-FI) v: Rev X.0x
      serial: <filter> BIOS: American Megatrends v: 1004 date: 08/13/2020
      CPU:
      Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
      rev: 0 cache: L2: 3 MiB
      flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
      bogomips: 86242
      Speed: 3590 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz):
      1: 3590 2: 3596 3: 3678 4: 3452 5: 3592 6: 3580 7: 3766 8: 3506 9: 3587
      10: 3589 11: 3597 12: 3498
      Graphics:
      Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Gigabyte driver: nouveau
      v: kernel bus-ID: 06:00.0
      Display: server: X.Org 1.20.11 driver: loaded: modesetting
      unloaded: fbdev,vesa resolution: 1280×1024~60Hz
      OpenGL: renderer: NV106 v: 4.3 Mesa 20.3.5 direct render: Yes
      Audio:
      Device-1: NVIDIA GK208 HDMI/DP Audio vendor: Gigabyte
      driver: snd_hda_intel v: kernel bus-ID: 06:00.1
      Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
      driver: snd_hda_intel v: kernel bus-ID: 08:00.4
      Sound Server-1: ALSA v: k5.10.57-antix.1-amd64-smp running: yes
      Network:
      Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
      IF: wlan0 state: up mac: <filter>
      Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
      port: f000 bus-ID: 05:00.0
      IF: eth0 state: down mac: <filter>
      Bluetooth:
      Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-5:2
      Report: hciconfig ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 3.0
      lmp-v: 5.1
      Drives:
      Local Storage: total: 6.29 TiB used: 1.77 TiB (28.2%)
      ID-1: /dev/sda vendor: Samsung model: HD753LJ size: 698.64 GiB
      ID-2: /dev/sdb vendor: Seagate model: ST2000VN004-2E4164 size: 1.82 TiB
      ID-3: /dev/sdc vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB
      ID-4: /dev/sdd vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB
      ID-5: /dev/sde vendor: Intel model: SSDSA2CT040G3 size: 37.27 GiB
      ID-6: /dev/sdf vendor: Kingston model: SV300S37A120G size: 111.79 GiB
      Partition:
      ID-1: / size: 85.96 GiB used: 9.94 GiB (11.6%) fs: ext4 dev: /dev/sdf1
      ID-2: /home size: 21.41 GiB used: 4.45 GiB (20.8%) fs: ext4 dev: /dev/sdf3
      Swap:
      ID-1: swap-1 type: partition size: 2.02 GiB used: 0 KiB (0.0%) dev: /dev/sdf2
      Sensors:
      System Temperatures: cpu: 43.0 C mobo: N/A gpu: nouveau temp: 41.0 C
      Fan Speeds (RPM): N/A
      Info:
      Processes: 286 Uptime: 1h 37m Memory: 15.58 GiB used: 1.15 GiB (7.4%)
      Init: runit runlevel: 2 Compilers: gcc: 10.2.1 Packages: 1869 Shell: Bash
      v: 5.1.4 inxi: 3.3.06
      =================================================================================

      My .conkyrc-file (with some comments removed):

      # set to yes if you want Conky to be forked in the background
      background yes

      short_units yes

      cpu_avg_samples 1
      net_avg_samples 1

      out_to_console no

      # X font when Xft is disabled, you can pick one with program xfontsel
      #font 7×12
      #font 6×10
      #font 7×13
      font 8×12
      #font 7×12
      #font *mintsmild.se*
      #font -*-*-*-*-*-*-34-*-*-*-*-*-*-*
      #font -artwiz-snap-normal-r-normal-*-*-100-*-*-p-*-iso8859-1

      # Use Xft?
      use_xft yes

      # Xft font when Xft is enabled
      #xftfont gentium:size=12
      #ftfont DejaVu Sans:size=10
      xftfont DejaVu Sans:bold:size=9
      #xftfont DejaVu Sans:size=9

      # Create own window instead of using desktop (required in nautilus, pcmanfm and rox desktops)
      own_window no
      own_window_transparent yes
      own_window_hints undecorated,sticky,skip_taskbar

      # Text alpha when using Xft
      xftalpha 1.0

      #on_bottom no

      # mail spool
      mail_spool $MAIL

      # Update interval in seconds
      update_interval 1

      # Use double buffering (reduces flicker, may not work for everyone)
      double_buffer yes

      # Minimum size of text area
      minimum_size 5 5
      maximum_width 180

      # Draw shades?
      draw_shades no

      # Draw outlines?
      draw_outline no

      # Draw borders around text
      draw_borders no

      # Stippled borders?
      stippled_borders 0

      # border margins
      #border_margin 10

      # border width
      border_width 2

      # Default colors and also border colors
      default_color white
      default_shade_color white
      default_outline_color white

      color2 ffffff
      color3 ff0000
      color4 yellow
      color8 0044aa
      color9 2266cc

      # Text alignment, other possible values are commented
      alignment top_left
      #alignment top_right
      #alignment bottom_left
      #alignment bottom_right

      # Gap between borders of screen and text
      gap_x 10
      gap_y 30

      # Add spaces to keep things from moving about? This only affects certain objects.
      use_spacer right

      # Subtract file system buffers from used memory?
      no_buffers yes

      # if_up_strictness link: up | link | address
      if_up_strictness address

      # set to yes if you want all text to be in uppercase
      uppercase no

      # boinc (seti) dir
      # seti_dir /opt/seti

      # Possible variables to be used:
      #
      # Variable Arguments Description
      # acpiacadapter ACPI ac adapter state.
      # acpifan ACPI fan state
      # acpitemp ACPI temperature.
      # adt746xcpu CPU temperature from therm_adt746x
      # adt746xfan Fan speed from therm_adt746x
      # battery (num) Remaining capasity in ACPI or APM
      # battery. ACPI battery number can be
      # given as argument (default is BAT0).
      # buffers Amount of memory buffered
      # cached Amount of memory cached
      # color (color) Change drawing color to color
      # cpu CPU usage in percents
      # cpubar (height) Bar that shows CPU usage, height is
      # bar’s height in pixels
      # downspeed net Download speed in kilobytes
      # downspeedf net Download speed in kilobytes with one
      # decimal
      # exec shell command Executes a shell command and displays
      # the output in torsmo. warning: this
      # takes a lot more resources than other
      # variables. I’d recommend coding wanted
      # behaviour in C and posting a patch :-).
      # execi interval, shell Same as exec but with specific interval.
      # command Interval can’t be less than
      # update_interval in configuration.
      # fs_bar (height), (fs) Bar that shows how much space is used on
      # a file system. height is the height in
      # pixels. fs is any file on that file
      # system.
      # fs_free (fs) Free space on a file system available
      # for users.
      # fs_free_perc (fs) Free percentage of space on a file
      # system available for users.
      # fs_size (fs) File system size
      # fs_used (fs) File system used space
      # hr (height) Horizontal line, height is the height in
      # pixels
      # i2c (dev), type, n I2C sensor from sysfs (Linux 2.6). dev
      # may be omitted if you have only one I2C
      # device. type is either in (or vol)
      # meaning voltage, fan meaning fan or temp
      # meaning temperature. n is number of the
      # sensor. See /sys/bus/i2c/devices/ on
      # your local computer.
      # kernel Kernel version
      # loadavg (1), (2), (3) System load average, 1 is for past 1
      # minute, 2 for past 5 minutes and 3 for
      # past 15 minutes.
      # machine Machine, i686 for example
      # mails Mail count in mail spool. You can use
      # program like fetchmail to get mails from
      # some server using your favourite
      # protocol. See also new_mails.
      # mem Amount of memory in use
      # membar (height) Bar that shows amount of memory in use
      # memmax Total amount of memory
      # memperc Percentage of memory in use
      # new_mails Unread mail count in mail spool.
      # nodename Hostname
      # outlinecolor (color) Change outline color
      # pre_exec shell command Executes a shell command one time before
      # torsmo displays anything and puts output
      # as text.
      # processes Total processes (sleeping and running)
      # running_processes Running processes (not sleeping),
      # requires Linux 2.6
      # shadecolor (color) Change shading color
      # stippled_hr (space), Stippled (dashed) horizontal line
      # (height)
      # swapbar (height) Bar that shows amount of swap in use
      # swap Amount of swap in use
      # swapmax Total amount of swap
      # swapperc Percentage of swap in use
      # sysname System name, Linux for example
      # time (format) Local time, see man strftime to get more
      # information about format
      # totaldown net Total download, overflows at 4 GB on
      # Linux with 32-bit arch and there doesn’t
      # seem to be a way to know how many times
      # it has already done that before torsmo
      # has started.
      # totalup net Total upload, this one too, may overflow
      # updates Number of updates (for debugging)
      # upspeed net Upload speed in kilobytes
      # upspeedf net Upload speed in kilobytes with one
      # decimal
      # uptime Uptime
      # uptime_short Uptime in a shorter format
      #
      # seti_prog Seti@home current progress
      # seti_progbar (height) Seti@home current progress bar
      # seti_credit Seti@hoome total user credit

      ## antiX additives examples. Add below Text##
      ##Battery examples##
      ##${color}battery: ${color}$acpiacadapter, ${battery_percent BAT1}%
      ##${color}battery:${color} ${battery}
      #${color}ACPI Battery: ${color}$battery
      #${battery_bar 11,0}
      ##Wireless example##
      #${color}Wireless:
      #${color}essid: ${wireless_essid wlan0}
      #${color}IP:${color} ${addr wlan0}
      #${color}speed: ${color} ${wireless_bitrate wlan0}
      #${color}link strength: ${color} ${wireless_link_bar 7,50 wlan0}

      # stuff after ‘TEXT’ will be formatted on screen

      TEXT
      ${color}${alignc}antiX
      ${color3}$alignc${font DejaVu Sans:size=12}${time %I:%M} $font
      ${color3}${alignc}${time %a %d %b}
      ${color}${alignc}${exec disp=${DISPLAY#:}; disp=${disp%.[0-9]}; cat $HOME/.desktop-session/desktop-code.$disp 2>/dev/null}
      ${color}${alignc}${execi 60 xdpyinfo | sed -n -r “s/^\s*dimensions:.*\s([0-9]+x[0-9]+).*/\1/p”}
      ${color}${alignc}$kernel
      ${color}${alignc}Uptime: $uptime

      ${color}CPU:${alignr}${color}${cpu}${color}%
      ${color}Freq:${color}${alignr}${freq}
      ${color}$alignr${cpugraph cpu0 30, 170 888888 2266cc}
      ${color}Disk:${alignr}${color}${diskio}
      ${color}${alignr}${diskiograph 30,170 888888 2266cc}
      ${if_up eth0}${color}eth0 up: $alignr${color} ${upspeed eth0}
      ${color}$alignr${upspeedgraph eth0 30,170 888888 2266cc}
      ${color}eth1 down: $alignr${color3} ${downspeed eth0}
      ${color2}$alignr${downspeedgraph eth0 30,170 888888 2266cc}${endif}
      ${if_up wlan0}${color}wlan0 up: $alignr${color} ${upspeed wlan0}
      ${color2}$alignr${upspeedgraph wlan0 30,170 888888 2266cc}
      ${color}wlan0 down: $alignr${color} ${downspeed wlan0}
      ${color}$alignr${downspeedgraph wlan0 30,170 888888 2266cc}${endif}

      ${color}${alignr}${color3}Used / Total
      ${color}RAM:${alignr}${color3}$mem ${color3} /${color3} $memmax
      ${color}Swap:${alignr}${color3}$swap ${color3} /${color3} $swapmax
      ${color}/ Disk:${alignr}${color3}${fs_used /} ${color3} /${color3} ${fs_size /}
      ${color3}${alignc}${execi 1000 persist-enabled}
      ${execi 1000 acpi 2>/dev/null | grep -q . && echo “Batt: “}${execi 10 acpi -b 2>/dev/null | cut -d” ” -f3,4 | sed ‘s/,$//’}

      ===========================================================================================================================

      My fluxbox ‘startup’ file:

      # fluxbox startup-script:
      #
      # Lines starting with a ‘#’ are ignored.

      # You can set your favourite wallpaper here if you don’t want
      # to do it from your style.
      # fbsetbg -l
      #
      # This sets a black background
      # /usr/bin/fbsetroot -solid black

      # This shows the fluxbox-splash-screen
      # fbsetbg -C /usr/share/fluxbox/splash.jpg

      # Other examples. Check man xset for details.
      # Turn off beeps:
      # xset -b
      # Increase the keyboard repeat-rate:
      # xset r rate 195 35
      # Your own fonts-dir:
      # xset +fp ~/.font
      #
      # Your favourite mouse cursor:
      # xsetroot -cursor_name right_ptr
      #
      # Change your keymap:
      # xmodmap ~/.Xmodmap

      # Eigen aanvullingen Startup apps
      # paneltoggle.sh
      rox –top=PANEL
      xmodmap -e ‘pointer = 3 2 1’
      fbxkb &
      volumeicon &

      # And last but not least we start fluxbox.
      # Because it is the last app you have to run it with ”exec” before it.

      # exec /usr/bin/fluxbox
      # or if you want to keep a log:
      exec /usr/bin/fluxbox -log ~/.fluxbox/log

      =========================================================================

      #71274
      Member
      Xecure

        (1) The new login screen doesn’t let you go back to the ‘username’ field after you press enter.

        Write the password or hit enter and you will go back to the username screen. If you don’t like the current login theme, change it with Control Centre > Session > Login Manager.

        (6) Fluxbox-minimal session.

        It has been stated many times in this forum that the minimal sessions are not meant to be used for normal use, and only for debuging and testing.
        If you want to disable options in desktop-session, edit ~/.desktop-session/desktop-session.conf, where you can disable conky, desktop-session startup, etc.
        In minimal- sessions, fluxbox startup WILL NOT WORK. If it worked before it was because of a bug that was fixed a few months ago in desktop-session.
        The connman issue may be a race problem related to how runit starts services in parallel. As you disabled connman, I will not comment anymore on possible solutions.

        The synaptics issue, I cannot reproduce. Synaptics is there in my fluxbox applications menu.

        antiX Live system enthusiast.
        General Live Boot Parameters for antiX.

        #71279
        Member
        PPC

          About your second point- Connman – I’ve been blessed that, it always worked for me, but I think there’s some procedure that’s advisable to do if you have problems connecting to the network after instalation… (I may have to hunt down those instructions, just in case…)

          (4) Synaptic is absent from the fluxbox menu.- may be some random bug- try updating the menu – it’s generated from the .desktop files available in /usr/share/applications, if it’t there, it should appear in the menu

          (5) Conky. I use fluxbox as window manager, with a different wallpaper for each desktop. – yep, I did that also, in MXFB, I helped wrote the GUI script that sets the different wallpapers- it worked fine in antiX, I don’t recall problems with Conky (but, then again, I rarely use Conky)

          (6)- min desktops – Xecure is right, I also use min desktops in antiX 19- I’ll have to do as Xecure advises, when I permantly switch to 21- it makes sense- if it’s 100% minimal, it loads NOTHING at all, at system startup, except the system itself and no startup files whatsoever…

          #71354
          Member
          dirkd

            @Xecure: Thanks for pointing me to Login Manager configuration. Should have found out myself maybe. I like the login screen a lot better now.

            In regard to minimal-fluxbox session: I’m perfectly happy with the normal fluxbox session, but I didn’t know about the purpose of the ‘minimal’ variety. I still think ‘minimal’ shouldn’t overwrite configuration files without warning. I was very confused noticing the erratic behaviour of fluxbox, and didn’t know at first what had happened.

            I also found Synaptic in the ‘Preferences’ section of the fluxbox menu. Simply overlooked the entry, since I never expected to find it there. I only wish I understood more about how the dynamic part of the fluxbox menu is constructed. I always thought I could send an application to any section of the menu I wanted, just by editing the .desktop file, but it seems it’s more complicated then that. I’m no expert in these matters, far from it, but I like to learn a little about what happens behind the scenes.

            @PPC: could you point me to an explanation of the method you used in MXFB? Maybe it’s simpler then what I use, without side effects on Conky. My method lets fluxbox react to the ChangeWorkSpace event, by adding a command in the ‘keys’ configuration file, activating the fbsetbg command.

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.