FTP for new antiX user

Forum Forums New users New Users and General Questions FTP for new antiX user

Tagged: 

  • This topic has 10 replies, 6 voices, and was last updated Jul 25-10:13 pm by Brian Masinick.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #7384
    Member
    JoeR

    Hello, I am new to antiX so please be gentle. My goal is to FTP into my antiX machine (local LAN) to save some files on a large hard drive. I prefer to use FTP because I can see the speeds and if any transfers have failed.

    my antiX setup:
    – antiX-17_386-full.iso running on a Dell dimension 2400 (installed and runs just fine) need to be 32bit for this old girl.
    – reserved 192.168.0.134 for antiX machine and I can ssh in just fine
    – Ethernet connected to LAN

    other machine that holds the files
    – acer Win 10 home laptop
    – wifi connected
    I tried to FTP using Filezilla but i get the response that the 192.168.0.134 refused the connection. What settings do i need to make on antiX to make the connection?

    many thanks

    #7387
    Forum Admin
    rokytnji
    Helpful
    Up
    0

    Howdy and Welcome. Post an out put from terminal in next post of

    inxi -Fxzr

    so members can see your install and repos. For settings. Check out run with doplhin channel on you tube or use search on youtube. AntiX Samba.

    • This reply was modified 3 years, 6 months ago by rokytnji.
    • This reply was modified 3 years, 6 months ago by rokytnji.

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    I'm not outa place. I'm from outer space.

    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #7393
    Member
    JoeR
    Helpful
    Up
    0

    output from the command inxi -Fxzr

    see file

    for some strange reason the forum would not allow me to put the output text directly in the reply window, i would get a forbidden error when i tried.

    • This reply was modified 3 years, 6 months ago by JoeR.
    • This reply was modified 3 years, 6 months ago by JoeR.
    Attachments:
    #7418
    Member
    skidoo
    Helpful
    Up
    0

    forum would not allow me to put the output text directly in the reply window, i would get a forbidden error

    Yep, it’s an ongoing “known issue” due to an overly-strict automated “spam” filter.
    A couple topics in SiteHelp subforum contain tips (reports of specific things/words that we’ve discovered which trigger the spamfilter)
    https://www.antixforum.com/forums/forum/administration/site-help/

    #7421
    Forum Admin
    rokytnji
    Helpful
    Up
    0

    you’re covered. Hell. I’m admin and I have to whitelist this action again for me because I am here on my other chromebook.

    $ sudo inxi -Fxzr
    System:    Host: antix1 Kernel: 4.10.5-antix.1-486-smp i686 bits: 32 gcc: 6.3.0 Console: tty 1
               Distro: antiX-17_386-full Heather Heyer 24 October 2017
    Machine:   Device: desktop System: Dell product: Dimension 2400 serial: <filter>
               Mobo: Dell model: 0F5949 v: A01 serial: <filter> BIOS: Dell v: A05 date: 12/02/2003
    CPU:       Single core Intel Celeron (-UP-) arch: Netburst Willamette rev.9 cache: 128 KB
               flags: (pae sse sse2) bmips: 4784 speed: 2392 MHz (max)
    Graphics:  Card: Intel 82845G/GL[Brookdale-G]/GE Integrated Graphics Device bus-ID: 00:02.0
               Display Server: X.org 1.19.2 drivers: intel (unloaded: modesetting,fbdev,vesa)
               tty size: 137x41 Advanced Data: N/A for root out of X
    Audio:     Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
               driver: snd_intel8x0 ports: ee00 edc0 bus-ID: 00:1f.5
               Sound: Advanced Linux Sound Architecture v: k4.10.5-antix.1-486-smp
    Network:   Card: Broadcom Limited BCM4401 100Base-T driver: b44 v: 2.0 bus-ID: 01:09.0
               IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
    Drives:    HDD Total Size: 480.1GB (5.9% used)
               ID-1: /dev/sda model: ST380011A size: 80.0GB
               ID-2: /dev/sdb model: ST3400832A size: 400.1GB
    Partition: ID-1: / size: 71G used: 4.8G (8%) fs: ext4 dev: /dev/sda1
               ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
    Sensors:   None detected - is lm-sensors installed and configured?
    Repos:     Active apt sources in file: /etc/apt/sources.list.d/antix.list
               deb http://repo.antixlinux.com/stretch stretch main nosystemd
               Active apt sources in file: /etc/apt/sources.list.d/debian-stable-updates.list
               deb http://ftp.ca.debian.org/debian/ stretch-updates main contrib non-free
               Active apt sources in file: /etc/apt/sources.list.d/debian.list
               deb http://ftp.ca.debian.org/debian/ stretch main contrib non-free
               deb http://security.debian.org/ stretch/updates main contrib non-free
    Info:      Processes: 146 Uptime: 12:36 Memory: 140.3/747.7MB Init: SysVinit runlevel: 5 Gcc sys: 6.3.0
               Client: Shell (sudo) inxi: 2.3.54
    

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    I'm not outa place. I'm from outer space.

    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #7425
    Member
    skidoo
    Helpful
    Up
    1

    vsftpd (Very Secure FTP Daemon) is a lightweight FTP server.

    to install vsftpd:
    sudo apt-get update
    sudo apt-get install vsftpd

    The installer immediately starts the vsftpd server, listening on TCP port 21.
    As a post-installation step, I recommend manually calling
    sudo service vsftpd stop
    and don’t restart the vsftpd service until you have tweaked its configuration options.

    to configure vsftpd:
    (beforehand, make a backup copy of the pristine conf)
    sudo cp /etc/vsftpd.conf /etc/vsftpd.conf_ORIG
    Use leafpad, or other text editor, to edit the configuration file:
    gksu leafpad /etc/vsftpd.conf

    To learn about ALL available configuration options, you can man vsftpd.conf
    In the meantime, the following changes to the default, as-shipped, configuration parameters will get you up-and-running:

    listen=YES
    listen_ipv6=NO
    local_enable=YES
    (refers to users in /etc/passwd , i.e. user accounts on the same machine the vsftpd server is running on)
    write_enable=YES (this line is outcommented by default)
    idle_session_timeout=9999 (default is 600)
    #ascii_upload_enable=YES (your call, uncomment if desired/needed)
    #ascii_download_enable=YES (your call, uncomment if desired/needed)
    chroot_local_user=NO (your call, you decide)
    #utf8_filesystem=YES (your call, uncomment if desired/needed)

    After editing /etc/vsftpd.conf, save the file and exit text editor, then start the vsftpd service (aka daemon):
    sudo service vsftpd start
    and you can immediately log into your vsftp server

    =================

    followup considerations:

    If you find that you’re unable to connect, check whether firewall service is running: sudo ufw status
    Until you configure suitable firewall rules, you may need to “sudo service ufw stop”
    in order to connect to the vsftpd server.

    (optional, but recommended) “apt-get install install fail2ban”, read the manpage, then configure and enable it.

    After stopping the vsftpd service, if you run the “htop” command and notice any still-running vsftpd processes
    you can “sudo killall vsftpd” to get rid of them. (I don’t know why the lingering processes sometimes occur, but they do.)

    Can use the vsftpwho to check whoall is currently connected to the vsftpd server.
    If you do, undertand that it’s normal to find one connection listed which is attributed to “root”.
    (misleading, and is a potential cause of worry.)

    If you search/read any additional online vsftpd tutorials, ignore any references to “systemctl” (systemd service manager)

    #7475
    Member
    JoeR
    Helpful
    Up
    0

    Hi Skidoo, Thank you for the excellent instructions and hints on how to properly configure vsftpd! I did just what you said and the FileZilla is humming away perfectly! Thank you for taking the time to write such an excellent & comprehensive set of instructions.
    Joe

    #63332
    Member
    agalloway
    Helpful
    Up
    0

    Unable to open port 21 for FTP.

    Setup:
    I have a remote location running a web cam server. I had an old homebrew AMD64 PC running Windows 7 that I had set up and everything worked well. The web server used nginx and I had five cameras on the web site page. I had Filezilla FTP Server running and was able to FTP the server to upload and download files from a couple of off site Pcs. (Linux Ubuntu desktop with Fillzilla Client and a Windows 8 laptop with Core FTP LE Client)
    A couple of weeks ago we had a heavy wet spring snow storm which caused massive power outages. Three days later with power restored I booted the server and it went to boot repair. Long story short, the HDD was flaky and dying. So I bought a Optiplex 2070 and began rebuilding the server.

    The server is in a remote location with cable ISP to MODEM, cat5 to a Linksys EA2700 running DD-WRT, and cat5 to the server. The server is a Dell Optiplex 7020 running a fresh load of Windows 7 Pro and updates. (Thanks to Windows Seven on how to do the updates). Web software is nginx 1.17.10 and is running well. I can use Remote Desktop to connect to the server from my Ubuntu desktop and the Windows 8 laptop. The router has Port Forward set for the web server, Remote Desktop, and a web cam wired through a router port.

    Here is the problem:
    I am unable to connect to the server using FTP.
    I have scoured the net for three days trying to find out why I can not connect with no luck.
    I have tried:
    Forwarded router ports 21, 990, 50000 – 51000.
    FTP with and without TLS.
    Set access through Windows firewall – no luck.
    Disabled Windows firewall – no luck.
    Verified clients OK by FTP to other sites.
    Verified FTP and Filezilla are enabled in Widows firewall advanced settings.
    Checked open ports with “Canyouseeme.org”, ports show open for Web and Desktop, port 21 FAILS.
    Deleted and reinstalled Flezilla.
    Tried different FTP and loaded Quick&EasyFTP.

    Example of Client error:
    note – port xxx21 is forwarded to port 21 on the server.
    Resolving xxxxxx.xxxxxx.com…
    Connect socket #1172 to xxx.xxx.xxx.169, port xxx21…
    Can’t establish connection –> xxxxxx.xxxxxx.com:xxx21 @ Wed May 06 14:04:56 2020 (0-5)
    Connection Failed

    Tried telnet to the server on port 21 and it also fails.

    Is there something simple I overlooked?
    Any help would be appreciated.

    #63566
    Member
    seaken64
    Helpful
    Up
    0

    @agalloway,

    We may be able to help you. But you’ve buried your question in an old topic. It’s generally not a good idea to tack your own question onto the end of an existing topic, especially an old one.

    You might get some help by re-posting to a new topic started by you. And please share your system info with us with “inxi -Fxz”.

    Seaken64

    #63580
    Moderator
    Brian Masinick
    Helpful
    Up
    0

    As suggested, you may be best to enter a new post. Have you, by any chance, looked into more recent alternatives to the classic FTP client? There are clients with SSL, including SFTP that may be worth investigating.

    Try searching for FTP alternatives.

    Brian Masinick

    #63581
    Moderator
    Brian Masinick
Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.