Getting the zram script to work (Solved)

Forum Forums Official Releases antiX-17 “Heather Heyer” Getting the zram script to work (Solved)

This topic contains 0 replies, has 1 voice, and was last updated by melodie Oct 24-1:45 pm.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #28511
    Member
    melodie
    melodie

    Hello,

    I’ll explain perhaps more than needed, I just want to make sure the context is taken in account, and that what will follow could also get to be tested in a regular antiX edition. (Be it the version 17 or the next one available now, 19).

    I have tried several ways to get zram to be loaded and working in the respins I did with Openbox (an Openbox recipe used in several distributions, at home and among the foss communities, goal : to be utmost easy for the common user while as light as possible, well, still using gtk3 and co). My goal in getting antiX as a basis for this recipe is to obviously be able to have the same recipe, but on machines much older than I used to deal with. (ie: a Dell D610 which can take 2 GB RAM max, and would not boot anything else than a regular CD … tried MX, didn’t work, tried the full antiX didn’t work either, even used Plop to boot from USB, didn’t work, didn’t test PXE as I don’t have a PXE server nor enough free time to learn how to setup one).

    Now to my point : I have tried installing the zram* package from repos, didn’t work, tried to get zram from the /usr/local/bin directory **the way it is explained in the zram comments**, it didn’t work. Here I enclose 2 screenshots.

    What worked:

    I added
    /usr/local/bin/zram start

    in /etc/rc.local, before the line “exit 0” and rebooted. This worked! And it kept working after reboot, so I thought I’d come to tell about it.

    • This topic was modified 2 weeks, 6 days ago by melodie. Reason: get to be notified
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.