grub confignuration file moved?

Forum Forums Official Releases antiX-17 “Heather Heyer” grub confignuration file moved?

This topic contains 2 replies, has 2 voices, and was last updated by stevesr0 Sep 8-6:18 pm.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26925
    Member
    Avatar
    stevesr0

    I performed a number of updates just now and a message popped up warning me that the grub configuration file would be moved to /var/temp/…. from /etc/default/grub if I accepted the maintainer’s version.

    I am NOT going to accept it, because I don’t know why it is being moved.

    Any reason for this shift? (and should I do it?)

    This is the maintainer’s file.

    # If you change this file, run ‘update-grub’ afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n ‘Simple configuration’

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
    GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash video=SVIDEO-1:d”
    GRUB_CMDLINE_LINUX=””

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)
    #GRUB_BADRAM=”0x01234567,0xfefefefe,0x89abcdef,0xefefefef”

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo’
    #GRUB_GFXMODE=640×480

    # Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY=”true”

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE=”480 440 1″

    The current version in /etc/default/grub differs in twoways.

    1. The GRUB_DISABLE_RECOVERY line is uncommented, and the maintainer’s version left this commented out. I imagine this affects the grub menu at boot.

    2. The current version has two additional lines at the end:

    GRUB_DISABLE_OS_PROBER=false
    GRUB_BACKGROUND=/usr/share/wallpaper/back.jpg

    Thanks.

    stevesr0

    • This topic was modified 1 week, 4 days ago by stevesr0.
    #26928
    Forum Admin
    anticapitalista
    anticapitalista

    The maintainer in this case is Debian (antiX does not package grub) and users should stick to the default reply which is ‘No’.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #26930
    Member
    Avatar
    stevesr0

    Thanks.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.