Hello – ACPI issue solved

Forum Forums New users Welcome to antiX Hello – ACPI issue solved

Tagged: 

  • This topic has 6 replies, 6 voices, and was last updated Apr 23-5:44 pm by j0ta.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #126713
    Member
    jl62

      Hello, just in case it might be useful to anyone: a few weeks ago I installed Antix 32 bit on a HP Mini 210. It originally came with Windows 7, then I upgraded to Windows8 (long time ago), but it was so slow that the Mini Notebook couldn’t be used. I decided to reuse the unit, giving Antix a try. At the beginning, initial attempts to install were unsuccessful due to a buggy BIOS. So I tried the acpi=off, which allowed me to proceed.

      After some experience with Antix, I realized that the HP Mini 210 has a 64 bit CPU, so I installed the 64 bit version, without formatting the hard-disk so as not to lose the data at /home

      Unfortunately, disabling ACPI created a few problems such as: lack of battery usage control, not being able to put it into suspend mode, etc. The HP MINI has a bothersome problem: it doesn’t come back to life easily after shutdown, so it is more convenient to put it into suspend mode. Getting it to boot meant going through a complicated procedure: removing the battery, connecting to the AC, and then pressing Windows key+B. After many attempts, some magic, and lots of luck, the screen might come back alive.

      Anyway, I became curious and tried some other ACPI parameters, as shown in this page: https://wiki.ubuntu.com/DebuggingACPI
      The relevant text is:

      “If “acpi=off” allows the system to boot, try to isolate the ACPI issue with the following boot parameters
      • Try booting with “acpi=ht”
      ◦ This disables all of ACPI except just enough to enable Hyper Threading. If acpi=off works and acpi=ht fails, then the issue is in the ACPI table parsing code itself, or perhaps the SMP code.
      • Try booting with “pci=noacpi”
      ◦ This disables ACPI for IRQ routing and PCI scanning.
      • Try booting with “acpi=noirq”
      ◦ This disables ACPI for IRQ routing.
      • Try booting with “pnpacpi=off”
      ◦ This disables the ACPI component of the Linux Plug and Play code.
      • Try booting with “noapic”
      ◦ Disables the IO-APIC for IRQ routing or PCI scanning.
      • Try booting with “nolapic”
      ◦ Disables the local APIC. “

      After several attempts at boot time (pressing e and editing the boot parameters) the option nolapic proved successful and at last Antix booted normally.

      Next, I edited /etc/default/grub adding the line: GRUB_CMDLINE_LINUX=”nolapic”. I regenerated and reinstalled grub and now the main ACPI options work smoothly.

      Thanks to the Antix team for making this possible.

      JL

      #126714
      Forum Admin
      anticapitalista

        Thank YOU for posting the fix.

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #126715
        Member
        marcelocripe

          Hello jl62.

          Welcome to antiX Linux and the Forum.

          I don’t know how to write in English and I send my texts translated by the internet translator. I hope you can understand everything. If your native language is not English, please translate my original Brazilian Portuguese text directly into your language with the help of internet translators and you will get a much better result.

          Please read my real welcome in the Welcome to antiX Linux and the forum (antiX 23) and Welcome to antiX Linux and the forum (antiX 19, 21 and 22) thread.

          marcelocripe
          (Original text in Brazilian Portuguese language)

          – – – – –

          Olá, jl62.

          Seja bem-vindo(a) ao antiX Linux e ao fórum.

          Eu não sei escrever em idioma Inglês e envio os meus textos traduzidos pelo tradutor da internet. Eu espero que você consiga compreender tudo. Se o seu idioma nativo não for o Inglês, por favor, traduza o meu texto original em Português no Brasil diretamente para o seu idioma com a ajuda dos tradutores da internet que você obterá um resultado muito melhor.
          Por favor, leia a minha verdadeira boas-vindas no tópico Seja bem-vindo (a) ao antiX Linux e ao fórum (antiX 23) e Seja bem-vindo (a) ao antiX Linux e ao fórum (antiX 19, 21 e 22).

          marcelocripe
          (Texto original em idioma Português do Brasil)

          #126716
          Member
          techore

            @jl62, nice and thank you for sharing your discovery and solution.

            #127259
            Member
            entropyagent

              This looks very interesting, thanks. I am hoping to incorporate it into my attempt to avoid “acpi=off” on a “new” (to me) MSI laptop, currently sporting Windows XP.

              #127364
              Member
              jl62

                Wish you best of luck!. It’s amazing how antiX makes old and supposedly unusable hardware come back to life and regular use.

                I’m so far very happy with antiX on my HP Mini 210 and on another relatively old Lenovo laptop which previously had Ubuntu installed (it goes without saying, antiX is way faster).

                #140224
                Member
                j0ta

                  Thanks that solved my recent boot problem !
                  Now this old laptop boots at first and not randomly

                  ​🇱​​🇮​​🇧​​🇷​​🇪​​🇧​​🇴​​🇴​​🇹​ ​🇺​​🇸​​🇪​​🇷​
                  ​🇦​​🇳​​🇹​​🇮​​🇽​ ​ 🇺​​🇸​​🇪​​🇷​
                  ​🇱​​🇮​​🇧​​🇷​​🇪​​🇼​​🇴​​🇱​​🇫​ ​🇺​​🇸​​🇪​​🇷​
                  ​🇳​​🇴​​🇸​​🇾​​🇸​​🇹​​🇪​​🇲​​🇩​ ​🇺​​🇸​​🇪​​🇷​

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.