Hello world! – But how to get (wlan)-online?

Forum Forums New users Welcome to antiX Hello world! – But how to get (wlan)-online?

  • This topic has 16 replies, 7 voices, and was last updated Oct 2-2:51 pm by Brian Masinick.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #40742
    Member
    kawe

    Hi to all,

    I am from Germany, a software developer for almost 20 years (mainly Java) and I am *not* an absolutely newcomer to Linux.
    In the 1990ies (;-)), I regularly used SuSE Linux.
    But over the years I finally moved completely back to MS, and I had to do so in my job.

    Last year, when I had to “upgrade” to Win10 I tried to convince my employer to let me turn to Linux.
    This failed, but I started to use Linux again in a VMM and on my old laptops at home (that won’t run with Win10 anyway).

    First I used Puppy Linux and Linux Mint, later a bit Zorin OS.
    But as I aim to have a max lightweight system at last, to get a fast, everyday usable system, I realized how overweight (or hard to maintain) many handy Linux distros got, and when I discovered Antix to be a real alternative, I have given it a try.

    Well done, :-)!
    I virtually don’t miss anything when I installed it in no time in a VirtualBox (there are some annoying issues in a multi-OS multi-monitor multi-resolution environment (config lost!?)) but nothing more to complain about, :-).

    ——————
    But when I went home and started the Antix (19.2.1 base, 32-bit) Live-CD in my old laptop(s), I got stuck in wlan troubles.
    I have no wired connection at home (however, I could maybe use an O2-Surfstick) and when I tried I couldn’t get a functional wlan connection in Antix, :-(.
    (No problems in Windows (XP, Vista, Win7, Win10) or in Linux Mint, Antix or Puppy, however.).

    First I had to learn there is no other setup tool in the live system but ceni (Wicd is completely missing and ConnMan is only available as connmanctl).

    I am not afraid using console applications and ceni is well designed concerning user guidance.
    but in the end, I cannot get the trick in getting a working wlan connection.

    I am able to see and connect to my WiFi (not always, that’s another story. Often I get “soft locked” and “hard locked” issues in Antix an I have to reset and reboot the whole system ….)
    But finally, I am able to enter the pass key and I am virtually connected an get my IP address and can even ping to another IP address (no matter what laptops I use, I’m afraid).

    In the end, I never get a working dns, a “connected symbol(?)” in the taskbar and therefore a working internet connection.

    It is hard to post diagnostic outputs when missing a functional connection, so I start this thread as a general newbie question first. Maybe I miss a very obvious point?

    And I have read the postings here about similiar troubles, but I can’t see the solution there, :-(.

    First:
    Will there be a difference if I used the full distro or an Antix 17 distro (other/more tools included)?

    I’d prefer to avoid this, but if this is the cure I’ll do so.
    ——————

    Thank you in advance

    Of course I’ll return posting the details manually if necessary (but this will take time as I am missing the direct connection at home).

    #40743
    Member
    Koo
    Helpful
    Up
    0
    :D

    Welcome kawe

    Have a look at this topic wifi not working

    I had trouble with my wifi not working and it had some thing to do with connman I do not know what connman is and I do not care. Maybe connman has been fixed not sure.

    But I have used ceni for years and it has never let me down. I used Xecure Re post #38949 on the link above and my troubles were over. I hope this can help you too.

    Control Centre > Network > Network Interfaces(Ceni)

    T430 i7-3632QM 16gb , antiX-19.2.1-runit_x64-base Hannie Schaft 29 March 2020 , 5.8.16-antix.1-amd64-smp

    #40744
    Member
    Xecure
    Helpful
    Up
    0
    :D

    A. wifi issues on antiX 19.2.1 base

    A. Use Connman
    If you want to use connman, delete the wifi information created by CENI in /etc/network/interfaces
    sudo geany /etc/network/interfaces
    It should look like this:

    #------------------------------------------------------------------------------
    # /etc/network/interfaces
    #
    # interfaces(5) file used by ifup(8) and ifdown(8)
    # Used by ceni but not by connman
    #------------------------------------------------------------------------------
    
    auto lo
    iface lo inet loopback
    

    Then try to connect using Connman

    B. Use ceni.
    You have to remove Connman completely and create a link for resolv.conf
    See anticapitalista’s answer:

    1. Remove connman and cmst

    sudo apt-get remove --purge connman connman-ui-gtk

    2. Delete the resolv.conf sym link in /etc/
    3. Create a new symlink in etc like this (in a terminal)

    sudo ln -s /etc/resolvconf/run/resolv.conf /etc/resolv.conf

    4. Try ceni again

    Launching connman (if not in the control centre): Open App Select. Search for connman. Select connman-ui-gtk
    A new icon will appear in taskbar. Right click and switch wifi ON.
    Hold left click on it and select the Wireless access.

    Next weekend I will make a video and upload it. This comes up too often.

    Will there be a difference if I used the full distro

    Full has more packages (libreoffice, bleutooth, etc.).

    or an Antix 17

    antiX 17 is based on stretch (Debian 9), the previous version of current Debian 10 (buster). It works as well but has not as new packages.

    • This reply was modified 10 months ago by Xecure.
    #40753
    Moderator
    Brian Masinick
    Helpful
    Up
    0
    :D

    Hopefully one of the tools that Xecure described very well will work out.

    In 95% or more of the cases, those solutions should work and they have ALWAYS worked for me personally.

    Just in case anyone else comes along with problems, I did a search and found at least 10 tools to connect to wireless networks in Linux:
    The first link shares TEN alternatives; the other links either repeat similar information or explain the alternatives from a slightly different viewpoint. I hope that this complements what Xecure provided, but I still recommend his solutions FIRST.

    See https://www.google.com/search?channel=tus2&client=firefox-b-1-d&q=linux+wifi+network+manager

    https://www.techrepublic.com/blog/10-things/10-tools-to-connect-to-wireless-networks-in-linux/

    https://www.linux.com/training-tutorials/how-configure-wireless-any-linux-desktop/

    https://www.blackmoreops.com/2014/09/18/connect-to-wifi-network-from-command-line-in-linux/

    Brian Masinick

    #40754
    Moderator
    Brian Masinick
    Helpful
    Up
    0
    :D

    I found another command line solution for those who prefer that kind of solution; again, for most people, the standard alternatives that Xecure has already documented are, in the overwhelming majority of cases, easier, well-supported and documented. But for the people who love to try different things, here’s another one:
    https://linuxconfig.org/connect-to-wifi-from-the-linux-command-line#h2-distributions

    Brian Masinick

    #40900
    Member
    seaken64
    Helpful
    Up
    0
    :D

    If I were in your situation (no wired internet) I would try turning off the security features temporarily to see if I could make a connection. Then, if successful, I would turn on the security features and try again. If you don’t have access to the router this may be difficult.

    I would also try a different wifi adapter, maybe a USB dongle.

    Good luck and welcome to antiX.

    Seaken64

    #40938
    Member
    gedisony
    Helpful
    Up
    0
    :D

    Antix 19.2.1

    I had a very similar problem with wifi.
    first it has something to do with wifi not being enabled. I forgot how i resolved it.
    something about being softlocked and i was able to unlock it/ I found the solution on a reddit post

    next issue is with DNS. I have to edit /etc/resolv.conf and add my pi hole dns server address.
    had to do this every time i restart because it gets overwritten.

    solution was posted above, i’m just repeating it here:

    uninstall connman
    sudo apt-get remove –purge connman

    Delete the resolv.conf sym link in /etc/

    Create a new symlink in etc like this (in a terminal)
    sudo ln -s /etc/resolvconf/run/resolv.conf /etc/resolv.conf

    #41077
    Member
    anti-ewaste
    Helpful
    Up
    0
    :D

    Completely tangential but after seeing this post I decided to set up pi hole here on my 3B, especially since I went ahead and gifted myself a 4B after receiving the former as a gift from a friend..

    • This reply was modified 9 months, 3 weeks ago by anti-ewaste.
    • This reply was modified 9 months, 3 weeks ago by anti-ewaste.
    #41358
    Member
    kawe
    Helpful
    Up
    0
    :D

    Sorry for my late reply. I was very busy the last weeks.
    And thanks to all. Finally, I am in, :-).

    The short answer (delete first either connman or ceni) is the truth, but there were more hurdles for a newbie:

    A. Use Connman
    If you want to use connman, delete the wifi information created by CENI in /etc/network/interfaces

    First, it might be a problem to try to get online by the live-CD.
    There are no ceni wifi information if you clean boot from CD.
    However, I did not manage to completely connect to my wifi that way.
    Everything seems to be ok, but then connman complains about DHCPPOFFERS.

    B. Use ceni.
    You have to remove Connman completely and create a link for resolv.conf
    See anticapitalista’s answer:

    anticapitalista wrote:

    1. Remove connman and cmst

    sudo apt-get remove –purge connman connman-ui-gtk

    2. Delete the resolv.conf sym link in /etc/
    3. Create a new symlink in etc like this (in a terminal)

    btw: connman-ui-gtk is not installed on base (live) distro.

    Anyway, it did *not* work for days (straight after a clean live CD boot).
    Always a similar problem: Wifi is found, ceni tries to connect and fails.

    But suddenly, when I had more than 20 minutes time and tried it more often, it worked, :-).

    I installed Antix to hdd then and I’ve got an absolutely stable wifi connection now using ceni.

    The only thing that is not so obvious is how to reconnect to a given config after the next reboot.

    I use

    sudo /etc/init.d/networking start

    now. Let me know if there is a more elegant way to do so (manually).

    Concerning my question about differences to the full distro and Antix 17:

    I meant this question related to this wifi problem.

    e.g. Antix 17 seems to have wicd bundled, and a gtk interface of connman is not available at least in the base distro at first.

    The information on the Antix-FAQ (e.g. https://download.tuxfamily.org/antix/docs-antiX-19/FAQ/net.html) might be a little bit outdated if you start with Antix 1*9* and are therefore sometimes confusing for a newbie.

    Thank you all for your help. I am *very* happy with Antix, :-).

    Some more minor questions appeared in the meanwhile, but first I try to solve them myself.

    • This reply was modified 9 months, 2 weeks ago by kawe.
    • This reply was modified 9 months, 2 weeks ago by kawe.
    • This reply was modified 9 months, 2 weeks ago by kawe. Reason: typos
    #41366
    Moderator
    Brian Masinick
    Helpful
    Up
    0
    :D

    @kawe: You caught a good one! Wicd used to be one of the default network management programs. It hasn’t been actively maintained so the development team replaced it.
    Ceni is really an executable “script”, not an executable image, so it has been retained, and it is in our smallest net and Core images, I believe it is the default for them. Connman is the network manager for our images that are “large enough” to include it.

    Brian Masinick

    #41369
    Member
    Xecure
    Helpful
    Up
    0
    :D

    If I have time this weekend I will try finishing the bash script to help easily transition between ceni and connman. It is a simple “network-switch”, that needs a very simple interface (I want to try to make it work in cli and gui).
    I started working on this some time ago when building the welcome screen, and after my experience with finding connman problems, I think I can build a reliable switch.

    The only thing that is not so obvious is how to reconnect to a given config after the next reboot.

    I use sudo /etc/init.d/networking start

    I checked antiX 17, and the service “networking” is configured exactly in the same way. Maybe it is interrupted by some other service, or maybe it starts too soon. I will see if I can test things out during the weekend and figure out if the ceni configuration doesn’t autostart on each antiX flavor.

    #41371
    Moderator
    Brian Masinick
    Helpful
    Up
    0
    :D

    If I have time this weekend I will try finishing the bash script to help easily transition between ceni and connman. It is a simple “network-switch”, that needs a very simple interface (I want to try to make it work in cli and gui).
    I started working on this some time ago when building the welcome screen, and after my experience with finding connman problems, I think I can build a reliable switch.

    The only thing that is not so obvious is how to reconnect to a given config after the next reboot.

    I use sudo /etc/init.d/networking start

    I checked antiX 17, and the service “networking” is configured exactly in the same way. Maybe it is interrupted by some other service, or maybe it starts too soon. I will see if I can test things out during the weekend and figure out if the ceni configuration doesn’t autostart on each antiX flavor.

    I look forward to seeing this tool and examining how it works.

    Brian Masinick

    #42083
    Member
    kawe
    Helpful
    Up
    0
    :D

    If I have time this weekend I will try finishing the bash script to help easily transition between ceni and connman. It is a simple “network-switch”, that needs a very simple interface (I want to try to make it work in cli and gui).
    I started working on this some time ago when building the welcome screen, and after my experience with finding connman problems, I think I can build a reliable switch.

    The only thing that is not so obvious is how to reconnect to a given config after the next reboot.

    I use sudo /etc/init.d/networking start

    I checked antiX 17, and the service “networking” is configured exactly in the same way. Maybe it is interrupted by some other service, or maybe it starts too soon. I will see if I can test things out during the weekend and figure out if the ceni configuration doesn’t autostart on each antiX flavor.

    I look forward to seeing this tool and examining how it works.

    In fact wlan seems to have been started after reboot, but is not functional at first (DHCP issues).
    And therefore (correction) I have to stop it first and then restart it manually.
    How would I try and delay the autostart?

    #42098
    Member
    Xecure
    Helpful
    Up
    0
    :D

    Two options.

    1: Change wlan configuration in /etc/netowrk/interfaces from allow-hotplug to auto. It could look like:
    auto wlan0
    And see if this helps fix the aouto connect at boot with ceni.

    2. Reinstall connman and connman-ui and test out this script to “switch” to connman.
    Once configured, see if connman autoconnects to the internet after rebooting.
    If you don’t know how connman works, watch this video:
    https://www.youtube.com/watch?v=b5Ryp4gM2Eg&feature=emb_title

    #42477
    Member
    kawe
    Helpful
    Up
    0
    :D

    Thank you very much for your hints.

    1: Change wlan configuration in /etc/netowrk/interfaces from allow-hotplug to auto. It could look like:
    auto wlan0

    You are right, this configuration works as expected. wlan0 is correctly activated and initialized at boot time.
    However, this is not always what you want. If the connection is not available while booting the system hangs for a considerable time.
    So one would expect “allow-hotplug” would fill the gap and connect if (and only if) available, wouldn’t one?

    I noticed that my main problems described above derives from the fact “allow-hotplug” will establish a kind of connection but this is not working in the end (due to DHCP failure).

    My personal solution here is again quick and (beginner’s) easy:

    I removed the “allow-hotplug/auto wlan0” line completely from /etc/network/interfaces and start wlan0 on demand using “sudo ifup wlan0” that is *now* working as expected at once.

    Manually starting/stopping a wlan conncetions has more advantages than disadvantages to me anyway.

    Concerning Connman: I will try it later when my system is running as desired (or as close as possible to this). But there is no need to for me straight now.

    • This reply was modified 8 months, 3 weeks ago by kawe.
Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.