help installing at 2 ssds netbook

Forum Forums Official Releases antiX-17 “Heather Heyer” help installing at 2 ssds netbook

This topic contains 4 replies, has 3 voices, and was last updated by cerdicola Feb 5-7:55 pm.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18436
    Member
    Avatar
    cerdicola

    Hi everyone,

    Trying to install antix 17.3.1 on an asus eeepc901.
    This little 2011 netbook has two ssd inside, first one sda 4Gb and second 16Gb, after I chose sbd as / point of install home and boot too, I have problem/bug:

    Installing grub, the installer only give me 2 options: Sdb where once I reboot computer woulnd’t find it, or sdc wich is the usb live stick I am using to install. Sda where I want to install grub as MBR don’t appear.

    As I saw This will be a huge problem after first boot, I tried to format as ext4 the sda with gparted, and install again, and sda appear but only at where to install system part, once I arrived to grub install sda is not present.

    I neither managed to install the grub from terminal…

    #18437
    Member
    caprea
    caprea

    Have you already tried the cli-installer ?
    Also you always should update the installer during live-session before installation.

    I wonder if maybe this is a problem with the 4gb size of the sda, it’s maybe somehow filtered out by the installer because the minimum size is 4gb for antiX-installation.
    You can look here, if this helps.
    https://forum.mxlinux.org/viewtopic.php?f=40&t=47569

    #18438
    Member
    Avatar
    cerdicola

    Hola Hi caprea,
    I has just see the video and It says that the cli-installer grub part is bugged too, as install it yes or yes after ask for it.

    My problem is not having a 4Gb SSD and another with16Gb. The problem is that the installer don’t let you choose where to install the grub, just choose the same place you have choosen previously to install the system.

    Anyway I am now trying to install antix using the cli-installer terminal way from the live usb now.

    EDITED AFTER CHECKED IT:
    Same bug at terminal install with cli-installer, It asks: Do you want to install grub at MBR? It would not be at root… And then instead of use MBR of first device, it installed the grub at the second device (sdb) where the BIOS dont look every time the computer boots.

    Also 1 more bug, even the cli-intsller is translated into spanish language the answers are not, So if It asks yes or no (S / n)you have to answer in english with y or n.

    • This reply was modified 2 months, 2 weeks ago by cerdicola.
    • This reply was modified 2 months, 2 weeks ago by cerdicola.
    • This reply was modified 2 months, 2 weeks ago by cerdicola.
    #18451
    Member
    noClue
    noClue

    asus eeepc901 … netbook has two ssd inside, first one sda 4Gb and second 16Gb

    We get 2 problems here. The first problem is Asus, very well renown for often ‘going their own way’, to say it polite. The second problem is, you have exactly none SSD and you don’t have an HDD neither. You have some sort of ‘better SD card in a special card reader’ to say it easy way. eMMC is not SSD.

    On your place, I’d make myself extra work to probably save myself a lot of time on trying and fiddling around.

    YUMI can make you (under Windows) a multi-boot pen key (USB drive). Put Gparted (standalone), DBAN, Clonezilla, antiX and Linux Mint XFCE on it first.

    1. Fully overwrite your both ‘SSD’s (with 0 is a standard way, if you know how to, you could do it with 1 too, to reduce wearing) in DBAN.

    2. Initialize both ‘SSD’s with DOS/MBR in Gparted.

    3. Create partitions and format them with Gparted:
    For sda 4 GB:
    1. 1 GB /boot (EXT2)
    2. 2 GB /swap (SWAP)
    For sdb 16 GB:
    3. 8 ~ 10 GB /root (EXT4)
    4. 8 ~ 10 GB /home (XFS)
    During install, choose NOT to format them — you already did it.

    4. Install antiX first and see what gives this time — if you can put the Grub on sda or not.
    Or, install Linux Mint first to test if it will let you choose sda for Grub (it should).
    Which install to try first you must decide. No risk — no fun. 😉
    However, if one install fails, repeat the steps 1 ~ 3 before making another try.

    5. Clonezilla for the backups whenever you want — before you start, after you’ve done it or in between …

    That should actually work.

    If it fails, there could be another (complicated) thing to try: use LVM, merge 2 ‘SSD’s in 1 (one) single volume and try installing with /boot, /root, /home and /swap all in one (merged LVM) partition. Theoretically, there is only one option left for installer (sda), to install the boot loader in one and only drive that it can find, since there’s only one (LVM merged) volume and that way Grub should land on a right place automatically.

    However, I didn’t try to do it in practice, so I can’t tell how the installers would interpret the existence of only one single drive and partition, consisting of two physical drives.

    https://unix.stackexchange.com/questions/329790/how-to-merge-multiple-hard-drives/329791

    How strange is to be anything at all. (Alice in Wonderland)

    #18467
    Member
    Avatar
    cerdicola

    caprea and noClue thanks for your help.
    I tried one or two more times choosing /boot at sda with the hope that that will do the trick and make installer can see sda later. It did not worked.

    So, I am giving an opportunity to manjaro32.

    ¡Muchas gracias por la ayuda y el interés!, thanks a lot for your help and interest!

    See you on the ocean penguins!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.