HELP: New antiX installation refuses to open programs until I change desktop

Forum Forums General Software HELP: New antiX installation refuses to open programs until I change desktop

  • This topic has 21 replies, 8 voices, and was last updated Jan 30-5:14 pm by Brian Masinick.
Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #98309
    Member
    PPC

      Hi!

      I’ve been using antiX for about 7 years, at it never stops surprising me. Most of the time, for being so amazing, sometimes for the wrong reasons:

      -Situation: my work desktop pc was replaced with a “Dell Optiplex 780” with a “newish” spining drive ov over 300Gb (from my previous desktop). antiX 21 Live 64 bits booted fine and I installed antiX to a a partition (I used the same live pen-drive, to install the system in 2 other computers, without any problem). Install went fine, I choose to “auto” login.
      -since the first boot from the installed system, no application would run from the menu, not even the terminal. The menu works fine, just does not start any program… but it allows me to choose another desktop- so I jumped from icewm to zzz-icem– and it works fine, after getting this strange window:

      Title of the window: "YAD",
       Text:
        "Window Manager not found to be running after 20 checks.
         Currently the desktop environment will not start :P
         Give Up Time:"(it displays a random number, probably miliseconds that went by before I switched desktops)

      After a reboot, the same situation- nothing works from the menu, until I change desktops again.
      I installed ft10 and enabled it – restarted and, jgmenu does not even get launched, when I click the Ft10’s menu (it’s an external program)

      I tried booting from icewm, zzzicewm, fluxbox, jwm and the problem remains. I can only open anything after I switch desktops

      Solutions I tried:
      – I downloaded, burned and installed antiX 22, 64bits, Full. Booted from the modern kernel and reinstalled, choose auto login, rox-icewm, did not change any default: same problem after restart

      -Tried both available kernels in antiX 21 and 22: same problem

      -Updated the system, restarted: same problem after restart

      I removed autologin and rebooted: guess what- I have to enter my password, and antiX sends me back to the login screen. If I enter my password, then I get a usable desktop, but I do have to go though the login screen twice! Very strange!

      Any guesses/ solution?

      I attached the inxi of this computer.

      P.

      • This topic was modified 1 year, 2 months ago by PPC.
      Attachments:
      #98314
      Member
      calciumsodium

        I used the same live pen-drive, to install the system in 2 other computers, without any problem

        Maybe first reformat the hard drive again and reinstall again since the USB works on other computers?

        #98318
        Moderator
        Brian Masinick

          I noticed in the inxi.txt listing that you are using /dev/sda7 for this particular system.

          That indirectly implies that there are quite a few different partitions somewhere on this drive or they’ve been renumbered.

          Because of this, it makes me wonder if the hexadecimal digits that point to this partition and this file system are correct or incorrect and if parts of your system are getting confused with something else that’s physically on this system.

          It’s really hard to see exactly what this may be because the inxi output only describes this configuration, not everything on that drive.

          I suggest poking around in the messages that are created with each system; not sure that dmesg will give you the answer or not, but dig into your various logs in the /var directory tree and see if anything weird or unexpected shows up. That may give you a better clue of what’s actually happening here because it certainly is unusual.

          System logs are your friend when nothing else makes sense. Even without understanding 100% of what they say, MAYBE something will jump out at you that will eventually lead to a solution to your problem.

          --
          Brian Masinick

          #98321
          Moderator
          BobC

            Maybe the install drive didn’t get formatted first?

            #98322
            Member
            PPC

              Hi, thanks for the input, everyone. The one piece of info I did not provide (I didn’t think it was relevant):

              -This drive had only 2 partitions:one ntfs with another OS and a ext4 one, with my previous antiX install that refuses to boot on this computer. Since gparted errored out trying to format the ntfs partition, I created a 24G empty space on the old antix partition and installed to the space, formated (twice, once in each install, in BTRFS).
              So this drive currently has 3 partitions: 5- the ntfs; 6- rootantiX19, in Exf4 and 7- rootantiX22 in BRTFS

              P.

              #98323
              Moderator
              Brian Masinick

                Do you have backups of any of this stuff?

                What would happen if you use the ENTIRE disk for your antiX installation – is that possible?

                I’m thinking if you can somehow SAVE the stuff from your other antiX19 environment, maybe you can just use one partition for the software and possibly another one for swap, and that’s it. If you have a way to save what’s there, or if you already have something saved, try that and see if it helps.

                If not, I’m also suspicious about the drive itself. Maybe it’s getting quite a few bad blocks. Check that possibility too and work around it if necessary.

                --
                Brian Masinick

                #98326
                Moderator
                Brian Masinick

                  In the meantime, can you run antiX from the live image? Maybe use this disk only to save a frugal or other form of persistence.
                  Since you’re having problems, you may have to try a variety of things before you stumble on what works.
                  I still think those logs, as long as you didn’t disable them, ought to tell a story of what’s happening.

                  --
                  Brian Masinick

                  #98327
                  Member
                  PPC

                    What I tried:

                    -I formated the ntfs partition to ext4 and installed antiX 22 to it, using the older kernel (I formated the partition when I first installed antiX 21 and then 22, from btrfs to ext4 and used it as “home”).
                    Install was fast. This time I selected no auto login- at first boot, problem was solved. Curious, I went to Control Panel > Session and choose The option (the icon with the user name and password) to configure slimski for autologin (an enable numlock). Rebooted- I had the original problem again.

                    -So I disabled autologin again and rebooted- again, I have to go through 2 login screens, in order to be able to use the system (the second one comes up right after the first one)

                    #98331
                    Member
                    calciumsodium

                      I was curious if you manually change the entry in the file /etc/slimski.local.conf

                      to
                      autologin_enabled false

                      if you still get the two login screens.

                      And then change it back to

                      autologin_enabled true

                      if the problem would be fixed or if the problem is repeated?

                      #98358
                      Member
                      sybok

                        Hi,
                        1) As Brian suggested, is there some more information in logs, e.g. ‘~/.desktop-session/log[.old]’ would be my first try.
                        2) Please configure some keyboard shortcuts (e.g. to open terminal etc.) – do they work well?

                        The computer seems a bit older, judging from the CPU:
                        3) How about installing ‘xserver-xorg-legacy’ if not installed (because someone proposed it somewhere else in the forum…)?
                        4) Would you care for trying an older kernel, e.g. 4.19?

                        5) Do minimal versions of desktops reproduce the same error?

                        #98372
                        Member
                        PPC

                          Hi

                          I can’t make sense of the log files, I attach them bellow, in zipped archives…

                          When the problem happens, the only keyboard shortcut that I know- printscreen does not work

                          Minimal version of icewm had the same exact problem, I just tested it.

                          I would install anything, kernel or package, to try to solve this, but I think it’s related to slimski…

                          New info: editing /etc/slimski.local.conf and making my username the default one, and rebooting did, in fact make my username appear as default user, but also triggered the double appearing login window! If I remove that line and reboot, then it’s back to “normal”, if I enter my username and password, antiX seems to log me in without any problem.

                          Editing that file manually to enable autologin causes the problem, editing that change out restores antiX to “normal” (I have to enter my username and password to log in to a normal working system).

                          Edit: in fact, enabling autologin by itself, on the config file does nothing… I tested- withou selecting a default user in the config file, slimski always asks for username/password and logs me in correctly.
                          Conclusion: on this computer, slimski seems to have some kind of problem with selecting a default user name- that causes the problem even without autologin!

                          I just installed and tested with the xorg package indicated above. No change in the problem. I don’t expect this can also be a Kernel problem, but I’ll try to test that too…

                          P.

                          P.

                          • This reply was modified 1 year, 2 months ago by PPC.
                          #98385
                          Member
                          PPC

                            I just tested installing and booting to kernel 4.19lts – same problem

                            I forgot to reply about this: I don’t see how this problem can be related to partitions, but I can’t copy the many hundreds of GB of files I have on my initial antiX 19 partition anywhere else but to another partition on this disk- I do have several backups, on one external drive and on big pen drive, but it would be almost impossible to set it up right as I had on my antiX 19 setup, without a huge amount of work. So I can’t install to the entire drive, on this device.

                            Edit: I forgot- as suggested, I checked out the drive’s health, with gnome-disk-utility and it’s fine.

                            @anticapitalista – to me, this is just an annoying bug, but if this happens in a computer with a user that has poor tech skills and does not know what it’s user even are, then, unfortunately, this could prompt that user away from antiX for good.
                            I hope that this is not like the bug with the localization of the first layer of the menu, reported only once, and then some users started reporting it…
                            I think most single user desktops probably have autologin turned on (unless users don’t even know about tha feature, and miss it in the install process).

                            P.

                            • This reply was modified 1 year, 2 months ago by PPC.
                            #98386
                            Member
                            sybok

                              I recall it was advised to reinstall some package (‘desktop-session-antix’?) in case of problems with desktop-session or copy the default settings from ‘/etc/skel/’ (?) over the current ones.

                              I once tested Kali linux and their undercover Windows-10 like mode of XFCE4. It failed to switch back and cleaning cache solved it; not sure if there is any equivalent to it [desktop-session cache file/folder] in antiX.

                              BTW, the old log dated 19-22 reports a syntax error in ‘/usr/local/bin/ft10_tint2_manager.sh’, line 60. I do not have it installed on the current system, hence I cannot comment on it.

                              PS: I have auto-login enabled in one of my (virtual) antiX-21 or antiX-22 stable-repositories machines, it log me into fluxbox and shortcuts work without problems.

                              #98388
                              Member
                              PPC

                                Thanks for the pointer: I reinstalled desktop-session-antix, rebooted, manually edited the config file to set my default username, rebooted- same problem- I have to go trough the login screen twice.

                                I don’t know if I said this, but between the first and the second login screens I do see the console, with some lines, but I can’t read what it says, because it’s only on screen for about 1 second…

                                #98399
                                Member
                                sybok

                                  Double login screen – this sounds like a screensaver is initiated and it locks the screen immediately.

                                  Reminds me of the old thread https://www.antixforum.com/forums/topic/login-failure-slim-all-fluxboxes-but-minimal/ where I messed up one of the configuration files and I was unable to log into a working session.

                                Viewing 15 posts - 1 through 15 (of 22 total)
                                • You must be logged in to reply to this topic.