Help with antiX 21 live-USB Persistence Cups Autostart [Solved]

Forum Forums New users New Users and General Questions Help with antiX 21 live-USB Persistence Cups Autostart [Solved]

  • This topic has 10 replies, 4 voices, and was last updated May 31-12:57 am by rej.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #107929
    Member
    rej

      Hi-

      The internal antiX 21, installed on a hard drive, starts cups automatically – is there a way to make cups autostart on the live-USB?

      Thank you.

      #107931
      Member
      abc-nix

        See which boot parameters are being used by the live system. If you find any “disable=XX” options, remove them. The disable option prevents services from starting up to speed up startup and make the system run lighter.

        After removing these options, if CUPS still does not start automatically, enable the service. If using runit, you can do this from the runit service manager (enable auto-start). If using sysvinit, this command should work:
        sudo update-rc.d cups defaults

        #107990
        Member
        rej

          bc-nix-

          Thanks for your reply.

          The file is default and does not appear to have any “disable=XX” options.

          Hopefully, I am looking at the correct file information from the Boot Parameters link.

          * edit: code stopped before the end of the file contents because of a [‘] in the text.

          etc/default/grub:

          # If you change this file, run 'update-grub' afterwards to update
          # /boot/grub/grub.cfg.
          # For full documentation of the options in this file, see:
          #   info -f grub -n 'Simple configuration'
          GRUB_DEFAULT=0
          GRUB_TIMEOUT=5
          GRUB_DISTRIBUTOR=<code>grep PRETTY_NAME /etc/lsb-release | cut -d= -f2 | cut -d\&quot; -f2 2> /dev/null || echo Debian</code>
          GRUB_CMDLINE_LINUX_DEFAULT="quiet"
          GRUB_CMDLINE_LINUX=""
          # Uncomment to enable BadRAM filtering, modify to suit your needs
          # This works with Linux (no patch required) and with any kernel that obtains
          # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
          #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
          # Uncomment to disable graphical terminal (grub-pc only)
          #GRUB_TERMINAL=console
          # The resolution used on graphical terminal
          # note that you can use only modes which your graphic card supports via VBE
          # you can see them in real GRUB with the command 

          vbeinfo’
          #GRUB_GFXMODE=640×480

          # Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux
          #GRUB_DISABLE_LINUX_UUID=true

          # Uncomment to disable generation of recovery mode menu entries
          GRUB_DISABLE_RECOVERY=”true”

          # Uncomment to get a beep at grub start
          #GRUB_INIT_TUNE=”480 440 1″

          GRUB_DISABLE_OS_PROBER=false
          GRUB_BACKGROUND=/usr/share/wallpaper/grub/back.png `

          • This reply was modified 1 year ago by rej.
          • This reply was modified 1 year ago by rej.
          #108010
          Moderator
          caprea

            On a bios-boot you should see the line with disable=lxm on boot screen
            on a uefi-boot you have to press the e-key on the first boot screen of the live usb

            On the screen that you then see go to the line that starts with linux.(with the up and down keys)
            Search in that line for the disable=lxm
            Deleting the L should be enough to let the cups service autostart.

            sudo service cups start
            should start the service, if the above doesn’t work for you.

            #108020
            Member
            rej

              Caprea-

              Thank you for your help!

              If I am looking in the right place in booting the Live-USB persistence, BIOS “Boot Options” (nothing that starts with “Linux”), the only line that is close to disable=lxm is: “quiet splasht disable=lxF”

              “sudo service cups start” is what I have been starting it with – is there a way to make that command start automatically?

              #108021
              Member
              abc-nix

                Regarding your previous question on how to start CUPS automatically upon boot, you can use the following command:
                sudo update-rc.d cups defaults
                This will add a script to the startup sequence, ensuring that CUPS starts up every time your live system boots.

                In addition, I would like to clarify that the section in the Antix Wiki I linked to that you should focus on is “LIVE or FRUGAL install“, and not the “local install” you referenced. This section provides instructions on how to change boot parameters temporarily or permanently for a live or frugal antiX system. Please refer to this section for more detailed information.

                #108041
                Moderator
                caprea

                  Yes, you are right, Rej, the line is disable=lxF
                  Delete the l from this line. Afterwards press the F8 button and set it to “save”

                  The cups service should now be activated. On the next boot of the live stick there will appear a “custom boot”
                  with your saved settings on top of the other options as default.

                  Afaik, this only applies to antiX versions with sysvinit, the disable=lxF has no effect on a runit version.(Someone please correct this if I am wrong)

                  #108072
                  Member
                  abc-nix

                    Afaik, this only applies to antiX versions with sysvinit, the disable=lxF has no effect on a runit version.(Someone please correct this if I am wrong)

                    Hi, caprea. My apologies for going off-topic here. After examining the antiX Live init scripts located at [GitLab], I found that it is possible to disable RunIt services in much the same way as SysVInit services are disabled. This means that the method should still be effective even when using an antiX live system based on RunIt.

                    Regards.

                    • This reply was modified 1 year ago by abc-nix. Reason: Reorganize
                    #108080
                    Forum Admin
                    anticapitalista

                      On antiX-23-runit running live, removing disable=lxF will not automatically start cups since it is not enabled on the iso.
                      The only runit services enabled when running live are:

                      connman
                      dbus
                      getty-tty1
                      getty-tty2
                      getty-tty3
                      seatd
                      slimski
                      udevd

                      Services included on live medium, but not enabled (antiX-full)

                      acpid
                      acpi-support
                      anacron
                      avahi-daemon
                      bluetooth
                      chrony
                      cron
                      cups
                      dhclient
                      getty-hvc0
                      getty-tty4
                      getty-tty5
                      getty-tty6
                      getty-ttyS0
                      getty-ttyv0
                      gpm
                      haveged
                      rpcbind
                      rsync
                      ssh
                      ufw

                      Philosophers have interpreted the world in many ways; the point is to change it.

                      antiX with runit - leaner and meaner.

                      #108088
                      Moderator
                      caprea

                        Thank you for going a little deeper here with further explanations and insights on how things are around runit on antiX, anticapitalista and also abc-nix.

                        #108123
                        Member
                        rej

                          abc-nix-

                          Thanks for the suggestion – “sudo update-rc.d cups defaults” did not allow the printer to run.

                          I am re-visting the “Boot Parameters” – Thanks again.
                          ______________________________________
                          anticapitalista-

                          Thank you for the runit information.
                          ______________________________________
                          caprea-

                          Thank you very much – deleting the “l” starts the printer automatically now!

                          There is no option to mark it “Solved”, or I would.

                        Viewing 11 posts - 1 through 11 (of 11 total)
                        • You must be logged in to reply to this topic.